none
Exchange 2016 新建接收连接器 RRS feed

  • 问题

  • 各位好!

          我在Exchange 2016 新建接收连接器;

    角色:前端传输

    安全性:仅勾选匿名

    端口:10025

    在范围,远程网络设置设置了某个IP段时,即使ip在该网段的计算机,也无法telnet通端口,提示“421 4.3.2 Service not available  遗失对主机的连接。”

    当把范围填写为0.0.0.0-255.255.255.255时,可以正常telnet。

    测试Exchange 版本:Exchange 2016 CU5   和Exchange 2016 CU8

    请问这是什么原因导致?

    2018年7月15日 12:05

全部回复

  • 你创建的接收连接器并选择的可能是Hub传输角色而不是接收连接器的前端传输角色造成的,检查一下
    2018年7月16日 1:41
  • 您好,

    从您的描述看,当把IP地址段设置为所有的时候,能够telnet成功,说明端口和网络都没有问题。

    但是,当把IP指定为一个固定范围的时候,无法Telnet成功,那么说明您监听的IP地址段的范围有问题。请检查创建连接的电脑所对应的公网IP地址是否正确。

    关于创建自定义的接收连接器,你查看这一篇文章:https://docs.microsoft.com/en-us/exchange/mail-flow/connectors/custom-receive-connectors 

    此致,

    敬礼

    Kyle Xu


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    点击了解更多,或者访问我们的专用论坛,与我们的技术专家一起分享探索 Microsoft Teams.

    2018年7月16日 6:53
    版主
  • 您好!

         非常感谢您的回复!

          我创建的连接器类型是“FrontedTransport”,不是HubTransport。

    2018年7月16日 7:37
  • 您好!

         非常感谢您的答复!

          我添加了服务器自己本身的IP和测试客户端IP,都是内网IP,经测试是会存在这个问题。

    2018年7月16日 7:39
  • 请问,有谁可以帮忙解决这个问题么?
    2018年7月24日 9:23
  • 您好,我经过测试,也有这样的问题,请问怎么检查呢?谢谢!
    2018年7月24日 9:35
  • 您好,

    很抱歉之前漏掉了这一个问题的通知,现在正在环境中进行测试。会尽快给您回复。

    此致,

    敬礼

    Kyle Xu


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    点击了解更多,或者访问我们的专用论坛,与我们的技术专家一起分享探索 Microsoft Teams.

    2018年7月24日 9:38
    版主
  • 您好,

    我在Exchange 2016 CU 7~CU10中都测试过,并没出现和您相同的情况:

    以下是我的在CU8中的测试截图:

    在客户端Telnet服务器10025端口的结果:

    此致,

    敬礼

    Kyle Xu


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    点击了解更多,或者访问我们的专用论坛,与我们的技术专家一起分享探索 Microsoft Teams.

    2018年7月25日 6:11
    版主
  • Kyle Xu

          非常感谢您的答复!

          我主要到了您的Exchange 使用的是英文版?我用的Exchange 2016是中文版,有没可能是中文的BUG?

    2018年7月28日 14:44
  • 您好,

    如果可以的话,请使用以下命令获取服务器上的连接器配置,并和您的测试流程一起发送到这一个邮箱(ibsexc@microsoft.com)中,我尝试在环境中使用相同的步骤,看是否会出现和您相同的问题。

    Get-ReceiveConnector | fl >>c:/temp/setting.txt

    此致,

    敬礼

    Kyle Xu


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    点击了解更多,或者访问我们的专用论坛,与我们的技术专家一起分享探索 Microsoft Teams.

    2018年8月7日 9:53
    版主
  • Kyle.Xu

           很高兴看到你的回复!

           我确认我的操作没有问题,步骤跟你截图一致。

    我怀疑会不会跟F5有关?我记得好像使用F5的话,如果配置不当,会把所有源IP信息都变成F5的设备IP。所以才会出现,我限定了客户端IP范围,Telnet就出现异常,地址范围填所有的话又恢复正常,可能就是因为Exchange识别到的所有源IP信息都是F5设备地址了。很久之前听人分享过这个问题,好像要把F5配置为NAT 的透传模式,并且把Exchange 服务器的网关指向F5?

          所以我有以下问题:

    1、我如何确定Exchange 识别到的源地址是正确的?我记得好像可以查日志信息?查哪个日志信息呢?

    2、F5的正确配置方式是怎样的?我刚提到的只是我模糊的记忆,不一定准确。

    2018年8月15日 7:02
  • Hi Kyle

          请问有新的消息么?不知你是否了解我所述的内容?

    2018年8月29日 3:12
  • 您好,

    我们并不能使用和测试三方工具,所以我们无法确保三方工具的使用以及安全性,如果您认为有问题,您可以尝试移除F5,或者直接Telnet指定的CAS服务器而不是指定F5的IP,您也可以尝试从一台CAS服务器来Telnet另一台CAS服务器。

    此致,

    敬礼

    Kyle Xu


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    点击了解更多,或者访问我们的专用论坛,与我们的技术专家一起分享探索 Microsoft Teams.

    2018年8月29日 5:39
    版主