none
在hyper-vr2中安装了ubuntu11.10,在本地服务器上能够使用鼠标控制ubuntu虚拟机,但是使用远程桌面则无法在ubuntu虚拟机中使用鼠标,为什么?谢谢! RRS feed

  • 问题

  • 在hyper-vr2中安装了ubuntu11.10,在本地服务器上能够使用鼠标控制ubuntu虚拟机,但是使用远程桌面则无法在ubuntu虚拟机中使用鼠标,为什么?谢谢!
    2011年11月11日 5:19

答案

全部回复

  • 您好!

    为了进一步帮助您解决该问题,请检查系统日志和应用程序日志,把错误相关事件的具体信息以及错误截图贴到论坛中来,包括事件ID、事件类型和事件描述。

     

    谢谢您的配合。


    如果您对我们的论坛在线支持服务有任何的意见或建议,请通过邮件告诉我们。
    Description: Description: TechNet 论坛好帮手立刻免费下载  TechNet 论坛好帮手

    2011年11月11日 9:36
    版主
  • 日志名称:          System

     

    来源:            storvsp

    日期:            2011/11/15 7:49:48

    事件 ID:         6

    任务类别:          无

    级别:            警告

    关键字:           经典

    用户:            暂缺

    计算机:           server1

    描述:

    “ubuntu11-32”中的存储设备已加载,但与服务器的版本不同。服务器版本为 4.2,客户端版本为 2.0 (虚拟机 ID 6019A877-A29A-486E-A82E-E1F997004B64)。设备可工作,但此配置不受支持。这意味着此问题未解决之前,将无法提供技术支持。若要解决此问题,请升级集成服务。若要升级,请连接到虚拟机,然后选择“操作”菜单中的“插入集成服务安装磁盘”。

    事件 Xml:

    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

      <System>

        <Provider Name="storvsp" />

        <EventID Qualifiers="32774">6</EventID>

        <Level>3</Level>

        <Task>0</Task>

        <Keywords>0x80000000000000</Keywords>

        <TimeCreated SystemTime="2011-11-14T23:49:48.641359200Z" />

        <EventRecordID>85241</EventRecordID>

        <Channel>System</Channel>

        <Computer>server1</Computer>

        <Security />

      </System>

      <EventData>

        <Data>\Device\STORVSP</Data>

        <Data>ubuntu11-32</Data>

        <Data>6019A877-A29A-486E-A82E-E1F997004B64</Data>

        <Data>4.2</Data>

        <Data>2.0</Data>

        <Binary>00000000050030000000000006000680000000000000000000000000000000000000000000000000</Binary>

      </EventData>

    </Event>

     

     

     

     

    日志名称:          System

    来源:            VMSMP

    日期:            2011/11/15 7:49:48

    事件 ID:         27

    任务类别:          无

    级别:            警告

    关键字:           经典

    用户:            暂缺

    计算机:           server1

    描述:

    “ubuntu11-32”上的网络驱动程序已加载,但其版本与服务器的版本不同。服务器版本为 3.2,客户端版本为 0.2 (虚拟机 ID 6019A877-A29A-486E-A82E-E1F997004B64)。设备可工作,但此配置不受支持。这意味着此问题未解决之前,将无法提供技术支持。若要解决此问题,请升级集成服务。若要升级,请连接到虚拟机,然后选择“操作”菜单中的“插入集成服务安装磁盘”。

    事件 Xml:

    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

      <System>

        <Provider Name="VMSMP" />

        <EventID Qualifiers="32768">27</EventID>

        <Level>3</Level>

        <Task>0</Task>

        <Keywords>0x80000000000000</Keywords>

        <TimeCreated SystemTime="2011-11-14T23:49:48.641359200Z" />

        <EventRecordID>85240</EventRecordID>

        <Channel>System</Channel>

        <Computer>server1</Computer>

        <Security />

      </System>

      <EventData>

        <Data>

        </Data>

        <Data>0</Data>

        <Data>

        </Data>

        <Data>ubuntu11-32</Data>

        <Data>6019A877-A29A-486E-A82E-E1F997004B64</Data>

        <Data>3.2</Data>

        <Data>0.2</Data>

        <Binary>0000000007002C00000000001B000080000000000000000000000000000000000000000000000000</Binary>

      </EventData>

    </Event>

    谢谢!

     

    2011年11月15日 1:32
  • 你好,

     

    首先,在Hyper-V上,Ubuntu不是一个受支持的Linux系统。你可以在下面的链接里找到受支持的Linux系统。

     

    http://technet.microsoft.com/en-us/library/cc794868(WS.10).aspx

     

    其次,使用远程桌面则无法在Ubuntu虚拟机中使用鼠标是因为你没有安装Linux专用的Integration Services。如果是Windows系统没有装Integration Services也会出现同样的问题。

     

    你可以从下面的链接里下载Linux Integration Services

     

    Linux Integration Services Version 3.1 for Hyper-V

    http://www.microsoft.com/download/en/details.aspx?id=26837

     

    下面是一个MVP发布的安装向导,你可以作为参考。

     

    Simplified instructions for installing the Linux Integration Components into Hyper-V virtual machines

    http://social.technet.microsoft.com/Forums/en-US/winserverhyperv/thread/0d2c5fa8-682c-4f5d-9fe7-388dd80a7e06

    2011年11月21日 9:12
    版主