none
(求助!!!)邮箱迁移报错-从exchange2003到exchange2010 RRS feed

  • 问题

  • 环境如下:

    3台Windows2003 DC

    1台Exchange2003(Windows2003)

    1台Exchange2010 HUB&CAS

    1台Exchange2010 Mailbox

    -------------------------------------------------------------------------------------------------------------------------------

    在邮箱迁移时报错信息如下:

     

    Summary: 1 item(s). 0 succeeded, 1 failed.

    Elapsed time: 00:00:00

    t 1

    Failed

    Error:

    Mailbox database "SERVER05\第一个存储组\邮箱存储(SERVER05)" doesn't exist.

    Exchange Management Shell command attempted:

    'SMTL.COM/SMTL/ITD/t 1' | New-MoveRequest -TargetDatabase 'Mailbox Database 0423961493'

    Elapsed Time: 00:00:00

    -----------------------------------------------------------------------------------------------------------------------------------

    日志信息如下:

     

    Log Name:      Application

    Source:        MSExchange Configuration Cmdlet - Remote Management

    Date:          8/1/2011 9:48:25 PM

    Event ID:      4

    Task Category: General

    Level:         Error

    Keywords:      Classic

    User:          N/A

    Computer:      mailbox01.SMTL.COM

    Description:

    (PID 3960, Thread 10) Task New-MoveRequest writing error when processing record of index 0. Error: Microsoft.Exchange.Configuration.Tasks.ManagementObjectNotFoundException: Mailbox database "SERVER05\??????\????(SERVER05)" doesn't exist.

       at Microsoft.Exchange.Configuration.Tasks.DataAccessTask`1.GetDataObject[TObject](IIdentityParameter id, IConfigDataProvider session, ObjectId rootID, OptionalIdentityData optionalData, Nullable`1 notFoundError, Nullable`1 multipleFoundError)

       at Microsoft.Exchange.Configuration.Tasks.DataAccessTask`1.GetDataObject[TObject](IIdentityParameter id, IConfigDataProvider session, ObjectId rootID, Nullable`1 notFoundError, Nullable`1 multipleFoundError)

       at Microsoft.Exchange.Management.RecipientTasks.NewMoveRequest.LocateAndVerifyMdb(DatabaseIdParameter databaseId, Boolean isSourceDatabase, Int32& serverVersion)

       at Microsoft.Exchange.Management.RecipientTasks.NewMoveRequest.InternalValidate()

       at Microsoft.Exchange.Configuration.Tasks.Task.ProcessRecord()

    Event Xml:

    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

      <System>

        <Provider Name="MSExchange Configuration Cmdlet - Remote Management" />

        <EventID Qualifiers="49152">4</EventID>

        <Level>2</Level>

        <Task>1</Task>

        <Keywords>0x80000000000000</Keywords>

        <TimeCreated SystemTime="2011-08-02T04:48:25.000000000Z" />

        <EventRecordID>1206</EventRecordID>

        <Channel>Application</Channel>

        <Computer>mailbox01.SMTL.COM</Computer>

        <Security />

      </System>

      <EventData>

        <Data>3960</Data>

        <Data>10</Data>

        <Data>New-MoveRequest</Data>

        <Data>0</Data>

        <Data>Microsoft.Exchange.Configuration.Tasks.ManagementObjectNotFoundException: Mailbox database "SERVER05\??????\????(SERVER05)" doesn't exist.

       at Microsoft.Exchange.Configuration.Tasks.DataAccessTask`1.GetDataObject[TObject](IIdentityParameter id, IConfigDataProvider session, ObjectId rootID, OptionalIdentityData optionalData, Nullable`1 notFoundError, Nullable`1 multipleFoundError)

       at Microsoft.Exchange.Configuration.Tasks.DataAccessTask`1.GetDataObject[TObject](IIdentityParameter id, IConfigDataProvider session, ObjectId rootID, Nullable`1 notFoundError, Nullable`1 multipleFoundError)

       at Microsoft.Exchange.Management.RecipientTasks.NewMoveRequest.LocateAndVerifyMdb(DatabaseIdParameter databaseId, Boolean isSourceDatabase, Int32&amp; serverVersion)

       at Microsoft.Exchange.Management.RecipientTasks.NewMoveRequest.InternalValidate()

       at Microsoft.Exchange.Configuration.Tasks.Task.ProcessRecord()</Data>

        <Data>{d05123a5-f72e-46cf-9d62-5f012030231d}</Data>

      </EventData>

    </Event>

    ------------------------------------------------------------------------------------------------------------------------------------------------------------------

    请教各位该如何解决,谢谢!

     

     


    2011年8月2日 5:07

答案

  • 请做一下测试:

    1. 请确认权限;并尝试使用PowerShell进行迁移

    2.在Exchange 2003迁移到Exchange 2003是否成功?

    3.使用Exchange 2010 BPA的工具进行分析;

    2011年8月2日 15:19

全部回复