none
运行过Sysprep 之后,系统不能自动登录,并且LogonCommands 在手工登录之后也不能执行 RRS feed

  • 问题

  •  

    系统是:win7 64bit

     

     下面是我执行的 sysprep 命令和参数

     

    在下面是 Sysprep.xml 配置文件,文件中配置了 自动登录,但是每次重启之后都不能自动登录。登录的时候提示密码错误,手动登录进去之后,SysprepGUI模式会跳出来,也不会运行LogonCommands 指定的命令。

     

    Command:

    C:\windows\system32\sysprep\sysprep.exe /generalize /audit /rebooting /unattend:C:\windows\system32\sysprep\sysprep.xml
    

     

     

    sysprep.xml File:

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="specialize">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <WindowsFeatures>
                    <ShowMediaCenter>false</ShowMediaCenter>
                </WindowsFeatures>
                <BluetoothTaskbarIconEnabled>false</BluetoothTaskbarIconEnabled>
                <ComputerName>*</ComputerName>
                <CopyProfile>true</CopyProfile>
                <DoNotCleanTaskBar>false</DoNotCleanTaskBar>
                <TimeZone>China Standard Time</TimeZone>
            </component>
            <component name="Microsoft-Windows-Security-SPP-UX" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SkipAutoActivation>true</SkipAutoActivation>
            </component>
        </settings>
        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <AutoLogon>
                    <Password>
                        <Value>UwBvAGUARwBpAHMAMgAwADAANAAhAFAAYQBzAHMAdwBvAHIAZAA=</Value>
                        <PlainText>false</PlainText>
                    </Password>
                    <LogonCount>6</LogonCount>
                    <Username>Administrator</Username>
                    <Enabled>true</Enabled>
                </AutoLogon>
                <LogonCommands>
                    <AsynchronousCommand wcm:action="add">
                        <CommandLine>C:\Local\CFIE.EXE C:\Local\Post.ini /R /X</CommandLine>
                        <Description>CFIE</Description>
                        <Order>1</Order>
                    </AsynchronousCommand>
                </LogonCommands>
                <OOBE>
                    <HideEULAPage>true</HideEULAPage>
                    <NetworkLocation>Work</NetworkLocation>
                    <ProtectYourPC>1</ProtectYourPC>
                </OOBE>
                <UserAccounts>
                    <AdministratorPassword>
                        <Value>UwBvAGUARwBpAHMAMgAwADAANAAhAEEAZABtAGkAbgBpAHMAdAByAGEAdABvAHIAUABhAHMAcwB3AG8AcgBkAA==</Value>
                        <PlainText>false</PlainText>
                    </AdministratorPassword>
                    <LocalAccounts>
                        <LocalAccount wcm:action="add">
                            <Password>
                                <Value>UwBvAGUARwBpAHMAMgAwADAANAAhAFAAYQBzAHMAdwBvAHIAZAA=</Value>
                                <PlainText>false</PlainText>
                            </Password>
                            <Description>Local Administrator</Description>
                            <DisplayName>Administrator</DisplayName>
                            <Group>Administrators</Group>
                            <Name>Administrator</Name>
                        </LocalAccount>
                    </LocalAccounts>
                </UserAccounts>
                <VisualEffects>
                    <FontSmoothing>ClearType</FontSmoothing>
                </VisualEffects>
                <DisableAutoDaylightTimeSet>false</DisableAutoDaylightTimeSet>
                <TimeZone>China Standard Time</TimeZone>
                <Display>
                    <ColorDepth>32</ColorDepth>
                    <HorizontalResolution>1024</HorizontalResolution>
                    <RefreshRate>60</RefreshRate>
                    <VerticalResolution>768</VerticalResolution>
                </Display>
                <OEMInformation>
                    <SupportPhone>022-58213151</SupportPhone>
                    <SupportURL>ServiceDesk.PRC@UTC.COM</SupportURL>
                    <SupportHours>5x10</SupportHours>
                </OEMInformation>
                <WindowsFeatures>
                    <ShowMediaCenter>false</ShowMediaCenter>
                </WindowsFeatures>
            </component>
            <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <InputLocale>en-US</InputLocale>
                <SystemLocale>en-US</SystemLocale>
                <UILanguage>en-US</UILanguage>
                <UILanguageFallback>en-US</UILanguageFallback>
                <UserLocale>zh-CN</UserLocale>
            </component>
        </settings>
        <settings pass="generalize">
            <component name="Microsoft-Windows-Security-SPP" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SkipRearm>0</SkipRearm>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="catalog:c:/users/zhaohc/desktop/customwin7sp1office2010_win7 64bit sp1 office2010.clg" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>
    
    
     
    夏天
    2011年8月30日 15:03

全部回复

  • 我现在是要封装系统,并非不小心点错。。。
    夏天
    2011年8月31日 4:10
  • Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
    "AutoAdminlogon"="1"
    "DefaultUserName"="administrator"
    "DefaultPassword"=""
    2011年9月1日 10:39
  • 我是在做应答文件,不可能所有的工作都需要修改注册表,

    我是使用 Windows System Image Manager 生成的。


    夏天
    2011年9月5日 5:44
  • 在使用imagex 抓取操作系统镜像之前,如果系统有密码或者已经设置了默认登陆的话就会出现无法自动应答,因为sysprep之后是没有密码的,自动登录失败鸟

    当满足下列条件都为真时,会出现此问题:
    • 创建 Sysprep 工具的主映像的位置的计算机具有 DefaultPassword 注册表项位于下面的 Windows 注册表子项:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
    • 您可使用 AutoLogonCount 和 AdminPassword 应答文件选项用于安装。
    • 运行此部分中使用的主映像和描述的应答文件执行无人参与的安装,Windows Server 2003 的 Sysprep 工具。

    解决方案

    若要解决此问题,请从主计算机上的 Windows 注册表中删除 DefaultPassword 注册表项。通过使用 Sysprep 工具,然后重新创建该图像。为此请按照下列步骤操作将被用来创建主映像的基于 Windows Server 2003 的计算机上。

    警告 如果注册表编辑器使用不当,您可能会导致严重的问题,可能会要求您重新安装操作系统。Microsoft 不能保证可以解决问题所产生的错误地使用注册表编辑器。使用注册表编辑器需要您自担风险。
    1. 单击 开始、 单击 运行,键入 regedit,然后单击 确定
    2. 找到以下注册表子项:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
    3. 用鼠标右键单击 DefaultPassword,单击 删除,然后再单击 
    4. 退出注册表编辑器。
    5. 通过使用 Sysprep 工具,重新创建主映像。

    删掉注册表之后,重新封装下,然后用wds试试看


    失业了,求微软平台顾问工作 MCITP/CCIE/VCP QQ:6927317 Pcdogyu@hotmail.com

    2012年4月9日 3:11