none
关于硬盘的ide和ahci模式 RRS feed

  • 问题

  • 我今天把硬盘改成ahci模式了,结果开机的时候系统就停在bios那里进不去,我是重置了bios用ide模式进去的。请问ahci怎么进去,我试了好几次都是停在bios那里,好像硬盘检测不出来,我如果要用ahci模式该怎么办。还有台式机用ide模式还是ahci模式?哪个好?有什么具体区别?

    ps:我还带了块sata1接口的硬盘,就是很多针的数据接口的那种。

    2010年8月21日 11:37

答案

  • 你好,

    如果在安装系统时BIOS中已经设置SATA II硬盘为IDE兼容模式,则在安装系统之后SATA II磁盘会以IDE兼容模式运行。该模式是SATA II磁盘向下兼容IDE传输模式,运行在IDE兼容模式的SATA II磁盘没有一些高级特性,比如NCQ(自然命令序列)。如果SATA II磁盘以AHCI(進階主機控制器介面)模式运行会获得更高的磁盘性能,可以更好的体现出SATA硬盘比传统的IDE硬盘优势。

    在已经安装好的系统,如果在BIOS中将硬盘运行模式由IDE改为AHCI模式将有可能导致系统蓝屏(错误加载驱动程序)或其他系统问题。

    可以尝试将BIOS中的SATA II运行模式改为AHCI之后在Windows启动选项菜单中按【F8】并选择安全模式,进入安全模式后会重新安装AHCI模式的磁盘驱动程序。


    请将已解决的问题标记为“答案”,以便更多的朋友能够方便的找到问题解决方案。 - MVP | Windows Desktop Experience | Virtualization Sino
    2010年8月22日 15:24
    版主
  • 我的意思是让 Windows 重新检测一遍 AHCI 模式。你可以先以 IDE 模式启动,进入设备管理器将 IDE 控制器及现有磁盘删除,然后检测并扫描硬件改动,这时设备管理器会提示重新启动计算机。
     
    重新启动后首先进入 BIOS 将模式切换为 AHCI,看看 Windows 能否自动识别并完成驱动配置。如果依然无法启动,可以用 Windows 安装光盘启动执行一下“修复计算机”-“修复启动”。
     
    --
    Alexis Zhang
     
    https://mvp.support.microsoft.com/profile/jie
    http://blogs.itecn.net/blogs/alexis
     
    推荐以 NNTP Bridge 桥接新闻组方式访问论坛以获取最佳用户体验。
     
    本帖是回复帖,原帖作者是楼上的 "Aboutime"
     
    现在问题是,我是用ahci装的系统,然后改了活动分区又改回来就不能再用ahci模式了。另外win7不是自带驱动吗?如果要再装一次驱动的话能说下哪里有这驱动还是网上下载?还是要重新装系统才能再开启?
     
     
    2010年8月23日 10:44

全部回复

  • AHCI是 SATA  IDE是 老式的接口
    Windows System & Performance 请将已解决的问题标记为“答案”,以便更多的朋友能够方便的找到问题解决方案。
    2010年8月21日 14:35
  • AHCI是 SATA  IDE是 老式的接口
    Windows System & Performance 请将已解决的问题标记为“答案”,以便更多的朋友能够方便的找到问题解决方案。

       那么我一块是 sata接口 一块是ide接口硬盘。sata装的是win7,请问能开启吗?我总是停留在检查sata硬盘这。

    2010年8月21日 15:09
  • 那當然了  選擇端口  后 就是IDE  SATA  你就不能在裝了系統后再更改 不然就會出現你這樣的問題 或是 藍屏  一般的話 BIOS裏面有 IDE  SATA選項的話 就是說這個電腦是 IDE转SATA接口的  不是纯正的SATA    SATA 比IDE 传输速度 快些   所以 你要使用SATA的話 就要重新安裝系統 因為你當初是用IDE接口裝的系統
    Windows System & Performance 请将已解决的问题标记为“答案”,以便更多的朋友能够方便的找到问题解决方案。
    2010年8月21日 15:33
  • 那當然了  選擇端口  后 就是IDE  SATA  你就不能在裝了系統后再更改 不然就會出現你這樣的問題 或是 藍屏  一般的話 BIOS裏面有 IDE  SATA選項的話 就是說這個電腦是 IDE转SATA接口的  不是纯正的SATA    SATA 比IDE 传输速度 快些   所以 你要使用SATA的話 就要重新安裝系統 因為你當初是用IDE接口裝的系統
    Windows System & Performance 请将已解决的问题标记为“答案”,以便更多的朋友能够方便的找到问题解决方案。
    你的意思是如果是纯正的sata接口的话,主板bios里面就不会有ide这个选项,直接是sata选项?
    2010年8月22日 1:02
  • 你在安装操作系统的时候用的是 IDE 模式还是 AHCI 模式?
     
    Windows 7 同时支持这两种模式,但如果在安装操作系统时使用的是 IDE,主硬盘也将是按照 IDE 模式配置的,
    再想切换回 AHCI 必须重新配置 AHCI 驱动程序。正确顺序是首先以 IDE 模式启动操作系统,安装 AHCI 驱动,
    然后重启进入 BIOS 切换回 AHCI 模式,再进入操作系统。如果不配置 AHCI 驱动就直接切换模式,只具有 IDE
    驱动的硬盘是无法完成操作系统启动的。
     
    --
    Alexis Zhang
     
    https://mvp.support.microsoft.com/profile/jie
    http://blogs.itecn.net/blogs/alexis
     
    推荐以 NNTP Bridge 桥接新闻组方式访问论坛以获取最佳用户体验。
     
    本帖是回复帖,原帖作者是楼上的 "Aboutime"
     
    我今天把硬盘改成ahci模式了,结果开机的时候系统就停在bios那里进不去,我是重置了bios用ide模式进去的。请问ahci怎么进去,我试了好几次都是停在bios那里,好像硬盘检测不出来,我如果要用ahci模式该怎么办。
     
     
    2010年8月22日 1:23
  • 我是用ahci模式装的win7,但是期间估计是蛋疼,把磁盘标记为活动分区改过了,然后又改回来了,以为没事了。结果开机就不能进了,只能重置了bios用ide模式进去。win7不是自带ahci模式驱动么?我当时装好系统,驱动精灵确实是可以更新ahci模式的驱动了。现在又没这选项了。要再改回ahci模式是不是还要重新装一次驱动?
    2010年8月22日 2:44
  • 你现在BIOS中设回IDE模式,按F10保存后重启就能进入windows,然后在windows中进入注册表编辑器,找到并单击下面的注册表子项之一:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV
    在右窗格中,右键单击“名称”列中的“Start”,然后单击“修改”。
    在“数值数据”框中,键入 0,然后单击“确定”,按F10保存后退出注册表编辑器,最后在BIOS中改为AHCI模式,

    这样更改就可以顺利进入windows,进入后windows就会提示有新硬件,安装完驱动后更改AHCI模式就大功告成!

    2010年8月22日 4:08
  • 你现在BIOS中设回IDE模式,按F10保存后重启就能进入windows,然后在windows中进入注册表编辑器,找到并单击下面的注册表子项之一:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV
    在右窗格中,右键单击“名称”列中的“Start”,然后单击“修改”。
    在“数值数据”框中,键入 0,然后单击“确定”,按F10保存后退出注册表编辑器,最后在BIOS中改为AHCI模式,

    这样更改就可以顺利进入windows,进入后windows就会提示有新硬件,安装完驱动后更改AHCI模式就大功告成!

    是不是HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci       和   HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV

    2个的start都要改成0? 我第一个HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci的start本来就是0.

    不行我2个都改0试过了,都没用。都是停在自检那里。还要把主板上的电池拿了才能进bios,太麻烦了。

    2010年8月22日 4:15
  • 你好,

    如果在安装系统时BIOS中已经设置SATA II硬盘为IDE兼容模式,则在安装系统之后SATA II磁盘会以IDE兼容模式运行。该模式是SATA II磁盘向下兼容IDE传输模式,运行在IDE兼容模式的SATA II磁盘没有一些高级特性,比如NCQ(自然命令序列)。如果SATA II磁盘以AHCI(進階主機控制器介面)模式运行会获得更高的磁盘性能,可以更好的体现出SATA硬盘比传统的IDE硬盘优势。

    在已经安装好的系统,如果在BIOS中将硬盘运行模式由IDE改为AHCI模式将有可能导致系统蓝屏(错误加载驱动程序)或其他系统问题。

    可以尝试将BIOS中的SATA II运行模式改为AHCI之后在Windows启动选项菜单中按【F8】并选择安全模式,进入安全模式后会重新安装AHCI模式的磁盘驱动程序。


    请将已解决的问题标记为“答案”,以便更多的朋友能够方便的找到问题解决方案。 - MVP | Windows Desktop Experience | Virtualization Sino
    2010年8月22日 15:24
    版主
  • 嗯,你需要重新安装一次驱动。Windows 可能会将修改过活动分区的硬盘当作一个新的设备。
     
    --
    Alexis Zhang
     
    https://mvp.support.microsoft.com/profile/jie
    http://blogs.itecn.net/blogs/alexis
     
    推荐以 NNTP Bridge 桥接新闻组方式访问论坛以获取最佳用户体验。
     
    本帖是回复帖,原帖作者是楼上的 "Aboutime"
     
    我是用ahci模式装的win7,但是期间估计是蛋疼,把磁盘标记为活动分区改过了,然后又改回来了,以为没事了。结果开机就不能进了,只能重置了bios用ide模式进去。win7不是自带ahci模式驱动么?我当时装好系统,
     
     
    2010年8月23日 0:20
  • 嗯,你需要重新安装一次驱动。Windows 可能会将修改过活动分区的硬盘当作一个新的设备。
     
    --
    Alexis Zhang
     
    https://mvp.support.microsoft.com/profile/jie
    http://blogs.itecn.net/blogs/alexis
     
    推荐以 NNTP Bridge 桥接新闻组方式访问论坛以获取最佳用户体验。
     
    本帖是回复帖,原帖作者是楼上的 "Aboutime"
     
    我是用ahci模式装的win7,但是期间估计是蛋疼,把磁盘标记为活动分区改过了,然后又改回来了,以为没事了。结果开机就不能进了,只能重置了bios用ide模式进去。win7不是自带ahci模式驱动么?我当时装好系统,
     
     

    现在问题是,我是用ahci装的系统,然后改了活动分区又改回来就不能再用ahci模式了。另外win7不是自带驱动吗?如果要再装一次驱动的话能说下哪里有这驱动还是网上下载?还是要重新装系统才能再开启?

     

    2010年8月23日 0:41
  • 我的意思是让 Windows 重新检测一遍 AHCI 模式。你可以先以 IDE 模式启动,进入设备管理器将 IDE 控制器及现有磁盘删除,然后检测并扫描硬件改动,这时设备管理器会提示重新启动计算机。
     
    重新启动后首先进入 BIOS 将模式切换为 AHCI,看看 Windows 能否自动识别并完成驱动配置。如果依然无法启动,可以用 Windows 安装光盘启动执行一下“修复计算机”-“修复启动”。
     
    --
    Alexis Zhang
     
    https://mvp.support.microsoft.com/profile/jie
    http://blogs.itecn.net/blogs/alexis
     
    推荐以 NNTP Bridge 桥接新闻组方式访问论坛以获取最佳用户体验。
     
    本帖是回复帖,原帖作者是楼上的 "Aboutime"
     
    现在问题是,我是用ahci装的系统,然后改了活动分区又改回来就不能再用ahci模式了。另外win7不是自带驱动吗?如果要再装一次驱动的话能说下哪里有这驱动还是网上下载?还是要重新装系统才能再开启?
     
     
    2010年8月23日 10:44
  • 好的,我试试。
    2010年8月23日 10:58
  • 如果你以前一直用IDE模式start键值应该是3才对啊!!我以前就是这样才成功改成AHCI模式的!而且修改后也没有拿了电池才能进BIOS的事情发生啊!

    2010年8月24日 13:57
  • 没,我是用ahci模式装的系统,改了下活动分区再改回来,就不能再用ahci模式进系统了,一定卡在自检那里,用主板跳帧重置bios才能用ide进。所以那个键值是0
    2010年8月24日 14:46