none
XP 和 Vista 无法互访, 使用网络上的主流解决方法, 仍然无法解决. RRS feed

  • 问题

  • 网络上的"xp和vista互访"的文章, 千篇一律, 它们的共同特点就是解决不了问题! 我寄希望于这里了, 微软自家的技术论坛, 应该能解决问题吧.

    xp有线, vista无线, 通过D-Link624+A路由器连接, 能共享上网, ping对方IP也没问题.

    因为vista是笔记本, 经常需要拿到办公场所使用, 所以windows系统使用自动获取IP地址, 由D-Link624+A提供DHCP的固定IP绑定.

    路由器本身是 192.168.0.1
    xp和vista分别绑定了 192.168.0.10 和 192.168.0.11

    两个系统使用了同样的用户名和密码, 都是唯一的管理员身份. 使用同一个工作组.

    xp 点网上邻居只能看到本机和路由器, 看不到vista. 手动选择" 查看工作组计算机 ", 能看到vista, 但无法访问, 提示:" \\book 无法访问. 您可能没有权限...... 找不到网络".

    vista 则根本看不到xp, 能看到本机和路由器, 手动输入IP:" \\192.168.0.10", 大约1分钟后提示:" windows 无法访问 \\192.168.0.10". vista 中"网络发现,文件共享,公用文件共享"都启用了, 网络连接定义为"专用网络", "密码保护的共享"关闭, 防火墙关闭.

    就这么多, 连不上, 很烦, 都说vista安全, 的确, 连自己都连不上了.


    我用 "VistaMaster" 优化过, 是不是关闭了某个重要的功能?? 或者, windows互访必须让系统自己定义IP地址(不是自动获取)?? 或者windows自己的dhcp服务和路由器冲突??

    求高人指点!
    2009年3月16日 18:27

答案

  •  谢谢上面两位朋友, 我的问题已经初步解决, vista 可以访问 xp 了(反之却不行), 究其原因可能是 McAfee VirusScan 企业版和 Comodo Firewall 的设置冲突(可能).

    在xp端, 我启动了所有能启动的服务, 关闭了Comodo Firewall防火墙, 删除了McAfee, 然后vista就可以访问xp了.

    "McAfee VirusScan 企业版" 真的很强, 禁用"按需访问"都不行, 只有删了才能连, 不知道哪里设定的不对.

    现在的问题就是xp访问vista了, 同工作组内都找不到vista ... ...
    • 已标记为答案 探员 2009年3月17日 11:03
    2009年3月17日 10:45
  • 好了, 问题解决了! Vista端的 "McAfee SecurityCenter"内置的防火墙默认关闭了 445端口, 打开就能访问了!

    绕了一大圈原来是自己防火墙设置问题.
    • 已标记为答案 探员 2009年3月17日 11:03
    2009年3月17日 11:02

全部回复

  • 你这样上来就说网上的方法都试过了。叫别人怎么提建议呢?你要说出你到底试了哪些步骤啊。毕竟,XP、Vista出来这么多时间了,我不觉得有什么方法是网上没有的。
    有一点是肯定的,XP/Vista互访,DHCP肯定是没问题的。
    2009年3月17日 1:06
  • 对于优化过的系统出现莫名的问题,真的很难帮你解决问题,我建议你进行一次系统还原,还原到系统被优化之前。而且网络定义你最好设置为公用,而不是专用。
    2009年3月17日 7:01
    版主
  •  谢谢上面两位朋友, 我的问题已经初步解决, vista 可以访问 xp 了(反之却不行), 究其原因可能是 McAfee VirusScan 企业版和 Comodo Firewall 的设置冲突(可能).

    在xp端, 我启动了所有能启动的服务, 关闭了Comodo Firewall防火墙, 删除了McAfee, 然后vista就可以访问xp了.

    "McAfee VirusScan 企业版" 真的很强, 禁用"按需访问"都不行, 只有删了才能连, 不知道哪里设定的不对.

    现在的问题就是xp访问vista了, 同工作组内都找不到vista ... ...
    • 已标记为答案 探员 2009年3月17日 11:03
    2009年3月17日 10:45
  • 好了, 问题解决了! Vista端的 "McAfee SecurityCenter"内置的防火墙默认关闭了 445端口, 打开就能访问了!

    绕了一大圈原来是自己防火墙设置问题.
    • 已标记为答案 探员 2009年3月17日 11:03
    2009年3月17日 11:02