GeneralUnhandledException in Project Server 2010 RRS feed

  • 问题

  • Receiving "GeneralUnhandledException" when trying to save a new project in project server 2010.
    2012年4月22日 2:48


  • Hi there,

    We will need to know more details to be able to help with this issue:

    1. Does this happen for all users and all new projects?
    2. Are the new projects created from a template or a blank project?
    3. Do existing projects save ok?
    4. Has this ever worked / is this a new install?
    5. What is displayed in the SharePoint ULS logs at the time of the error?



    Paul Mather | Twitter | http://pwmather.wordpress.com

    2012年4月22日 15:43
  • 1.  I'm the administrator.  I'm trying to set up a new EPT and a new PDP that launches when the new project type is selected.  I'm the only one that has tried to use it.  I have another EPT that we have been using for about a year.  It works fine.  It's just the new one.

    2.  I'm using a PDP.  Haven't even gotten to a project schedule or project site yet.  Can't get past the new project step.

    3.  Yes.  Existing projects are fine.

    4.  Yes.  It has worked up.  It's just the new one I'm trying to set up that doesn't. 

    5.  No clue.  I don't have access to that information.

    Janice Weaver

    2012年4月22日 20:18
  • Hi there,

    So you click the new EPT, enter the Project details then click save, at that point it errors? Do you use any workflows? Do you use a Project Plan template for the EPT or none?

    The SharePoint ULS logs will be the best place to start investigating the issue, please ask the system administrator to take a look in the logs.



    Paul Mather | Twitter | http://pwmather.wordpress.com

    2012年4月23日 6:24
  • Correct.  Once I hit "save" I get the error.

    No workflow used.

    No project plan template used.

    I will ask my support person to check the log. 

    Is there any relationship to the fact that this is a new EPT?  The original one works fine. 

    Janice Weaver

    2012年4月23日 12:37
  • Can you just navigate to PWA >  Server Settings > Enterprise Project Types. Click on your new EPT, then just click Save without making any changes. Go back the the Project Center and try again with the new EPT. If this doesn't work try changing the PDP's that you have available to this new EPT and retest.



    Paul Mather | Twitter | http://pwmather.wordpress.com

    2012年4月23日 17:07
  • Hi Paul,

    I met exactly the same issue. May I ask how to solve this?

    I tried your way by saving the new EPT, but the issue remains.



    2013年5月13日 6:32
  • We took the latest CU and it has been working fine.  That was last year.

    Janice Weaver

    2013年5月15日 16:41