none
exchange 2010&2016 IMAP proxy 问题 RRS feed

  • 问题

  • 环境:exchange 2010和2016共存环境,客户端解析全部指向到2016服务器(mail.xx.com,autodiscover.xx.com全部指向到2016服务器)

    账号在2010数据库时。测试配置IMAP模式。会一直弹出密码框,无法登陆到接受服务器。

    账号在2016数据库时,可以配置成功

    2016 iMAP 设置

    请问是什么地方配置有问题么?还是说IMAP代理时需要设置什么

    2019年11月8日 3:40

全部回复

  • 您好,

    您是在域内配置IMAP账户吗?

    请问您给Exchange 2010用户配置IMAP账户时,接收服务器和发送服务器设置的是什么,IMAP和SMTP端口设置使用的是什么端口号?您可以将IMAP账户的配置页面截图到下面,但请注意覆盖个人信息。

    请您检查下Exchange 2010服务器上Microsoft Exchange IMAP4服务是否启动。

    您可以使用下面的命令检查下Exchange 2010上IMAP的设置,并且确保IMAP客户端使用的主机名,端口和加密方法都设置正确了:

    Get-IMAPSettings -Server <server name>|fl

    下面是我环境中的设置,如果只是给域内用户配置IMAP账户,务必确认InternalConnectionSettings设置正确:

    此致,

    Lydia Zhou


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    2019年11月8日 10:41
    版主
  • 请问上面的回复对您有帮助吗?如果有其他疑问,欢迎随时回复。

    此致,

    Lydia Zhou


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    2019年11月14日 1:12
    版主
  • 相关服务、端口和IMAP设置信息都已经检查过了吗?

    请让我们知道以上回复是否帮到您,如果您已经解决了问题,可以与我们分享吗?这也许会帮助更多有类似问题的人。

    此致,

    Lydia Zhou


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    2019年11月19日 14:58
    版主
  • 我测试配置IMAP模式时,除了账号密码不一样,其他都一样,

    账号在2016数据库是可以正常配置使用的,账号在2010是无法配置的,mail.xxx.xx 的解析是指向2016服务器的。

    发送服务器已勾选  我的发送服务器(SMTP)要求验证,加密连接类型都尝试了,在2010数据库的账号是无法配置的


    2019年11月20日 4:29
  • 根据您提供的截图,您使用Get-IMAPSettings得到的配置信息是Exchange 2010的还是2016的?

    如果是Exchange 2010服务器的设置,请确保您配置IMAP账户时设置的接收/发送服务器名和InternalConnectionSettings里的服务器的FQDN相同。

    此致,

    Lydia Zhou


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    2019年11月22日 9:46
    版主
  • 根据InternalConnectionSettings的设置来配置IMAP账户的接收/发送服务器后,还有相同的问题吗?

    如果还没有解决,请您提供下“错误”页面的报错内容。

    此致,

    Lydia Zhou


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    2019年11月28日 2:06
    版主
  • 下面对以上回复做个简单的总结。

    问题:

    环境:exchange 2010和2016共存环境,客户端解析全部指向到2016服务器(mail.xx.com,autodiscover.xx.com全部指向到2016服务器)

    账号在2010数据库时。测试配置IMAP模式。会一直弹出密码框,无法登陆到接受服务器。账号在2016数据库时,可以配置成功。

    可能原因:

    可能是配置IMAP账户时的设置不符合Exchange 2010服务器上一些关于IMAP的设置。

    已给出的建议:

    检查给Exchange 2010用户配置IMAP账户时,设置的接收服务器和发送服务器是什么,IMAP和SMTP端口使用的是什么端口号。

    检查下Exchange 2010服务器上Microsoft Exchange IMAP4服务是否启动。

    可以使用下面的命令检查下Exchange 2010上IMAP的设置,并且确保IMAP客户端使用的主机名,端口和加密方法都设置正确了:

    Get-IMAPSettings -Server <server name>|fl

    下一步建议:

    确保配置IMAP账户时设置的接收/发送服务器名和Exchange 2010上InternalConnectionSettings里的服务器的FQDN相同。

    此致,

    Lydia Zhou


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    2019年12月2日 15:46
    版主