none
Exchange2013 SP1邮箱角色传输服务安装时报错 RRS feed

  • 问题

  • Exchange2013 SP1安装到邮箱角色传输服务93%时报如下错误,请高手帮忙,谢谢。

    错误:
    运行"$error.Clear();
                if ($RoleProductPlatform -eq "amd64")
                {
                    $fastInstallConfigPath = Join-Path -Path $RoleBinPath -ChildPath "Search\Ceres\Installer";
                    $command = Join-Path -Path $fastInstallConfigPath -ChildPath "InstallConfig.ps1";
                    $dataFolderPath = Join-Path -Path $RoleBinPath -ChildPath "Search\Ceres\HostController\Data";

                    try
                    {
                        # the BasePort value MUST be kept in sync with dev\Search\src\OperatorSchema\SearchConfig.cs
                        &$command -action i -baseport 3800 -dataFolder $dataFolderPath -silent;
                    }
                    catch
                    {
                        $errorMsg = "Failure configuring SearchFoundation through installconfig.ps1 - " + $_.Exception.Message;
                        Write-ExchangeSetupLog -Error $errorMsg;
                       
                        # Clean up the failed configuration attempt.
                        &$command -action u -silent;
                        try
                        {
                            if ([System.IO.Directory]::Exists($dataFolderPath))
                            {
                                [System.IO.Directory]::Delete($dataFolderPath, $true);
                            }
                        }
                        catch
                        {
                            $deleteErrorMsg = "Failure cleaning up SearchFoundation Data folder. - " + $dataFolderPath + " - " + $_.Exception.Message;
                            Write-ExchangeSetupLog -Error $deleteErrorMsg;
                        }
                    }
                }
            "时生成以下错误:"Failure configuring SearchFoundation through installconfig.ps1 - Error occurred while configuring Search Foundation for Exchange.System.TimeoutException: Timed out waiting for Admin node to be up and running
       在 Microsoft.Ceres.Exchange.PostSetup.DeploymentManager.WaitForAdminNode(String hostControllerNetTcpWcfUrl)
       在 Microsoft.Ceres.Exchange.PostSetup.DeploymentManager.Install(String installDirectory, String dataDirectoryPath, Int32 basePort, String logFile, Boolean singleNode, String systemName, Boolean attachedMode)
       在 CallSite.Target(Closure , CallSite , Type , Object , Object , Object , Object , Object , Object , Boolean )"。


    No pain no gain

    2014年11月21日 15:12

答案

  • 你好,

    建议你参考下面这篇文章中的解决方案:

    http://forums.petri.com/showthread.php?t=62520#

    手动运行 installconfig.ps1 脚本在安装exchange 2013的时候。

    C:\Program Files\Microsoft\Exchange Server\V15\Bin\Search\Ceres\Installer> .\installconfig.ps1 -action a -dataFolder "c:\Program Files\Microsoft\Exchange Server\V15\Bin\Search\Ceres\HostController\Data"

    请注意,以上提供的网址为三方连接。网页中的内容和信息更新均不受微软控制,仅供当下参考之用。微软不会对其提供的信息失误、不准确或错误负直接或间接的责任。敬请谅解。请您确保在充分理解其风险后采纳。

    谢谢!

    Niko Cheng
    TechNet Community Support

    2014年11月24日 7:27
    版主

全部回复

  • 您好,

    请参考KB http://support.microsoft.com/kb/2889663

    修改环境变量试试

    2014年11月22日 1:39
  •  谢谢!但问题依旧。


    No pain no gain

    2014年11月22日 2:27
  • 搭建了多次环境,问题都出现在这里,不知哪里出问题。

    No pain no gain

    2014年11月22日 9:09
  • 你好,

    建议你参考下面这篇文章中的解决方案:

    http://forums.petri.com/showthread.php?t=62520#

    手动运行 installconfig.ps1 脚本在安装exchange 2013的时候。

    C:\Program Files\Microsoft\Exchange Server\V15\Bin\Search\Ceres\Installer> .\installconfig.ps1 -action a -dataFolder "c:\Program Files\Microsoft\Exchange Server\V15\Bin\Search\Ceres\HostController\Data"

    请注意,以上提供的网址为三方连接。网页中的内容和信息更新均不受微软控制,仅供当下参考之用。微软不会对其提供的信息失误、不准确或错误负直接或间接的责任。敬请谅解。请您确保在充分理解其风险后采纳。

    谢谢!

    Niko Cheng
    TechNet Community Support

    2014年11月24日 7:27
    版主