none
关于office 2010 excel保存提示 RRS feed

  • 问题

  • 我使用的是excel2010 当我打开excel 2003表格时,什么操作都没做,就连鼠标也没有点击单元格,但是关闭的时候会提示是否保存,并且提示“excel 在打开上次由excel的早期版本保存的文件时会重新计算公式”。在选项里面将公式的自动重算功能关闭之后,并且保存,下次再次打开就不会出现这样的问题,但是有个问题是,这样的设置是基于文档的,也就是每个带有公式计算的excel2003文档都需要这样设置一遍才可以。

    另外一种办法就是将文件先转化为xlsx格式也可以规避这个问题。但是这样每个excel2003都需要转化,也不太方便。

    有没有办法对文档统一设置为不自动重算

    2010年6月27日 17:04

答案

  • 可以通过以下方法解决,具体步骤如下:

    (1)启动Excel,然后开启录制宏,在【保存在】中选择【个人宏工作簿】。

    (2)单击【确定】按钮,无需录制任何操作,然后停止宏的录制。

    (3)按Alt+F11组合键,打开VBE窗口,在左侧可以看到除了当前打开的工作簿外,还有一个个人宏工作簿,名为【PERSONAL.XLS】,选择该名称。

    (4)展开【PERSONAL.XLS】下方的【Microsoft Excel对象】,然后双击ThisWorkbook模块,在其中写入以下代码:

    Private Sub Workbook_Open()
      Application.Calculation = xlCalculationManual
    End Sub
    
    (5)在VBE窗口中单击菜单栏中的【保存】按钮,这样就完成了所需的设置。

    以后在Excel中再打开任何工作簿时,都自动变为手动计算,而不是自动计算了。个人宏工作簿的默认位置:

    C:\Documents and Settings\用户名\Application Data\Microsoft\Excel\XLSTART\PERSONAL.XLS


    我的小站:http://pfsx.5d6d.com

    我的新书:《Word排版之道》已被台湾引进

    我的新书:《Excel公式与函数大辞典》已出版上市

    2010年6月27日 21:29
    版主

全部回复

  • 可以通过以下方法解决,具体步骤如下:

    (1)启动Excel,然后开启录制宏,在【保存在】中选择【个人宏工作簿】。

    (2)单击【确定】按钮,无需录制任何操作,然后停止宏的录制。

    (3)按Alt+F11组合键,打开VBE窗口,在左侧可以看到除了当前打开的工作簿外,还有一个个人宏工作簿,名为【PERSONAL.XLS】,选择该名称。

    (4)展开【PERSONAL.XLS】下方的【Microsoft Excel对象】,然后双击ThisWorkbook模块,在其中写入以下代码:

    Private Sub Workbook_Open()
      Application.Calculation = xlCalculationManual
    End Sub
    
    (5)在VBE窗口中单击菜单栏中的【保存】按钮,这样就完成了所需的设置。

    以后在Excel中再打开任何工作簿时,都自动变为手动计算,而不是自动计算了。个人宏工作簿的默认位置:

    C:\Documents and Settings\用户名\Application Data\Microsoft\Excel\XLSTART\PERSONAL.XLS


    我的小站:http://pfsx.5d6d.com

    我的新书:《Word排版之道》已被台湾引进

    我的新书:《Excel公式与函数大辞典》已出版上市

    2010年6月27日 21:29
    版主
  • 虽然很复杂也不知道这些代码啥意思,但是还是谢谢宋同学的方法
    2010年6月28日 16:32