none
LYNC2010服务器地址簿无法搜人问题。 RRS feed

  • 问题

  • LYNC2010+Exchange2010企业版部署,3台前端服务器。LYNC客户端使用LYNC2010或Skype for business 2016。7月10日左右因为LYNC前端服务器内部证书到期,于是重新走了一遍证书申请流程,之后LYNC前端服务器就恢复正常了。

    最近有用户抱怨使用LYNC2010或SKPYE for Business 2016无法用名字搜人,只能用SIP地址搜,显示未找到结果。(不确定是不是跟证书的重新申请有关系)

    服务器端运行Test-CsAddressBookService, 显示以下错误:

    TargetUri  :
    TargetFqdn : XXX.contoso.com
    Result     : Failure
    Latency    : 00:00:00
    Error      : 404, Not Found
    Diagnosis  : ErrorCode=4005,Source=YYY.contoso.COM,Reason=Destination URI eithe
                 r not enabled for SIP or does not exist
                 Microsoft.Rtc.Signaling.DiagnosticHeader

    运行Test-CsAddressBookWebQuery, 显示以下错误:

    TargetUri  :
    TargetFqdn : XXX.contoso.com
    Result     : Failure
    Latency    : 00:00:00
    Error      : 404, Not Found
    Diagnosis  : ErrorCode=4005,Source=YYY.contoso.com,Reason=Destination URI eithe
                 r not enabled for SIP or does not exist
                 Microsoft.Rtc.Signaling.DiagnosticHeader

    前端服务器日志里有一台报:

    “无法按配置的方式使用证书
    传输:TLS,IP 地址:*,端口:5061。错误: 0xC3E93C0D (SIP_E_STACK_TRANSPORT_CERT_NOT_FOUND)。
    原因: 该证书可能已被删除,或者配置不正确。
    解决方法:
    确保在本地计算机证书存储区中存在有效证书。还要确保服务器有足够的权限访问该存储区。”

    大致检查了一下,感觉证书没有问题,不然这台前端服务也起不来了。

    2018年7月19日 7:40

全部回复

  • Hi,

    有多少用户出现了这个问题?

    在出现问题的用户端是否搜索所有用户都存在这个问题,还是只是不能搜索某些用户?

    在服务器中您使用的Addressbook Policy是哪种方式,WebserachandFiledownload还是Webserachonly

    如果是WebserachandFiledownload方式,我们建议您可以尝试删除用户临时文件夹,重新登陆,查看是否有地址簿文件下载。

    Lync 2010: %userprofile%\AppData\Local\Microsoft\Communicator\sip_xxx

    SFB2016: %userprofile% \AppData\Local\Microsoft\Office\16.0\Lync\sip_xxx

    CMD中运行以下命令添加注册表值,设置使地址簿文件立即下载至客户端:

    Lycn2010:  reg add HKLM\Software\Policies\Microsoft\Communicator /v GalDownloadInitialDelay /t REG_DWORD /d 0 /f

    SFB2016:  reg add HKLM\Software\Policies\Microsoft\Office\16.0\Lync /v GalDownloadInitialDelay /t REG_DWORD /d 0 /f

    如果是Websearchonly方式,由于最近您更换过证书且有个证书相关报错,我们建议您检查下前端服务器中IIS中站点绑定的证书配置,查看证书配置是否正确。

    此外,我们建议您运行Test命令时在末尾添加“-verbose”参数以输出详细的过程。

    此致,

    Shaw

    2018年7月20日 3:30
    版主
  • 感谢您的解答。

    问题已经找到。原因是虽然刚换了所有前端的证书,但还是漏了一个,漏了负载均衡设备A10上的前置证书。

    在A10上导入新证书后,问题就立刻解决了。

    2018年7月24日 6:47
  • Hi,

    很高兴看到问题得以解决,确实如果有负载均衡设备也会需要更新证书,非常感谢您的分享。

    您可以将您的回复“标记为答复”以帮助其他遇到相似问题的用户.

    此致

    Shaw Lu


    2018年7月24日 8:19
    版主