none
excel保存到sharepint后在网页中打开报错 RRS feed

  • 问题

  • 大侠好。

    这里是个sharepoint2010服务器场,这几天测试了下excel service, 发现excel文件保存到sharepoint2010后用浏览器打开报如下错误。 在此之前我已经在管理中心中定义了excel受信任位置了,难道其他还有地方需要设置?

    请大侠帮我诊断下吧,万分感谢。


    chengli

    2012年4月22日 6:27

答案

全部回复

  • Hi chennyli,

    这里有一篇文章介绍关于“Excel Services is unable to process the request. Wait a few minutes and try performing this operation again.”错误的原因以及一些检查步骤:
    http://blog.sina.com.cn/s/blog_627b565a01013tld.html

    Thanks,
    Lhan Han
    2012年4月23日 7:00
    版主
  • 大侠好。 我参考了您发的link,上面说的补丁我已经打过,而且相关设置我本也就已经设置好了。可问题还是依旧。

    请大侠再帮我分析下吧,谢谢。


    chengli

    2012年4月24日 2:25
  • Hi chennyli,

    再尝试检查下面几项:
    1、Check the Trusted File Location for Excel Services
    2、Check if you can run Get-SPExcelServiceApplication

    这里有篇论坛帖子可供参考:
    http://sharepoint.stackexchange.com/questions/22346/excel-web-access-web-part-error(如果不能访问,请告知我,我将把帖子中的内容转到我的sina博客中)

    Thanks,
    Lhan Han
    2012年4月24日 6:24
    版主
  • 大侠好。上面的帖子我能打开, 也按照下面的几点检查了下。

    • Excel Services is actually running on the farm.
    • Check if you can run Get-SPExcelServiceApplication
    • Check the Trusted File Location for Excel Services
    • Check if your Web Application has a service connection to the Excel Services

    以下截图是我的检查结果,发现都是正常的。唉,可是还是不行。由于只能发两张图,还有张关于Trusted File Location for Excel Services的图见一楼我发的帖子。

    谢谢大侠


    chengli

    2012年4月24日 12:45
  • 对了,下面这个图是系统日志中的错误信息:

    日志名称:          Application
    来源:            Microsoft-SharePoint Products-SharePoint Server
    日期:            2012/4/24 1:14:11
    事件 ID:         2159
    任务类别:          Unified Logging Service
    级别:            错误
    关键字:          
    Event 5240 (Excel Services Application) of severity 'Error' occurred 14 more time(s) and was suppressed in the event log
    事件 Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-SharePoint Products-SharePoint Server" Guid="{C33B4F2A-64E9-4B39-BD72-F0C2F27A619A}" />
        <EventID>2159</EventID>
        <Version>14</Version>
        <Level>2</Level>
        <Task>31</Task>
        <Opcode>0</Opcode>
        <Keywords>0x4000000000000000</Keywords>
        <TimeCreated SystemTime="2012-04-23T17:14:11.177272100Z" />
        <EventRecordID>323036</EventRecordID>
        <Correlation />
        <Execution ProcessID="6088" ThreadID="4428" />
        <Channel>Application</Channel>
        <Computer>CT002.centrotherm.cn</Computer>
        <Security UserID="S-1-5-21-3866568512-870033975-4251343334-500" />
      </System>
      <EventData>
        <Data Name="int0">5240</Data>
        <Data Name="string1">Excel Services Application</Data>
        <Data Name="int2">14</Data>
      </EventData>
    </Event>


    chengli

    2012年4月24日 12:53
  • Hi chengli,

    通过查询你上面给出的错误详细,出现你这样问题的原因应该是:Excel Services 应用程序 服务器计算机处于无效状态,可能需要重新启动。
    1. 重新启动之前,请验证是否经常出现此问题。这可能是一个可以自动更正的不稳定问题,不需要重新启动服务器。

    2. 如果此问题经常出现,请重新启动运行 Excel Services 应用程序 的服务器。

    3. 如果此问题仍然经常出现,并且重新启动服务器不能解决此问题,请确认服务器的硬件可以正常运行,或重新安装 Excel Services 应用程序 并将该服务器重新添加到服务器场中。

    详细请查看微软官方SharePoint知识库:
    http://technet.microsoft.com/zh-cn/library/ee513104.aspx

    Thanks,
    Lhan Han

    2012年4月25日 1:45
    版主
  • hi, Lhan

    服务器已重新启动过,无果。 对了,我这里的前端服务器和应用程序服务器是同一台服务器,数据库在另一个台服务器上。

    另外您说的“重新启动运行 Excel Services 应用程序 的服务器。”,我不知道在哪里去重新启动它,见下图。

    还有如果需要重新安装Excel Services 应用程序的话,是否就是按下图中设置呢,有什么要改的的吗? 谢谢大侠指点


    chengli

    2012年4月25日 2:03
  • 问题解决了, 我参看了这个link里面的两处设置。

    http://blog.armgasys.com/?p=133 


    chengli

    • 已标记为答案 Louis_LI 2012年4月25日 6:51
    2012年4月25日 6:51
  • Hi chennyli,

    感谢你贴出你的解决方案,但是你贴出的链接不能访问,希望你能贴出一个可以访问的链接,这将能帮助到其他遇到相似问题的人。

    Thanks,
    Lhan Han
    2012年4月25日 6:56
    版主
  • 可能我这里是专线,可以访问这个链接。下面是我从链接中复制的主要内容:

    The Solution

    EDIT: Updated solution post service pack 1
    (What!!!, you don’t have SP1 installed yet??  checkout this link for details)

    1. Navigate: Site Actions –> Site Settings
    2. Click the Site Collections Features link located under the Site Collection Administration section of the page
    3. Locate and active the Open Documents in Client Applications by Default

    NOTE: This does not always resolve the issue, even with SP1 installed.  We have yet to determine a consistent root cause.  If the solution steps above do not resolve the issue, continue on to our original solution below (or reinstall SharePoint… whichever works best for you)

    Original Solution
    The problem was traced to SharePoint’s built-in URL redirection for various files types.  Behind the scenes, SharePoint was attempting to redirect the Excel file to a common viewer component.  We just needed to turn this redirection off.

    Edit the serverfilesExcelServer.xml file at the following location:
    [Program Files]\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\XML\

    Comment out any lines with the file extension of xlsx or xls

    Example:

    <?xml version="1.0" encoding="utf-8" ?>

    <!– Copyright (c) Microsoft Corporation. All rights reserved. –>

    <ServerFiles>
        <!–<Mapping FileExtension="xlsx" RedirectUrlTemplate="/_layouts/xlviewer.aspx?id=|0" NoGetRedirect="TRUE" CreateRedirectUrlTemplate="/_layouts/xlviewer.aspx?new=1"/> –>
        <Mapping FileExtension="xlsb" RedirectUrlTemplate="/_layouts/xlviewer.aspx?id=|0" NoGetRedirect="TRUE" CreateRedirectUrlTemplate="/_layouts/xlviewer.aspx?new=1"/>
        <Mapping FileExtension="xlsm" RedirectUrlTemplate="/_layouts/xlviewer.aspx?id=|0" NoGetRedirect="TRUE" CreateRedirectUrlTemplate="/_layouts/xlviewer.aspx?new=1"/>
    </ServerFiles>

    Perform an IISRESET and you will now be presented with the tried and true standard “Open Document” dialog


    chengli

    2012年4月25日 9:11