none
Cannot remove failed VMM server

    问题

  • Hi,

    I had a VMM server fail on me which required a rebuild.  During the commissioning of the new server, the client decided  to change the name of the server.  Once i'd rebuilt the server and restored the old database, now I have 2x VMM servers, old name and new name.

    I cannot find out how to remove the old VMM server from the GUI, nor PowerShell.  Editing the database directly is not an option, this is a production install.  I can see how to remove old dead hosts, but not dead VMM servers.

    Also rather worryingly the "old" server name is responding and green (which is not possible!)  VMM is not detecting the fact the server is actually down\gone.

    Thanks

    2017年12月29日 10:43

全部回复

  • Hello,

    Based on my understanding, the "old" server name is responding, because the server name is resolved to the same IP address as the new server name. Thus, the VMM can still detect the server is still up and running.

    For the deletion of old vmm server object, it looks like that there is no such button or command either from the GUI or PowerShell. The following thread discusses the similar problem, and you may refer to the solution mentioned in it.

    https://social.technet.microsoft.com/Forums/ie/en-US/40ff5446-e2f2-4b10-a9b8-b94d2efe38eb/how-to-remove-old-vmm2012-server-name-from-vmm-server-navigation-pane?forum=virtualmachingmgrsetup

    Best regards,

    Andy Liu


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2018年1月1日 5:11
  • Hi,

    The old VMM server does not exist and is different IP address to new one, which is worrying.  The only thing that is present is the AD account still which i'll delete shortly.  Be interesting to know what VMM is looking at to think its still alive.

    I'll check your link.

    Thanks

    Richard

    2018年1月3日 20:19
  • Hello Richard,

    Does the old VMM server also exist at the location Fabric -> Infrastructure -> Library Servers?

    If so, you can try to remove the old VMM server first.

    Best regards,

    Andy Liu


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    2018年1月4日 9:19
  • Hi,

    I have a different server as a library server.  See attached.

    2018年1月4日 9:25
  • Hello,

    Interesting.

    The 'old' VMM server should not be treated as responding and active.

    I think either the 'new' VMM server is not detecting the status of the 'old' VMM server actually, or it does in fact, but through the loopback interface(127.0.0.1), instead of the physical network interface.

    Best regards,

    Andy Liu


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2018年1月9日 6:02
  • I've seen this before when VMM runs in a clustered environment.  Taking down a node, still shows as responding.  Clearly a bug and needs addressing as you cant rely on it.
    2018年1月11日 13:11
  • Find out the old VMM server ID. Record the ServerID of the old VMM server.

    SELECT * FROM [VirtualManagerDB].[dbo].[tbl_VMM_Server]

    Run the following to remove the old VMM server. Please replace the ID in the yellow part.

    EXEC prc_VMM_RemoveVmmServerById 'ServerID'

    2018年4月6日 2:37
  • Running these commands worked for me, although it does not refresh in the management console until you close and re-open the console.

    2018年7月3日 13:57