none
WDS - image capture upload - There is not enough space on the disk

    问题

  • I have passed all the steps of the image capture wizard of the WDS Server 2008 R2...

    In the middle of the process of the uploading the image captured it tells me "There is not enough space on the disk".

    I canceled the process and I can see the xyz.wim file created in the local machine, but no in the WDS server (E:\RemoteInstall).

    Obviously I have sufficient space on both, local machine where I am capturing the image and on the WDS server.

    Also, both disk drives are NTFS without quota allocation.

    Anyone has an idea of how to solve it¿?

    I have read some information in Internet, but with no succesful.

    Thanks in advanced.

     

    2011年4月29日 17:34

答案

  • You have to create an small (10GB) partition in the client machine, and then in the wizard you need to specify that you want to create the .wim there.

    It works like a charm.

    Good luck!

    • 已标记为答案 Tacheleu 2011年6月17日 12:01
    2011年6月17日 12:01

全部回复

  • Hi guys,

    any idea?

    I am sure that I am not the unique person that am with this issue.

     

    2011年5月3日 14:27
  • Hi,

    Have you tried the steps discussed here?

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    2011年5月4日 10:39
    版主
  • Hi Magon,

     

    yes I have done all this that Zingy (Tuesday, November 14, 2006) describes. But for example he has an error connecting to the WDS server that I have solved, and I am one step ahead.

    In the other hand I am using WDS in WS2008R2 and W7 client.

     

     

    2011年5月4日 13:35
  • Hi,

    There might be conflict with the Server side. I suggest try it again later.

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    2011年5月6日 9:37
    版主
  • It works if I copy the .wim file (10GB) using a shared directory.

    Therefore, I have uninstalled WDS role and I installed once again. If it will fail again, I will try with another SO what it means will be another WDS capture.

    I have re-re-recheck that all partitions are NTFS.

    More concretly, the host server (hyper-v) has c: and d: partitions, both are ntfs. In d: partition I have 1,8TB free and are stored the .vhd for two VM, the first one has DC, WDS, DNS installed and the second one has DHCP installed. The first one, has also two partitions, c: and d:. Both are NTFS. c: is for SO and d: is exclusively for WDS role. In d: partition WDS role is where WDS stores all configuration for WDS and also the .wim files that are send trough the network.

    When it tells me "There are not enough space on the disk" I think that it is refering to d: partition, but how I said in the first line of the post, using shared directory it works. And also I can discard a switch issue.

    I will continue doing tests.

    • 已建议为答案 Gigi4444 2011年6月14日 19:11
    • 已标记为答案 Tacheleu 2011年6月17日 12:00
    • 取消答案标记 Tacheleu 2011年6月17日 12:00
    2011年5月6日 12:42
  • I have the exact same problem. Not enought space. I did try to manualy import the wim file created localy in th C: drive in to the WDS with the WDS console. It work but, the image itself after I deploy it. with the same PC,To test the image after I reboot the PC. The image fail and I was not able to repair IT on the PC.

    Any solution?

     


    2011年6月14日 19:16
  • You have to create an small (10GB) partition in the client machine, and then in the wizard you need to specify that you want to create the .wim there.

    It works like a charm.

    Good luck!

    • 已标记为答案 Tacheleu 2011年6月17日 12:01
    2011年6月17日 12:01
  • Hi,

     

    I have the same problem. After capturing until 100% and writing the Metadata I get the error message: "There is not enough space on the disk". 

    The client is running Windows 7 x64 with 500 GB hard drive and only one partition (plus the 100 MB system-reserved partition). The image is 75GB and the wim file is 34 GB (for me it is too little). On the WDS server are 240 GB free space. The marked solution doesn't work for me. 

    I read all the posts here but no solution works. My problem is that I cannot recognize whether the problem is server or client based. Where is not enough space? 

    Does anybody have another suggestion? Until two months the WDS server was working fine and I had no problems with capturing and uploading any image. 

    Kind regards,

    Martin

    2012年1月20日 22:17
  • We are having the same issue here. W7 x64 sp1, 75GB image Toughbook. We have a 200GB C: drive and a 100GB D: drive. We use the D: drive to capture the image and then the upload happens after that. The WDS server has 350+GB available. Not sure what to look at now. I can capture smaller images (servers, laptops, desktops) with no issues. This one is just bloated so we can bypass a long user synch process. Any ideas would be appreciated.

    Thanks

    Erik

    • 已建议为答案 HunterIT 2012年8月31日 8:44
    • 取消建议作为答案 HunterIT 2012年8月31日 8:44
    2012年3月5日 14:18
  • How big is the image that is being generated? What version of WinPE is your capture images based off of?
    2012年3月10日 0:26
  • Has anyone found a resolution to this yet?  I have the same exact problem and have yet to find a solution.  Have more than 100GB of free space on both the Client and Server, so space is definitely not an issue.  I do not have this issue with sysprepping Win XP machines, only using Sysprep on Windows 7.
    2012年4月19日 19:41
  • Can you gather the tracing logs from WdsCapture? To do this, perform the following steps:

    Edit the registry in WinPE prior to running WdsCapture.exe to contain the following keys:

    HKLM\Software\Microsoft\Tracing\WDSCAPTURE

    • EnableFileTracing (REG_DWORD) == 1
    • FileTracingMask (REG_DWORD) == 0xffff0000
    • MaxFileSize (REG_DWORD) == 0x01900000
    • FileDirectory (REG_EXPAND_SZ) == %windir%\tracing
  • Then, run WDS capture and grab the tracing logs from x:\windows\tracing and post them here.

2012年4月19日 19:58
  • "Can you gather the tracing logs from WdsCapture? To do this, perform the following steps:

    Edit the registry in WinPE prior to running WdsCapture.exe to contain the following keys:

    HKLM\Software\Microsoft\Tracing\WDSCAPTURE

    • EnableFileTracing (REG_DWORD) == 1
    • FileTracingMask (REG_DWORD) == 0xffff0000
    • MaxFileSize (REG_DWORD) == 0x01900000
    • FileDirectory (REG_EXPAND_SZ) == %windir%\tracing

    Then, run WDS capture and grab the tracing logs from x:\windows\tracing and post them here."

    Hi Aaron,

    Just a clarification, do I edit the registry on the client PC, or on the WDS?

    Thanks,

    Dan

    2012年4月23日 17:54
  • On the client PC, inside of the WinPE image that's running WdsCapture.exe
    2012年4月24日 19:53
  • Hi Aaron,

    There is no "WDSCapture" in either the client machine(machine I want to capture) or the WDS (server I want to capture to).  On the WDS, I only see WdsImge, WDSMGMTY, WDSMMC, WDSSERVER, and WdsTptMgmt under HKLM\Software\Microsoft\Tracing

    On the client machine there are absolutely no references to WDS in the registry.

    Any thoughts?

    2012年5月8日 17:15
  • This Works for  me, i Have the  same  problem,  the directory where i save the image file was too small...

    try to create a New directory where you save all your  image file....

    2012年6月2日 4:11
  • I was having the exact same problem, Capture was getting to 33% then failing. After spending a good day trying different variations, I removed the Windows 7 Product Key from my answer file, and removed unattendedjoin component. Ran Sysprep, then began to capture image. Got past 33% and fully captured image.

    2012年8月31日 8:49
  • The registry keys will not be created by default. You'll need to create them prior to running WdsCapture.exe
    2012年9月7日 21:29
  • Having the same issue. I will try this

    2014年1月9日 15:45
  • if i create small partition (10GB) , only installation of the windows 7 OS is nearly full in the partition  .so how could i install other apps using this partition ??? we have to install only windows OS ???
    2016年6月2日 8:01
  • I have had the same problem - right after the wizard applies the Windows PE environment , and wants to start capturing image it sez error 80070070 there is not enough space on disk - i have solved this issue , after the wizard fails and opens cmd to X:\ simply type diskpart - list disk - select disk 0 - list partition - note that the windows reserve partition is set to partition 1 - this is your problem - type: select partition 1 - delete partition - partition is successfully deleted since windows is not running on client - now the important part - insert a windows bootable media and start windows installation - notice now after u select install custom windows installation , that when it prompts for the partition to install , the C: partition on the drive will now be listed as partition 1 - do a quick format and then select that partition to install windows to (c:) installation will continue , after installation u will notice by going to disk management that there is now no windows reserve partition , just unallocated space , install some siftwares and try capturing the image again using f12 wizard and tadaaa it captures the image fine because windows partition is now partition 1 and there is sufficient space on it for the local copy of the wim
    2017年2月10日 4:56