none
Outlook无法自动存档Exchange上的邮件 RRS feed

  • 问题

  • 环境是Exchange2010SP3/Outlook2010。

    一个用户的Outlook中设置的自动存档功能突然不起作用了。现象是可以看到自动存档运行时的进度条走过并结束,也没有报错,但服务器上的邮件一个都没有存档下来。

    在这个用户的计算机上用其他人的账户测试,可以正常存档。

    这个用户的账户到其他的计算机上测试,则同样不能存档,所以看上去应该是这个用户邮箱账户的问题。

    不知道是什么原因?

    2017年6月12日 3:03

答案

  • Hi Jason,

    终于找到问题原因,用户曾手工在邮箱目录中里移动过邮件。归档策略的时间设定默认并非是邮件的接收时间为准,而是以邮件在邮箱里的“修改”时间为准,因而这些被移动过的邮件的“修改时间”尚未到归档策略的时间设定,所以都没有被归档。

    可以通过修改注册表,忽略邮件的“修改”时间:

    [HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\14.0\Outlook\Preferences]
    "ArchiveIgnoreLastModifiedTime"=DWORD:00000001

    Stanley

    • 已标记为答案 Stanley_L 2017年7月12日 2:22
    2017年7月12日 2:22

全部回复

  • 您好,

    请检查事件日志是否有相关的错误信息报告和通过下面的命令检查这个邮箱的配额是否已经达到:

    Get-MailboxStatistics -Identity <User> |FL displayname,totalitemsize

    Get-Mailbox -Identity <User> | fl *Quota*

    你也可以运行New-MailboxRepairRequest 对这个邮箱, 或者移动这个邮箱到另外一个数据库进行测试.

    
    

    我们可以提高日志水平去检查是否有相关错误报告,参考下面截图:

    
    

    如果仍然不工作,建议导出这个邮箱到PST,重建邮箱然后导入之后进行测试。

    希望可以帮到您。


    Regards,

    Jason Chao


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2017年6月13日 5:09
  • Hi Jason,

    感谢你的答复。

    我根据你提供的命令检查了该用户的邮箱容量为380MB,跟Outlook中看到的一致,并没超过750MB限额。但奇怪的是,我将这个邮箱移动到另一个的DB后,发现移动日志中的移动进度显示总容量是975MB,不知这是否正常?

    目前邮箱在新的DB中(限额2GB),也同样不能自动归档。但我又发现一个现象,当我手动操作归档时(下图),如果选择第一个“按照文件夹的自动存档设置...”,就不能正常存档(可以看到进度条,但没有邮件被存档),但如果选择第二个选项“将该文件夹及其子文件夹存档”,则可以根据手工设定的条件存档。这是什么道理呢?

    另外,我也开启了Expert级别的日志,哪里可以查看日志呢?

    2017年6月14日 2:22
  • 您好,感谢您的回复。

    这个正常可能有邮箱的日历的大小在里面。

    手动归档,是要选择“将该文件夹及其所有子文件夹存档”:

    参考:https://support.office.com/zh-cn/article/%E6%89%8B%E5%8A%A8%E5%B0%86%E9%A1%B9%E7%9B%AE%E5%AD%98%E6%A1%A3-ecf54f37-14d7-4ee3-a830-46a5c33274f6?ui=zh-CN&rs=zh-CN&ad=CN

    请您把您自动归档的设置截图如下,以作进一步的排错:

    感谢您的努力。


    Regards,

    Jason Chao


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2017年6月14日 9:59
  • Hi Jason,

    这是自动存档设置的截图:

    谢谢!

    Stanley

    2017年6月15日 3:01
  • 感谢您的回复。

    这个设置是没有问题的。

    建议导出这个用户邮箱到PST做个备份。然后disconnect这个邮箱,然后重新connect,之后检查是否能自动归档。

    如果还是不工作,建议重建邮箱,重新导入pst, 再检查是否工作。


    Regards,

    Jason Chao


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • 已建议为答案 Jason.Chao 2017年6月24日 15:32
    2017年6月19日 15:42
  • Hi Jason,

    终于找到问题原因,用户曾手工在邮箱目录中里移动过邮件。归档策略的时间设定默认并非是邮件的接收时间为准,而是以邮件在邮箱里的“修改”时间为准,因而这些被移动过的邮件的“修改时间”尚未到归档策略的时间设定,所以都没有被归档。

    可以通过修改注册表,忽略邮件的“修改”时间:

    [HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\14.0\Outlook\Preferences]
    "ArchiveIgnoreLastModifiedTime"=DWORD:00000001

    Stanley

    • 已标记为答案 Stanley_L 2017年7月12日 2:22
    2017年7月12日 2:22