none
Test-EdgeSynchronization命令提示输入密码(Exchange2007) RRS feed

  • 问题

  • 我运行Test-EdgeSynchronization命令测试的时候提示输入密码,如下图,麻烦问下,为什么会弹出这个图?这个密码怎么设置的呢?

    [PS] C:\Windows\system32>Test-EdgeSynchronization


    Name                        : EDGEServer
    LeaseHolder                 :
    LeaseType                   : 0
    ConnectionResult            : Failed
    FailureDetail               : The LDAP server is unavailable.
    LeaseExpiry                 : 1/1/0001 12:00:00 AM
    LastSynchronized            : 1/1/0001 12:00:00 AM
    CredentialStatus            : Skipped
    TransportServerStatus       : Skipped
    TransportConfigStatus       : Skipped
    AcceptedDomainStatus        : Skipped
    SendConnectorStatus         : Skipped
    MessageClassificationStatus : Skipped
    RecipientStatus             : Skipped
    CredentialRecords           : Number of credentials 0



    • 已编辑 npc.xiao 2016年12月5日 10:01
    2016年12月5日 10:00

答案

  • 您好,

    根据报错信息来看,您应该在导入证书时勾选了“Enable strong private key protection”,所以每次使用到这张证书时都会出现提示确认是否允许访问。该密码是您在导出证书时创建的密码,同时该密码也用于证书导入。如截图:

    针对您的问题,我们可以有2中解决方法:
    1. 继续这个弹框,在允许时输入密码。
    2. 关闭“Enable strong private key protection”从而取消弹框。

    如果您需要关闭“Enable strong private key protection”的话,我们需要将这张证书删除后重新导入,或者导出之后重新导入,然后再导入时不要勾选这个选项(默认是不勾选的)。

    然后我们就要确定Test-EdgeSynchronization使用的是哪张证书,在做边缘订阅时我们会使用到一张Edge服务器上的自签名证书来进行加密。不知您是否有导入其他的证书呢?
    注:如果在Edge和Hub中都使用相同的三方信任证书,在做边缘订阅时会出现问题。请查看


    Best Regards,

    Allen Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2016年12月6日 7:32
  • 您好,

    如果您的证书是PFX格式的,在导入证书时就会需要这个Password参数。但是您可以尝试通过Export-ExchangeCertificate导出PFX格式,然后再导入测试下。

    通常情况下,Edge服务器上的证书只用来加密而不用来验证,所以自签名的证书就可以了;但如果您需要为某些特定组织提供加密的话,我们就需要这个三方信任证书了。

    详情请参考以下链接:
    https://jaapwesselius.com/2014/06/20/exchange-2013-edge-transport-server-and-ssl/
    :本文包含的部分链接为非微软第三方网站链接,所以微软公司不会对其合法性、可靠性和潜在危险做任何暗示或者保证,您可以自行确定是否最终访问。如有其相关问题,请直接联系相关网站。

    Best Regards,

    Allen Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • 已建议为答案 Allen_WangJF 2016年12月14日 13:22
    • 已标记为答案 npc.xiao 2017年2月6日 7:41
    2016年12月7日 5:52

全部回复

  • 您好,

    根据报错信息来看,您应该在导入证书时勾选了“Enable strong private key protection”,所以每次使用到这张证书时都会出现提示确认是否允许访问。该密码是您在导出证书时创建的密码,同时该密码也用于证书导入。如截图:

    针对您的问题,我们可以有2中解决方法:
    1. 继续这个弹框,在允许时输入密码。
    2. 关闭“Enable strong private key protection”从而取消弹框。

    如果您需要关闭“Enable strong private key protection”的话,我们需要将这张证书删除后重新导入,或者导出之后重新导入,然后再导入时不要勾选这个选项(默认是不勾选的)。

    然后我们就要确定Test-EdgeSynchronization使用的是哪张证书,在做边缘订阅时我们会使用到一张Edge服务器上的自签名证书来进行加密。不知您是否有导入其他的证书呢?
    注:如果在Edge和Hub中都使用相同的三方信任证书,在做边缘订阅时会出现问题。请查看


    Best Regards,

    Allen Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2016年12月6日 7:32
  • 非常感谢,edge和Hub使用的是两个不同的第三方证书,应该是没问题。

    我还有个疑问,创建证书请求使用的New-ExchangeCertificate命令,导入使用的Import-ExchangeCertificate,有个参数-Password <SecureString>,这个参数是用来设置密码的么?我在导入的时候没有加-Password参数。

    2016年12月6日 16:09
  • 您好,

    如果您的证书是PFX格式的,在导入证书时就会需要这个Password参数。但是您可以尝试通过Export-ExchangeCertificate导出PFX格式,然后再导入测试下。

    通常情况下,Edge服务器上的证书只用来加密而不用来验证,所以自签名的证书就可以了;但如果您需要为某些特定组织提供加密的话,我们就需要这个三方信任证书了。

    详情请参考以下链接:
    https://jaapwesselius.com/2014/06/20/exchange-2013-edge-transport-server-and-ssl/
    :本文包含的部分链接为非微软第三方网站链接,所以微软公司不会对其合法性、可靠性和潜在危险做任何暗示或者保证,您可以自行确定是否最终访问。如有其相关问题,请直接联系相关网站。

    Best Regards,

    Allen Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • 已建议为答案 Allen_WangJF 2016年12月14日 13:22
    • 已标记为答案 npc.xiao 2017年2月6日 7:41
    2016年12月7日 5:52