none
SharePoint 2010频繁在系统的“应用程序”日志中报错:3351,用户 'NT AUTHORITY\ANONYMOUS LOGON' 登录失败 RRS feed

  • 问题

  • 两台Windows 2008 SP2,已安装所有补丁,一台安装SharePoint,一台安装SQL Server 2008 R2。

    所有其他的问题都已经解决了,但是现在系统日志中还是频繁出现如下错误:


    - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
      <Provider Name="Microsoft-SharePoint Products-SharePoint Foundation" Guid="{6fb7e0cd-52e7-47dd-997a-241563931fc2}" />
      <EventID>3351</EventID>
      <Version>14</Version>
      <Level>1</Level>
      <Task>3</Task>
      <Opcode>0</Opcode>
      <Keywords>0x4000000000000000</Keywords>
      <TimeCreated SystemTime="2010-01-27T21:00:14.622Z" />
      <EventRecordID>3112</EventRecordID>
      <Correlation />
      <Execution ProcessID="1732" ThreadID="2196" />
      <Channel>Application</Channel>
      <Computer>oa.thinktop.biz</Computer>
      <Security UserID="S-1-5-19" />
      </System>
    - <EventData>
      <Data Name="string0">OA_SharePoint_Config</Data>
      <Data Name="string1">odb.thinktop.biz</Data>
      <Data Name="string2">用户 'NT AUTHORITY\ANONYMOUS LOGON' 登录失败。</Data>
      </EventData>
      </Event>


    - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
      <Provider Name="Microsoft-SharePoint Products-SharePoint Foundation" Guid="{6fb7e0cd-52e7-47dd-997a-241563931fc2}" />
      <EventID>7043</EventID>
      <Version>14</Version>
      <Level>2</Level>
      <Task>15</Task>
      <Opcode>0</Opcode>
      <Keywords>0x4000000000000000</Keywords>
      <TimeCreated SystemTime="2010-01-28T03:26:32.804Z" />
      <EventRecordID>3124</EventRecordID>
      <Correlation ActivityID="{D3C06B29-A749-4521-ACE8-01D296062C58}" />
      <Execution ProcessID="1188" ThreadID="5256" />
      <Channel>Application</Channel>
      <Computer>oa.thinktop.biz</Computer>
      <Security UserID="S-1-5-21-1969659141-1009047609-1628377102-1115" />
      </System>
    - <EventData>
      <Data Name="string0">加载控件模板文件 /_controltemplates/TaxonomyPicker.ascx 失败: 未能从程序集“Microsoft.SharePoint.Portal, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c”中加载类型“Microsoft.SharePoint.Portal.WebControls.TaxonomyPicker”。</Data>
      </EventData>
      </Event>


    - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
      <Provider Name="Microsoft-SharePoint Products-SharePoint Foundation" Guid="{6fb7e0cd-52e7-47dd-997a-241563931fc2}" />
      <EventID>7043</EventID>
      <Version>14</Version>
      <Level>2</Level>
      <Task>15</Task>
      <Opcode>0</Opcode>
      <Keywords>0x4000000000000000</Keywords>
      <TimeCreated SystemTime="2010-01-28T03:26:32.804Z" />
      <EventRecordID>3124</EventRecordID>
      <Correlation ActivityID="{D3C06B29-A749-4521-ACE8-01D296062C58}" />
      <Execution ProcessID="1188" ThreadID="5256" />
      <Channel>Application</Channel>
      <Computer>oa.thinktop.biz</Computer>
      <Security UserID="S-1-5-21-1969659141-1009047609-1628377102-1115" />
      </System>
    - <EventData>
      <Data Name="string0">加载控件模板文件 /_controltemplates/TaxonomyPicker.ascx 失败: 未能从程序集“Microsoft.SharePoint.Portal, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c”中加载类型“Microsoft.SharePoint.Portal.WebControls.TaxonomyPicker”。</Data>
      </EventData>
    初步判断为某个服务进程使用了错误的登陆账号,但是无法确定服务{6fb7e0cd-52e7-47dd-997a-241563931fc2}为何,如何修改服务的登陆凭据。不知各位是否曾经遇到过同样的问题?请问您是如何解决的?

    BTW:已经安装WFC Hotfix Windows6.0-KB971831-x64.msu,已经修复了IIS中SharePoint网站 sts 的应用程序池关联错误。
    2010年1月28日 4:11

全部回复

  • 是哪个类服务的错? 事件日志上的嘛

    看似 Web App 的错呀,是不是有站点扩展并启用了 Forms 验证?匿名验证? web.config 中 impersonate=true ?  改为 impersonate=false


    Hope Helpful | Xiaofeng Wang | http://www.leoworks.net
    2010年1月28日 9:22
  • 是哪个类服务的错? 事件日志上的嘛

    看似 Web App 的错呀,是不是有站点扩展并启用了 Forms 验证?匿名验证? web.config 中 impersonate=true ?  改为 impersonate=false

    没有启用Forms验证。刚刚装好,然后利用向导自动生成了所有的场服务和一个网站集。
    2010年1月28日 13:16
  • 发现很多人有同样的错误:http://social.technet.microsoft.com/Forums/en/sharepoint2010setup/thread/c894d98c-24ab-416c-aca9-ae57644deb5e


    Hope Helpful | Xiaofeng Wang | http://www.leoworks.net
    2010年1月29日 15:01
  • 发现很多人有同样的错误:http://social.technet.microsoft.com/Forums/en/sharepoint2010setup/thread/c894d98c-24ab-416c-aca9-ae57644deb5e


    Hope Helpful | Xiaofeng Wang | http://www.leoworks.net

    But.......  一直没有找到可用的解决方法。

    纠结ing...
    2010年2月1日 6:27
  • Sharepoint2010目前还是Beta,会出现许多莫名的错误,并且有许多部分的工作明显没有完成,因此不用太计较
    风中的舞蹈
    2010年2月4日 1:30
    版主
  • - 彻底晕了,在TechNet放出来的正式版本中,这个问题还一样的存在...
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
      <Provider Name="Microsoft-SharePoint Products-SharePoint Foundation" Guid="{6fb7e0cd-52e7-47dd-997a-241563931fc2}" />
      <EventID>7043</EventID>
      <Version>14</Version>
      <Level>2</Level>
      <Task>15</Task>
      <Opcode>0</Opcode>
      <Keywords>0x4000000000000000</Keywords>
      <TimeCreated SystemTime="2010-04-23T17:04:00.843Z" />
      <EventRecordID>1538</EventRecordID>
      <Correlation ActivityID="{491C16DD-C657-4273-A085-F64BE7648316}" />
      <Execution ProcessID="4104" ThreadID="4900" />
      <Channel>Application</Channel>
      <Computer>oa.thinktop.biz</Computer>
      <Security UserID="S-1-5-21-1969659141-1009047609-1628377102-500" />
      </System>
    - <EventData>
      <Data Name="string0">加载控件模板文件 /_controltemplates/TaxonomyPicker.ascx 失败: 未能从程序集“Microsoft.SharePoint.Portal, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c”中加载类型“Microsoft.SharePoint.Portal.WebControls.TaxonomyPicker”。</Data>
      </EventData>
      </Event>
    2010年4月23日 18:19
  • 正解似乎在这里:

     Load control template file /_controltemplates/TaxonomyPicker.ascx /ScenarioNavigation.ascx failed

    Locate the file “TaxonomyPicker.ascx” in the Controltemplates directory of the 14 Hive, search for the following line

    <%@ Control className="TaxonomyPickerControl" Language="C#" Inherits="Microsoft.SharePoint.Portal.WebControls.TaxonomyPicker&#44;Microsoft.SharePoint.Portal, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" %>
    and replace ‘&#44;’ with ‘,’.The correct line should look like
    <%@ Control className="TaxonomyPickerControl" Language="C#" Inherits="Microsoft.SharePoint.Portal.WebControls.TaxonomyPicker,Microsoft.SharePoint.Portal, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" %>
    正在测试中...
    2010年4月23日 18:44