none
系统中用户名的图片(图标)问题 RRS feed

  • 问题

  • 我的系统是xp sp3,昨天发现我的用户图标(图片)不能更改(不清楚啥时候出现这个问题的),具体的请看图,请问如何恢复(修复)?先谢谢了。


     

     

    " border="0" />

     

    2008年11月23日 2:46

答案

  •  j-mcgrady 写:

    你好, 云轩 

    很可能是图标缓存文件的问题,重新建立图标缓存

    方法一:

     1)开始-运行
               %USERPROFILE%\AppData\Local 

    2) attrib –h IconCache.db
                   目的:去除隐藏属性
    3)del IconCache.db
                    目的:删除图标缓存文件
    4)重启电脑,系统会自动建立新的图标缓存文件


    方法二:

    打开记事本,copy以下字段

    [HKEY_CLASSES_ROOT\.ico]
    @="icofile"
    "PerceivedType”="image"
    "Content Type"="image/x-icon"

    [HKEY_CLASSES_ROOT\.ico\PersistentHandler]
    @=”{098f2470-bae0-11cd-b579-08002b30bfeb}”
    [HKEY_CLASSES_ROOT\icofile]
    @=”Icon”
    "ImageOptionFlags”=dword:00000000
    [HKEY_CLASSES_ROOT\icofile\DefaultIcon]
    @=”%1″

    保存为.reg的文件,然后运行,

    开始-〉运行分别输入:
    regsvr32 themeui.dll
    regsvr32 /i mshtml.dll

    重启。

     

    谢谢斑竹

     

    我的问题已经解决了,原来是C:\Documents and Settings\All Users\Application Data\Microsoft\User Account Pictures\下的Default Pictures文件夹丢失了,从别的xp上拷了一个放进去就ok了。

     

    不好意思,我没有用您的方法(之前没看到您的方法)

    2008年11月23日 4:52
  • 用户帐户的头像是 BMP 位图,不是 ICO 图标,因此这个问题与图标缓存无关。

     

    楼主自己找到的方法是正解。

    2008年11月23日 13:05
    版主

全部回复

  •  j-mcgrady 写:

    你好, 云轩 

    很可能是图标缓存文件的问题,重新建立图标缓存

    方法一:

     1)开始-运行
               %USERPROFILE%\AppData\Local 

    2) attrib –h IconCache.db
                   目的:去除隐藏属性
    3)del IconCache.db
                    目的:删除图标缓存文件
    4)重启电脑,系统会自动建立新的图标缓存文件


    方法二:

    打开记事本,copy以下字段

    [HKEY_CLASSES_ROOT\.ico]
    @="icofile"
    "PerceivedType”="image"
    "Content Type"="image/x-icon"

    [HKEY_CLASSES_ROOT\.ico\PersistentHandler]
    @=”{098f2470-bae0-11cd-b579-08002b30bfeb}”
    [HKEY_CLASSES_ROOT\icofile]
    @=”Icon”
    "ImageOptionFlags”=dword:00000000
    [HKEY_CLASSES_ROOT\icofile\DefaultIcon]
    @=”%1″

    保存为.reg的文件,然后运行,

    开始-〉运行分别输入:
    regsvr32 themeui.dll
    regsvr32 /i mshtml.dll

    重启。

     

    谢谢斑竹

     

    我的问题已经解决了,原来是C:\Documents and Settings\All Users\Application Data\Microsoft\User Account Pictures\下的Default Pictures文件夹丢失了,从别的xp上拷了一个放进去就ok了。

     

    不好意思,我没有用您的方法(之前没看到您的方法)

    2008年11月23日 4:52
  • 用户帐户的头像是 BMP 位图,不是 ICO 图标,因此这个问题与图标缓存无关。

     

    楼主自己找到的方法是正解。

    2008年11月23日 13:05
    版主