none
SP3之后(所有更新至今天),DirectX中的声音不正常 RRS feed

  • 问题

  •  

    具体表现为每次重新启动,在“控制面板-声音和音频设备-音频-高级-性能”那个硬件加速级别会自动设置成“基本加速”,手动把它调整为完全之后,重新启动机器会自动恢复。

     

    我的音频设备是创新SB Audigy 4、Logitech USB 耳机、Logitech快看太空版

    2008年7月15日 0:20

全部回复

  • 如果在升级 SP3 之前正常,可能需要升级音频驱动程序以支持 SP3。到创新及罗技网站看看有没有支持 SP3 的最新驱动。

     

    2008年7月15日 3:41
    版主
  •  

    这招儿试过了,所有驱动更新至最新,甚至我还重装了几次系统,弄得激活热线那边的小M都郁闷了。
    2008年7月15日 15:25
  • 那就暂时没有办法了,等待驱动程序升级,或者暂时不升级 SP3。

    2008年7月16日 3:35
    版主
  • 好吧,我把我的配置罗列在这里,权当一记录吧,我也不知道这个是不是普遍现象:

     

    主板:技嘉GA-K8NF-9 2.2(nForce4)

    Windows XP 专业版 SP3

    声卡:创新Sound Blaster® Audigy 4 value

    2008年7月16日 13:35
  • 我现在怀疑不是声音驱动程序的问题,而是出在DirectX方面,每次重启之后,都会恢复到“基本”加速级别,而手动更改这个级别之后,也没有改观,是否是因为某些注册表项目没有正常配置,手动更改只是显示而已,实际上并未储存?

     

    嗯,请教一下,能否能列出注册表中与DirectX声音加速级别相关的项目,我想自行查看一下。

    2008年7月17日 1:35
  • 当时设置也无法生效就是说硬件无法开启加速,这还是驱动程序的原因。

     

    由于 SP2 是正常的,所以这不是系统设置的限制。

    2008年7月17日 3:51
    版主
  • 嗯,今儿终于找到问题所在了:

     

    音频硬件配置:

    创新 Creative Audigy 4 Value

    罗技摄像头快看太空版MP(内置麦克风)

    罗技 USB 耳机(型号没标)

     

    问题出在罗技摄像头上,原始驱动程序QuickCam 9.0.2驱动程序安装之后,DirectX的声音加速就只能在基本了——而且恶劣的是,卸载了这个驱动程序之后也不能恢复,问题依旧,不知道他修改了些什么——当然,摄像头功能倒是一切正常。

     

    我换用罗技最新版驱动程序QuickCam 11.5之后,发现该驱动程序根本就不能驱动这个硬件——估计罗技自己摆乌龙了。

     

    无奈之下,重新安装Windows,然后上微软的Update网站,还好,微软这里有摄像头的驱动程序,安装了之后,摄像头的高级功能,因为需要罗技那个QuickCam软件支持,算是作废了,但是基本功能都可以使用——摄像头、内置麦克风都可以正常识别并使用。

     

    呃,其他功能都一切正常,目前看起来只有等罗技的QuickCam12了。

     

    顺便说一下,我本来想反映给罗技一下的,结果他们不提供电子邮件客服反馈,而那个800客服热线,明显只能客服技术水平欠佳,大约不能理解我在说什么。

    2008年7月19日 4:49