none
Exchange2013服务器重启后邮件无法使用 RRS feed

  • 问题

  • 前几天发现ECP无法登录,今晚就把Exchange服务器重启一下,结果出了事。

    首先发现客户端连不上服务器,owa和ecp打开是空白页。登录到服务器发现Exchange ToolBox打不开,Exchange Managent Shell也连不到服务器上。

    又重启了几次现象依旧。在9月份曾经续订了exchange证书,再没做过其他设置上的改动,也没安装过更新。

    IIS是运行的,可以打开测试网页。服务Windows Remote Managent也在运行。DNS服务器在另一虚拟机上,可以正常解析域名。

    事发突然,恳请各位帮忙出出主意啊,多谢!!

    Exchange Toolbox错误:

    FX:{714FA079-DC14-470f-851C-B7EAAA4177C1}
    未解析成员“Microsoft.Exchange.Configuration.MonadDataProvider.MonadDataAdapterInvocationException,Microsoft.Exchange.Configuration.ObjectModel, Version=15.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35”的类型。
    System.Runtime.Serialization.SerializationException

    在 Microsoft.ManagementConsole.Internal.IMessageClient.ProcessRequest(Request request)
       在 Microsoft.ManagementConsole.Executive.RequestStatus.BeginRequest(IMessageClient messageClient, RequestInfo requestInfo)
       在 Microsoft.ManagementConsole.Executive.SnapInRequestOperation.ProcessRequest()
       在 Microsoft.ManagementConsole.Executive.Operation.OnThreadTransfer(SimpleOperationCallback callback)

    Exchange Managent Shell错误:

    New-PSSession : [mail.guweier.com] 处理远程服务器 mail.guweier.com 中的数据失败,并显示以下错误消息: WinRM Shell 客户端
    无法处理该请求。传递给 WSMan Shell 函数的 shell 句柄无效。 只有当 WSManCreateShell 函数成功完成时,shell 句柄才有效。将
    请求更改为包含有效的 shell 句柄,然后再次尝试。 有关详细信息,请参阅 about_Remote_Troubleshooting 帮助主题。
    所在位置 行:1 字符: 1
    + New-PSSession -ConnectionURI "$connectionUri" -ConfigurationName Microsoft.Excha ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [New-PSSession], PSRemotin
       gTransportException
        + FullyQualifiedErrorId : -2144108212,PSSessionOpenFailed


    vbscape

    2018年10月25日 16:37

答案

  • 您好,

    从您的描述来看,问题应该是出在IIS站点绑定的证书上。我们可以通过如下方式检查:

    打开IIS管理器 -> Default Web Site -> 右击,编辑绑定 -> 检查HTTPS/443 上绑定的证书是否正确。
    同样地,打开IIS管理器 -> Exchange Back End -> 右击,编辑绑定 -> 检查HTTPS/444 上绑定的证书是否正确。

    希望能帮到您!

    此致,

    敬礼

    Manu Meng


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    点击了解更多,或者访问我们的专用论坛,与我们的技术专家一起分享探索 Microsoft Teams.

    • 已标记为答案 vbscape 2018年10月26日 7:18
    2018年10月26日 3:22
    版主

全部回复

  • 您好,

    从您的描述来看,问题应该是出在IIS站点绑定的证书上。我们可以通过如下方式检查:

    打开IIS管理器 -> Default Web Site -> 右击,编辑绑定 -> 检查HTTPS/443 上绑定的证书是否正确。
    同样地,打开IIS管理器 -> Exchange Back End -> 右击,编辑绑定 -> 检查HTTPS/444 上绑定的证书是否正确。

    希望能帮到您!

    此致,

    敬礼

    Manu Meng


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    点击了解更多,或者访问我们的专用论坛,与我们的技术专家一起分享探索 Microsoft Teams.

    • 已标记为答案 vbscape 2018年10月26日 7:18
    2018年10月26日 3:22
    版主
  • 多谢版主,正式这个原因!

    我之前忘了贴服务器日志,那里已经提到了SSL配置出错。版主高手啊!

    证书没有绑定。选择里面有4个,WMSVC、Microsoft Exchange、Microsoft Exchange Server Auth Certificate和我们自己的域证书。

    我绑了我们的域证书,发现就恢复正常了。但是不知道具体绑定哪个更好。

    续订证书后客户端每次启动都会出现证书警告,有时是2个警告,域证书和autodiscover证书。不知道是不是也是这个原因?

    总之,万分感谢!




    vbscape

    2018年10月26日 7:29