none
vista下跑qq的问题 RRS feed

  • 问题

  • 最近vista一直跟qq2009过不去,系统启动之后都不能开启qq客户端,会报错“应用程序的并行配置不正确”。

    然后看了系统日志“E:\通讯软件\QQ2009\Bin\QQ.exe”的激活上下文生成失败。 找不到从属程序集Microsoft.VC80.ATL,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.762"。 请使用 sxstrace.exe 进行详细诊断。

    反复删之,不重启情况下使用正常,一旦重启就问题重现。我的OS环境是Vista Home(SP1),QQ是2009 Preview 3版的,有没有高手能帮忙解决呢?感激不尽!


    2008年9月2日 1:48

答案

  • 这可能是因为电脑中没有安装开发QQ 2009所用的开发工具对应的Runtime运行时环境,请尝试安装这个:

    http://www.microsoft.com/downloads/details.aspx?familyid=200B2FD9-AE1A-4A14-984D-389C36F85647&displaylang=zh-cn ,这个是针对Visual C++ 2005的

    如果安装后还是不行,可以尝试安装这个:
    http://www.microsoft.com/downloads/details.aspx?familyid=A5C84275-3B97-4AB7-A40D-3802B2AF5FC2&displaylang=zh-cn ,这是针对Visual C++ 2008的
    2008年9月2日 2:37
  • 这个问题应该是MSI包的问题, 尝试卸载后清楚注册表内QQ相关项, 重新安装.

     

    2008年9月2日 3:21
    版主

全部回复

  • 这可能是因为电脑中没有安装开发QQ 2009所用的开发工具对应的Runtime运行时环境,请尝试安装这个:

    http://www.microsoft.com/downloads/details.aspx?familyid=200B2FD9-AE1A-4A14-984D-389C36F85647&displaylang=zh-cn ,这个是针对Visual C++ 2005的

    如果安装后还是不行,可以尝试安装这个:
    http://www.microsoft.com/downloads/details.aspx?familyid=A5C84275-3B97-4AB7-A40D-3802B2AF5FC2&displaylang=zh-cn ,这是针对Visual C++ 2008的
    2008年9月2日 2:37
  • 这个问题应该是MSI包的问题, 尝试卸载后清楚注册表内QQ相关项, 重新安装.

     

    2008年9月2日 3:21
    版主
  • 安装到 默认路径下

     

     看看  行不行

    2008年9月4日 6:45
  • 2009目前不稳定,建议不要使用。
    2008年9月5日 3:21
  • 您好:请问那个QQ版本比较适应于Vista家庭高级版,小弟个人想QQ大部份软体用Microsoft构架来开发,怎还有不兼容地方,看来吃饭要懂得,耕地播种,扦秧,除草,施肥,收割,展米,做做饭,才有得吃,

    2009年11月19日 6:22