none
请教:exchange 24003 与两台exchange 2010共存时,2003到2010的邮件流向 RRS feed

  • 问题

  • 先说说环境如图:
    在根域为第一台exchange 2003,在一子域安装第二台exchange 2010 exc10_01 共存,同时自动建立first routing group [exchane2003,FYDIB0H2SPDLT] ,与exchang 2010的DWBGZMFD01NBJR,而且可以正常双向路由组连接器;在另一子域安装第三台exchange 2010时,已经正常安装,同时也可以相互发送。现在出现问题:从exchange 2003 发信到先安装的第一个子域的exchange 会从刚安装的exchange 2010中转。
        请高手指点 !感恩!
       [PS] C:\Windows\system32>Get-RoutingGroupConnector
    Name                      SourceRoutingGroup                             TargetRoutingGroup
    ----                      ------------------                             ------------------
    EXC10-MSB                 Exchange Routing Group (DWBGZMFD01QNBJR)       First Routing Group
    MSB-EXC10                 First Routing Group                            Exchange Routing Group (DWBGZMFD01QNBJR)
    Exc2010ConnectedMSB       Exchange Routing Group (DWBGZMFD01QNBJR)       First Routing Group
    Exc2010ConnectedMSB       First Routing Group                            Exchange Routing Group (DWBGZMFD01QNBJR)

    [PS] C:\Windows\system32>Get-RoutingGroupConnector |fl

    RunspaceId                   : 99e041f8-bcae-46f6-89b0-ac24e1e5aff3
    2013年4月16日 12:34

全部回复

  • 补充下,exchange 2003 与第一台exchange ,已经是自动建立routinggroupconnector,如果将第三台exchange 断开,还是可以从msb-exc10走。请向下,在三台共存的情况下还要怎样设置,才能让msb-exc10直接正常传送,不需要经过exc2010这一台? 请高手指教,先谢了!
    2013年4月16日 12:36
  • 这个问题就是在于开销值最小的问题,默认来说2003 像2010 第一台之间是有建立路由组连接器的,所以他能直接连接和发送,第二台和这台2003 是没有建立路由组连接器的,所以他会走到2010 有路由组连接器的机器,然后再通过AD站点路由的方式路由到其他的EX2010

    技术超级500人群:66140619 第三波(Acer)上海分公司招聘技术工程师: ------------------------------------- 熟悉一门或者多门微软技术、个性鲜明并能够主动处理问题,客户沟通能力良好! 一年14薪左右、年度TechED(依据实际表现),免费参加微软各类技术培训。 工作职责:提供客户 Daily Support & On-site support,与技术主管及Partner合作达成项目工总目标! 详情加群交流!

    2013年4月16日 14:03
    版主
  • 謝謝版主,解答!但好象不是此答案。

    简单点说, 現在是msb 送信到exc10,要經過exc2010, msb<==>exc10<==>exc2010<==>msb 中間的cost =1 ,我希望能夠是 msb==> exc10,因為按理來說,中間的cost 只有1.求解!! 

    2013年4月16日 14:49
  • AD站點的成本更高,為100

    2013年4月16日 14:52
  • 求指教啊,不要沉!

    2013年4月17日 3:49
  • 您好!

    在Exchange2003中,通过路由组决定路由,而在exchange2010中通过AD站点决定路由,若要exchange2003和exchange2010之间通信,需要创建RGC,因此,该原因很可能是你的RGC的cost值引起的。请运行Get-RoutingGroupConnector |fl检查他们的cost.

    这里有个thread供你参考。

    http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/714042ec-20cd-47f6-a18a-35bc20cb3183/


    微软一站式示例脚本库: http://blogs.technet.com/b/onescript

    2013年4月17日 6:45
  • 我創建的RGC,COST=1,應該不是COST的問題 ,謝謝!

    2013年4月17日 7:02
  • 您好!

    1.两个RGC cost的值都是1吗,若是,这可能会随机选择一个RGC来走,我建议你改成不同的cost试试。

    2.生产环境下,建议你将exchange2003升级到exchange2010后,再安装其他exchange server 2010.


    微软一站式示例脚本库: http://blogs.technet.com/b/onescript

    2013年4月17日 7:07
  • 1、如果是按最小成本走的话,应该不会随机走;因为如果 ex03经过ex10-02(第二台210),到过ex10-01的话,成本是2,但我不确定两台2010之间的成本是多少?

    2、现在是所有的ex03到ex10,都是经过ex10-02,没有随机跑的意愿~

    2013年4月17日 7:12
  • 现在两台ex10,成为一个routinggroup 成员,并且第一台还是主服务器,后来安装的是次服务器,直是头大了
    2013年4月17日 7:14
  • 您好!

    exchange2010之间的话是通过AD站点进行路由的。


    微软一站式示例脚本库: http://blogs.technet.com/b/onescript

    2013年4月25日 8:51
  • 你好,

       是ex03 到兩台ex10之間的都cost=1,但是exo3送信到第一台ex10时,却要经过后装的ex10,怎样才能直接到过?

    2013年4月25日 12:00
  • 您好!

    Exchange2003和Exchange2010之间邮件的传输主要是通过RGC来做的。我还是建议你运行Get-RoutingGroupConnector |fl检查RGC配置。


    微软一站式示例脚本库: http://blogs.technet.com/b/onescript

    2013年4月26日 6:11
  • 配置上目前看不出錯了。

    2013年4月26日 7:38