none
Error (2912) ob VMM2012 machine when creating new VM

    问题

  • Hi,

    I have a testing enviornment of all in one box , MY DC is hyper-v host , Vmm2012 , SQL are VMs.

    I get the follwing error when craeting new VM using VMM , although the VHD file gets depoyed to the hyper-v , bu the ceation fail before install VM components:

    Error (2912)
    An internal error has occurred trying to contact an agent on the VMM2012.Jitpros.local server: NO_PARAM: NO_PARAM..
    Unknown error (0x80072f05)

    Recommended Action
    Ensure the agent is installed and running. Ensure the WS-Management service is installed and running, then restart the agent.


    Information (11037)
    There currently are no network adapters with network optimization available on host dc01.jitpros.local.

     

    any ideas


    Hikmat Kanaan Amman-Jordan MCSE
    2011年6月8日 10:48

答案

  • Hi Carmen

    It was my mistake not VMM2012 problem, I couldn't remove this bug report.

    The problem was that My machine time was set a year ago , and it looks that this invalidate the certificate used to communicate between VMM and the agent , when I fixed the date my VMM , the evaluation period of VMM ended and I couldn't start it , so I had to reinstall it .

    Sorry for this for miss


    Hikmat Kanaan Amman-Jordan MCSE
    2011年6月9日 12:29

全部回复

  • Hikmat, I see you also opened up a bug on Connect for this. I have assigned it to our Dev staff. Could you collect traces and assign those to the Connect bug you submitted?  You can find info for collecting traces using Mpsrpt 2012 here in the guide:  http://technet.microsoft.com/en-us/library/gg610654.aspx

    We will need traces from the VMM Server and the host.


    Carmen M. Summers (MSFT) --Posting is provided "AS IS" with no warranties, and confers no rights.

    2011年6月8日 19:37
  • Hi Carmen

    It was my mistake not VMM2012 problem, I couldn't remove this bug report.

    The problem was that My machine time was set a year ago , and it looks that this invalidate the certificate used to communicate between VMM and the agent , when I fixed the date my VMM , the evaluation period of VMM ended and I couldn't start it , so I had to reinstall it .

    Sorry for this for miss


    Hikmat Kanaan Amman-Jordan MCSE
    2011年6月9日 12:29
  • Hi

    So i ran into this issue today, kept getting the below error on SCVMM 2016:

    Error (2912)
    An internal error has occurred trying to contact the 'Hostname.' server: NO_PARAM: NO_PARAM.

    WinRM: URL: [http://Hostname:5985], Verb: [INVOKE], Method: [GetError], Resource: [http://schemas.microsoft.com/wbem/wsman/1/wmi/root/microsoft/bits/BitsClientJob?JobId={9B375AD0-212C-42E6-B6BE-C332CC06E23D}]

    Internal server error (500) (0x801901F4)

    The only way i got this resolved is doing the following:

    • Removed Cluster nodes off SCVMM server
    • Made sure all components were removed (SCVMM Agent,DHCPExtn) from Hyper-V Hosts
    • I then installed the DHCPExtn manually on all hosts
    • And added the Cluster nodes back in SCVMM
    • After this i was able to deploy VM's from Templates again



    2018年6月2日 15:01