none
域组策略设置win10客户端屏幕保护程序无效 RRS feed

全部回复

  • 我将屏幕保护程序强制设置为“打开”,并在注册表和策略下设置了锁定屏幕保护程序的时间。

    策略设置位于用户>策略>管理>控制面板下,设置“启用屏幕保护程序”,“密码保护”和“屏幕保护程序超时”选项。

    在“用户”>“首选项”>“ Windows”>“注册表”下强制执行的注册表设置,将键“ ScreenSaveActive” = 1,“ ScreenSaverIsSecure” = 1,“ ScreenSaveTimeOut” =几秒钟设置为注册表项。确保您查看拼写-“ ScreenSaverIsSecure”是唯一带有第二个“ r”键的键。确保超时与您在“策略”部分中设置的超时相同,否则结果将不一致。

    针对Windows 2008/2008R2的扩展支持将于2020年结束,之后微软将不再为其提供安全更新。点击此处或扫描二维码获取《在 Azure 上运行 Windows Server 的终极指南》,把握良机完成云迁移并实现业务现代化。


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2020年7月27日 9:27
  • 你好

    问下,在“用户”>“首选项”>“ Windows”>“注册表”下强制执行的注册表设置,将键“ ScreenSaveActive” = 1,“ ScreenSaverIsSecure” = 1,“ ScreenSaveTimeOut” =几秒钟设置为注册表项。这个值是在注册表的哪个路径下修改?

    2020年7月28日 4:51
  • 首先给您介绍这个GPO。 这GPO是一个关于用户的设置,所以需要链接到用户所在的OU里面而不是机器所在的OU。

    屏幕保护程序超时
     GPO路径:用户配置\管理模板\控制面板\个性化
    注册表:HKCU \ Software \ Policies \ Microsoft \ Windows \ Control Panel \ Desktop!ScreenSaveTimeOut
    至少Windows 2000 Service Pack 1
    注意:此设置已过时,以后将不再可用。
    请改用“指定睡眠超时”。
    指定在启动屏幕保护程序之前必须经过的用户空闲时间。配置后,此空闲时间可以设置为最少1秒到最多86,400秒或24小时。如果设置为零,则不会启动屏幕保护程序。在以下任何情况下,此设置均无效:-禁用或未配置设置。 -等待时间设置为零。 -“启用屏幕保护程序”设置被禁用。 -“屏幕保护程序可执行文件名称”设置或客户端计算机的“个性化”或“显示控制面板”的“屏幕保护程序”对话框均未在客户端上指定有效的现有屏幕保护程序。如果未配置,则使用通过“个性化”或“显示控制面板”中的“屏幕保护程序”对话框在客户端上设置的等待时间。默认值为15分钟。

    2. 其次我们确认这个GPO是不是应用到了user,要看user对应注册表有没有更改。

    registry: HKCU\Software\Policies\Microsoft\Windows\Control Panel\Desktop!ScreenSaveTimeOut  

    3. 刷新用户的组策略我们需要登出再登录或者重启电脑。刷新后如果注册表的值不是300 说明GPO未应用。

    4. 如果已经是300,但是未生效,我们可能需要从操作系统的角度排查原因。

    针对Windows 2008/2008R2的扩展支持将于2020年结束,之后微软将不再为其提供安全更新。点击此处或扫描二维码获取《在 Azure 上运行 Windows Server 的终极指南》,把握良机完成云迁移并实现业务现代化。



    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    2020年7月31日 6:18