none
xp启动后,service.exe占据CPU100%,耗尽所有的虚拟内存,启动过程耗时达10分钟之久,该如何解决? RRS feed

  • 问题

  •    最近发现启动时内存不断上涨【本机内存1G,PM1.6,80G IDE硬盘,32M独立显卡】(察看是Service.exe占用的),CPU100%,直到虚拟内存不足为止(设置为2G),提示虚拟内存不足后,就逐渐下降回复正­常值(260M)。在网上搜索过,用最新的卡巴和麦咖啡,以及DR.WEB查均无病毒和木马,尝试删除一些软件,情况依旧,SERVICES仍旧占100%CPU,直到虚拟内存耗光后再逐步降下来才恢复正常。也尝试清楚EVENT LOG,禁止PNP等方式,问题依旧。
       在微软网站搜索过,只是针对WIN2000有过补丁,而对于XP,并没有解决办法,青椒各位专家,这究竟是哪里出了问题,应如何解决?

    2009年5月5日 14:13

全部回复

  • 首先在本机建立一个系统还原点! 

    请在出现问题的客户端上执行一次clean boot

    a. 运行MSCONFIG

    b. 在常规下选择 选择性启动。

    c. 然后清除Process System.ini File, Process Win.ini FileLoad Startup Items 的复选框,但是保留使用原始Boot.ini

    d. 在服务下,先点隐藏所有windows 服务,然后选择 disable all.

    e. 然后重新启动。观察问题是否依旧发生。


    Microsoft Certified Systems Engineer 如果您觉得对您有帮助,请在“是否有帮助”点“是”;如果你觉得回复很满意,请“标记为已解答”
    2009年5月6日 7:05
  • msconfig中排查一下启动项。
    可能是其中一个程序造成的
    如果问题没有解决,还请继续跟帖讨论。
    2009年5月6日 14:46
  •    感谢两位的回复。我再详细说明下我电脑的情况!
       我以前是用GHOST备份的系统,备份前运作良好。因为偶尔会出现SERVICES.exe进程占据CPU100%的状况,所以我不得不在出现这个情况时,用GHOST还原。由于刚购买了NOD32,所以在还原后我立马卸载掉以前的卡巴,卡巴要求重启,重启后就出现SERVICEs.exe消耗CPU,消耗内存和虚拟内存的情况。
       1、我以为卡巴的问题,于是重新装上卡巴,但问题依旧。然后打上所有最新的补丁,重启,问题依旧。
       2、在GOOGLE,BAIDU上都搜索过,也参照过相关的帖子,比如说驱动程序可能有问题,但我从设备管理器里看,包括隐藏设备也查看了,没看见什么黄色感叹号的出现。
       3、我又参照国外的文章,删除了和SERVICES相关的EVENT LOG,有网友参照这个方法成功的,但我的没有。
       4、按照谢依村先生的方法试过,虽然启动后很多服务都没有启动了,但是,问题依旧。
       5、我能肯定的,系统是没有病毒和木马的。运用了几种最新的杀软都无任何结果。
       6、启动项里,目前只剩下CTFMON和360的启动项了。
       7--------==============----------------安全模式和最后一次起作用的配置进去都没有问题。
       8、关于最后一次起作用的配置能进去的问题:虽然可以进去,但我应该怎么去排查问题,查微软的网站,与注册表保存相关。遗憾的是,不能把ControlSet002改成CurrentControlSet。我的想法是直接改注册表直接过了这一关算了。
       我的想法:有可能是驱动有问题,但更有可能是微软的BUG,因为WIN2000有专门的补丁,而XP SP2却没有。
       恳请MICROSOFT的版主们帮俺想想办法。
    2009年5月7日 10:06
  • 不知道你是否会用PROCESS EXPLORER这个工具,用此观察SERVICES镜像的调用,来排查问题试试!
    Microsoft Certified Systems Engineer 如果您觉得对您有帮助,请在“是否有帮助”点“是”;如果你觉得回复很满意,请“标记为已解答”
    2009年5月13日 6:59