none
求助:ocs前端服务无法启动 RRS feed

  • 问题

  • 大家好

      
    我的环境是这样的:域控和ocs等服务器都使用hyper-v运行在一台08的宿主机上,今天凌晨由于自动更新使得宿主机自动重启,等域控和ocs等虚拟机起来后,ocs的前端服务便无法启动,在"服务"手动启动报错说"服务不能在本地启动,请参考特定服务错误代码 "-2147217400",并且我在事件日志中看到很多61013,12326,12323和20482等错误.那位大虾能给我点意见??谢谢了.

     

    之后我为了公司能尽快使用ocs,于是乎我新建池和服务器想把用户移动过来,令我崩溃的是居然和先前出错的那一台一个症状,前端无法启动,报错信息一样,郁闷了郁闷了,中秋过不好了,呵呵

     

    以下为事件日志错误:

    2008-9-11 17:42:09 OCS Server 错误 (1000) 12326 N/A IM "无法启动协议栈。必须停止该服务
    错误代码为: 0x80041008 (wbemErrInvalidParameter)。
    原因: 查看事件日志中以前的项,查找失败原因。
    解决方法:
    解决以前的事件日志项中列出的故障,然后尝试重新启动服务器。"
    2008-9-11 17:42:09 OCS WMI Consumer 错误 (1002) 20482 N/A IM "服务器无法从 WMI 提供程序中检索某个类的初始配置。
    类: MSFT_SIPTrustedServiceSetting
    原因: 如果与 Active Directory 或 SQL 后端数据库的连接关闭,或者服务帐户的权限被更改,则可能发生此情况。如果使用 UI 或 WMI 在类中输入的项无效,或者,如果本地 WMI 知识库中出现损坏,则检索可能也会失败。
    解决方法:
    请确保运行服务的帐户具有正确的权限,并且与 Active Directory 或 SQL 后端数据库的连接正常工作。请验证相同的项不会作为直接联盟伙伴或 IM 服务提供商存在。"
    2008-9-11 17:39:23 OCS MCU Infrastructure 错误 (1022) 61013 N/A IM "进程 AVMCUSvc(3436) 未能向位于 https://impool.hsw.com:444/LiveServer/MCUFactory/ 的 MCU 工厂发送运行状况通知。
    失败次数: 254 (自 2008-9-11 16:35:39 以来)。"
    2008年9月11日 10:15

答案

  •  

    如你重新建立池,建议把AD里关于OCS的相关用户删了;数据库里关于以前池的资料也清理,(记得备份XML联系人列表以便于恢复联系人)另外在AD里删除以前池的信息(打开AD用户和计算机,选查看、高级功能找到system\microsoft\pools)我遇到同样的问题,以前是这样搞定的,不知对你有帮助不,呵呵,如详细了解请加392285961或golfyuan@hotmail.com
    2008年9月14日 4:04

全部回复

  • 首先有可能是以外的关机造成的...

    可以这样试试,开机F8,选择最后一次正确的配置.在启动....

     

    2008年9月12日 1:45
  •  可是我在域中又新建了ocs池并安装新的ocs服务器,抱错依旧,仍不能启动前端服务,唉.

     PS:实在是很佩服微软的产品,莫明其妙的错误,相当找抽的报错信息.....

    2008年9月12日 3:51
  • 呵呵.很正常,我也碰见过很多回.慢慢来..

    按照正常的方式,先停服务,在删除OCS....

    在重新装下...

     

    2008年9月12日 6:48
  • 顺便问一下,如何干净的删除ocs服务器,我每次删除都是在已经停止服务的情况下,可每次还是警告说会在AD里残留信息,求斑竹给个正解,呵呵

    2008年9月12日 7:10
  • 在安装OCS的时候,AD的架构已经扩展....

     

    可以用ADSI,在Configuration Directory Partition分区查看...

     

    RTCXXX....

     

    貌似是不能删......

    2008年9月12日 9:11
  • 郁闷了,我已经删除服务器删除池再建新池新服务器两遍了,仍然无法启动前端,报错依旧.

    2008年9月12日 9:22
  •  

    谢谢斑竹解答,等放假回去再说吧,真是苦恼。
    2008年9月13日 3:49
  •  

    如你重新建立池,建议把AD里关于OCS的相关用户删了;数据库里关于以前池的资料也清理,(记得备份XML联系人列表以便于恢复联系人)另外在AD里删除以前池的信息(打开AD用户和计算机,选查看、高级功能找到system\microsoft\pools)我遇到同样的问题,以前是这样搞定的,不知对你有帮助不,呵呵,如详细了解请加392285961或golfyuan@hotmail.com
    2008年9月14日 4:04
  •  

    谢谢楼上的,我试试
    2008年9月16日 5:35