none
exchange 邮箱迁移成功,登录邮箱提示无邮箱或者分配许可 RRS feed

  • 问题

  • 您好,exchange迁移邮箱成功,但是登录的时候提示找不到收件人邮箱或者未分配许可,环境如下

    两套邮箱系统,分别是源域:contoso.com,以及目标域:wiki.com

    执行步骤如下:

    1、通过ADMT迁移用户、组、安全传输文件、计算机成功

    2、迁移邮箱成功

    3、通过迁移的账户登录PC无问题,登录OUTLOOK或者OWA报错如下截图

    备注:发现当用户迁移到指定OU单元的时候,之后迁移邮箱成功,并在Users下面又自动建了个用户,但是这个用户状态是“disable”,求指导

    2020年9月19日 11:16

答案

  • 您好,

    >>用的是一个OU,迁移之前和迁移之后

    您的意思是用户所在的源服务器的OU和目标服务器的OU是同一个吗?

    我想和您确认的是prepare-moverequest脚本和ADMT指定迁移的OU是否是同一个OU

    因为注意到您运行prepare-moverequest脚本的时候并没有指定OU,这样的话脚本默认会将Disabled账户创建在User这个OU下。

    这可能就导致虽然ADMT成功迁移了该账户,但Exchange相关的属性没有应用于此账户。

     

    此外,根据我的测试,如果AD中已经存在同名但没有Exchange属性的账户的话,重新运行此脚本就会创建一个新的启用了邮箱的账户,并在后面加上数字。因此Get-Mailbox命令中会显示此账户的结果。

    >>刚刚执行命令报错了

    出现此报错的原因应该为该用户的邮箱已经迁移。

     

    建议您尝试在源服务器上重建一个测试邮箱账号,指定Prepare-moverequestADMT迁移的目标OU为同一个。

    查看是否会出现问题。


    此致,

    Kael Yao


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    • 已编辑 Kael Yao 2020年9月23日 6:02
    • 已建议为答案 Kael Yao 2020年9月24日 5:48
    • 已标记为答案 Tony Mu 2020年11月7日 15:13
    2020年9月23日 6:02

全部回复

  • 您好,

    请问您是否在使用ADMT迁移用户前运行了Prepare-MoveRequest.ps1脚本?

    此脚本会在目标服务器的AD中新建一个Disabled的用户。

    由于ADMT在迁移用户时,默认不会包含Exchange相关的AD属性,所以需要通过此Disabled的用户来存储Exchange相关的AD属性。

    如果此脚本指定的目标OU和ADMT迁移的目标OU不是同一个的话,就可能导致Exchange相关属性未能绑定至指定OU下的用户,进而导致出现此问题。

    您可以通过查看AD中该用户的相关属性来进行确认:

    先选中Server Manager-->ADUC-->View-->Advanced Features,然后右键点击用户-->Properties,选择Attribute Editor栏。

    如下图所示,左侧为没有Exchange相关属性的用户,右侧为Exchange的邮箱用户。

    您可以通过重新运行Prepare-MoveRequest.ps1脚本的方法(需要加上localobject和overwritelocalobject等参数来作用于指定用户)

    查看是否能解决此问题。

    更多信息您可以参见这篇文章:Exchange 2010 Cross-Forest Migration Step by Step Guide – Part I

    (请注意:由于该网站不是由Microsoft托管,因此链接可能会更改,恕不另行通知。Microsoft不保证此信息的准确性)

    此致,

    Kael Yao


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    2020年9月21日 6:44
  • 用的是一个OU,迁移之前和迁移之后,当执行完exchange迁移之后就会在OU下面多了新的 用户,然后后面一堆数字,您看下截图,我迁移用户之前也用了预检测的ps1脚本,用的命令如下:Prepare-MoveRequest.ps1 -Identity tony -RemoteForestDomainController otdc.Contoso.com -RemoteForestCredential $RemoteCredentials -LocalForestDomainController wikidc.wiki.com -LocalForestCredential $LocalCredentials,刚刚执行命令报错了

    2020年9月21日 7:56
  • 您好,

    >>用的是一个OU,迁移之前和迁移之后

    您的意思是用户所在的源服务器的OU和目标服务器的OU是同一个吗?

    我想和您确认的是prepare-moverequest脚本和ADMT指定迁移的OU是否是同一个OU

    因为注意到您运行prepare-moverequest脚本的时候并没有指定OU,这样的话脚本默认会将Disabled账户创建在User这个OU下。

    这可能就导致虽然ADMT成功迁移了该账户,但Exchange相关的属性没有应用于此账户。

     

    此外,根据我的测试,如果AD中已经存在同名但没有Exchange属性的账户的话,重新运行此脚本就会创建一个新的启用了邮箱的账户,并在后面加上数字。因此Get-Mailbox命令中会显示此账户的结果。

    >>刚刚执行命令报错了

    出现此报错的原因应该为该用户的邮箱已经迁移。

     

    建议您尝试在源服务器上重建一个测试邮箱账号,指定Prepare-moverequestADMT迁移的目标OU为同一个。

    查看是否会出现问题。


    此致,

    Kael Yao


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    • 已编辑 Kael Yao 2020年9月23日 6:02
    • 已建议为答案 Kael Yao 2020年9月24日 5:48
    • 已标记为答案 Tony Mu 2020年11月7日 15:13
    2020年9月23日 6:02
  • 您好,

    请问您的问题有最新进展吗?

    如果您对此问题有任何疑问或需要进一步的帮助,请随时回复。

    此致,

    Kael Yao


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    2020年9月28日 2:23
  • prepare-moverequest脚本和ADMT指定迁移的OU是否是同一个OU,我重新建个用户试下,非常感谢您。
    2020年10月29日 7:25
  • 问题解决非常感谢
    2020年11月7日 15:14