none
win7客户端向server2008 写文件无响应 RRS feed

  • 问题

  • Win7Win2008R2的共享目录写入文件时,始终无法结束,也不报错中断,而且无法取消。

    有时复制较少的文件可能会成功,但大多数显示无响应

    服务器权限及容量都没问题

    从共享目录读取文件是正常的,Win7Win2003共享目录写入也是正常的,WinXPWin2008R2写入也是正常的。

    Win7/Win2008的增量差分压缩功能引起的,但我取消掉这个功能,问题依然如故。

    交换机肯定没问题,全部换过,服务器内存也加过,没这个问题

    2012年7月31日 7:07

答案

  • 您好,

    请您尝试以下建议看问题是否解决:

    方法1:

    请您禁用Windows Sever 2008的 SMB V2:

    找到HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Services \ LanmanServer \ Parameters

    加入一个新的REG_DWORD 键值同时命名为 Smb2.
    Value name     Smb2
    Value type     REG_DWORD
    0 =     disabled
    1 =     enabled
    把value设置为0禁用SMB2.

    方法2

    Windows 7 客户端,打开CMD 分别输入:

    netsh interface tcp set global autotuninglevel=disabled

    netsh int ip set global taskoffload=disabled

    方法3:

    使用Robocopy命令行进行文件复制。

    关于Robocopy的使用请参考以下链接:

    http://blog.csdn.net/mutougede/article/details/5691765


    2012年8月1日 9:29
    版主

全部回复

  • Win7Win2008R2的共享目录写入文件时,始终无法结束,也不报错中断,而且无法取消。

    有时复制较少的文件可能会成功,但大多数显示无响应

    服务器权限及容量都没问题

    从共享目录读取文件是正常的,Win7Win2003共享目录写入也是正常的,WinXPWin2008R2写入也是正常的。

    Win7/Win2008的增量差分压缩功能引起的,但我取消掉这个功能,问题依然如故。

    交换机肯定没问题,全部换过,服务器内存也加过,没这个问题

    http://social.technet.microsoft.com/Forums/zh-CN/window7betacn/thread/01e130bb-cb56-4ded-b482-bb760ec36a17

    一模一样的问题,请问怎么解决?

    2012年7月31日 7:24
  • 對於這個問題, 你可以參考一下下面這個帖子

    工作组环境中,Win7访问文件服务器的问题
    http://social.technet.microsoft.com/Forums/zh-CN/window7betacn/thread/15e817ac-f935-493f-b4c7-1afa0a73928d


    Folding@Home

    2012年7月31日 13:36
  • 您好,

    请您尝试以下建议看问题是否解决:

    方法1:

    请您禁用Windows Sever 2008的 SMB V2:

    找到HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Services \ LanmanServer \ Parameters

    加入一个新的REG_DWORD 键值同时命名为 Smb2.
    Value name     Smb2
    Value type     REG_DWORD
    0 =     disabled
    1 =     enabled
    把value设置为0禁用SMB2.

    方法2

    Windows 7 客户端,打开CMD 分别输入:

    netsh interface tcp set global autotuninglevel=disabled

    netsh int ip set global taskoffload=disabled

    方法3:

    使用Robocopy命令行进行文件复制。

    关于Robocopy的使用请参考以下链接:

    http://blog.csdn.net/mutougede/article/details/5691765


    2012年8月1日 9:29
    版主
  • 您好,

    请您尝试以下建议看问题是否解决:

    方法1:

    请您禁用Windows Sever 2008的 SMB V2:

    找到HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Services \ LanmanServer \ Parameters

    加入一个新的REG_DWORD 键值同时命名为 Smb2.
    Value name     Smb2
    Value type     REG_DWORD
    0 =     disabled
    1 =     enabled
    把value设置为0禁用SMB2.

    方法2

    Windows 7 客户端,打开CMD 分别输入:

    netsh interface tcp set global autotuninglevel=disabled

    netsh int ip set global taskoffload=disabled

    方法3:

    使用Robocopy命令行进行文件复制。

    关于Robocopy的使用请参考以下链接:

    http://blog.csdn.net/mutougede/article/details/5691765


    用第二个方法解决了,谢谢
    2012年8月2日 1:27