none
禁用未使用网卡导致的域控器无法正常运行 RRS feed

  • 问题

  • 域架构:单域多站点

    在站点在提升域服务器时,没有将未接线的网卡禁用,提示有动态IP地址是否加域,直接忽略此提示进行提升,提升后如下图所示

    现在安装DHCP服务器后,服务器名一直是169.254,且打开DHCP IPV4作用域时有延迟,如下图

    现在若将另外三个网卡禁用,重启服务器后直接显示无可用网络,如下图

    此时看log有如下显示(ad ds log和dns log)

    如果把下图中红框内网卡解除禁用,即可恢复正常。后两块网卡启用禁用不造成影响。也设置过让“以太网”接线,设置相同IP,“以太网2”禁用。同样的问题。也就是前两块网卡得同时启用才行。

    以上,请问如何操作才能禁用三块未使用的网卡并且让域控器正常运行呢?

    希望有大神能解答,感谢!

    2018年1月31日 2:06

答案

  • 你好!我这几天又进行了一些测试。原文里的那些报错是因为服务器刚启动,有一些服务还没有起来导致的。当那些服务都启动后,便不再报错了。此时,整个域服务器看起来一切正常。日志内也没有相关报错信息。(另外三个网卡已经全部禁用)

    唯一不正常的一点是网络部分应该显示“域网络” 的状态依然显示为 “未识别的网络”。 但这似乎没有造成什么影响。等待数个小时依然如此。 不过如果此时手动点击几次 “网络连接” ,或者点击 “网络状态---共享选项”后,(其余有关网络设置的操作不知道会不会产生这种结果)便会正常显示为“域网络”了。以上操作我测试机过三台服务器,都是如此。这难道是一个BUG?(另外三个网卡已经全部禁用)




    • 已编辑 tycjh 2018年2月3日 9:53
    • 已标记为答案 tycjh 2018年2月5日 16:57
    2018年2月3日 9:49

全部回复

  • 您好,

    基于目前的情况,我想收集更多信息来缩小问题的范围:
    1. 当禁用了另外三块网卡之后,该DC是否能够与其他计算机进行通信(ping)?DNS是否能够顺利解析(nslookup)?
    2. 建议检查看看网卡1和网卡2是否有配置过teaming。
    3. 请问DHCP服务器是否安装在了这台DC上?

    如果需要进一步的帮助,请随时告诉我们。

    此致
    Albert

    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    2018年2月1日 3:22
  • 未安装dhcp服务。

    ping没有问题。

    网卡1和网卡2未进行任何配置。(teaming这个技术我没了解过,是在windows下做的还是?我们系统都是全新安装后之后提升域控器的,未做多余设置

    现在其实服务器有四块网卡,只有一块网卡插了网线。在另外三块未禁用的情况下进行了提升为域服务器的操作,成为域服务器后,如果再禁用掉其他三块网卡,就会出现如上提示报错


    • 已编辑 tycjh 2018年2月2日 4:25
    2018年2月2日 3:58
  • 另 DNS解析也正常
    2018年2月2日 4:24
  • 你好!我这几天又进行了一些测试。原文里的那些报错是因为服务器刚启动,有一些服务还没有起来导致的。当那些服务都启动后,便不再报错了。此时,整个域服务器看起来一切正常。日志内也没有相关报错信息。(另外三个网卡已经全部禁用)

    唯一不正常的一点是网络部分应该显示“域网络” 的状态依然显示为 “未识别的网络”。 但这似乎没有造成什么影响。等待数个小时依然如此。 不过如果此时手动点击几次 “网络连接” ,或者点击 “网络状态---共享选项”后,(其余有关网络设置的操作不知道会不会产生这种结果)便会正常显示为“域网络”了。以上操作我测试机过三台服务器,都是如此。这难道是一个BUG?(另外三个网卡已经全部禁用)




    • 已编辑 tycjh 2018年2月3日 9:53
    • 已标记为答案 tycjh 2018年2月5日 16:57
    2018年2月3日 9:49
  • 您好,

    建议可以尝试禁用启用一下网卡看看问题是否解决。

    此致
    Albert

    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    2018年2月5日 7:56
  • 我今天一共重启17台域控服务器,发现约有1/3的服务器存在这个状况,点击一下网络的图标,就显示成正常的域网络了,不过不管点不点,都没什么报错,暂时先就这样吧。
    2018年2月5日 16:57
  • 您好,

    很高心听到您已经自行解决了这个问题。另外,感谢在论坛中分享您的解决方案,这将有助于任何遇到类似问题的人。

    如果还有什么我们可以为您做的,请随时在论坛发帖。

    此致
    Albert


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    2018年2月6日 6:05