none
Exchange Server 2013 在XP系统上总提示输入密码 RRS feed

  • 问题

  • Hi Team,

    环境:服务器:Windows 2012 STD + Exchange Server 2013

    AD: windows 2012 STD

    客户端:Windows XP PRO + Outlook 2012 pro

    问题:

    使用outlook 2010 Exchange 模式连接Exchange Server 2013服务,使用自动发现是配置成功,但是重新打开outlook客户端是发现提示输入用户名和密码。输入正确用户名和密码不能通过验证,一直提示输入用户名和密码.

    

    尝试操作:

    我在论坛上找到了一些解释说是代理服务器没有指定正确。所以在Exchange Powershell 上输入以下语句指定证书服务器:

    Set-OutlookProvider EXPR -CertPrincipalName:"msstd:mail.kbxdg.com"
    Set-OutlookProvider EXPR -Server mail.kbxdg.com

    但是没吧问题解决。

    请帮忙把这个问题的解决方法提供一下,谢谢!


    Regards, Jason

    2014年10月23日 5:36

答案

  • 建议修改以下注册表

    对于outlook2007修改

    [HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\AutoDiscover]

    "ExcludeScpLookup"=dword:00000001
    "ExcludeHttpRedirect"=dword:00000001
    "ExcludeHttpsAutoDiscoverDomain"=dword:00000001
    "ExcludeHttpsRootDomain"=dword:00000001
    "PreferLocalXML"=dword:00000001
    "ExcludeSrvRecord"=dword:00000001

    2. Uncheck option "only connect to proxy servers that have this principal in there certificate" in connection settings

    对于OS是windows XP 电脑修改:

    1.启动注册表编辑器。为此,请依次单击「开始」、“运行”,在“打开”框中键入regedit,然后单击“确定”。
    2.找到并单击以下注册表子项:HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\LSA
    3.验证注册表值SuppressExtendedProtection和LmCompatibilityLevel是否存在。
    如果这些注册表值不存在,请按照下列步骤创建它们:
    a.在选中了步骤 2 中列出的注册表子项的情况下,指向“编辑”菜单上的“新建”,然后单击“DWORD 值”。
    b.键入SuppressExtendedProtection,然后按 Enter 键。
    c.在选中了步骤 2 中列出的注册表子项的情况下,指向“编辑”菜单上的“新建”,然后单击“DWORD 值”。
    d.键入LmCompatibilityLevel,然后按 Enter 键。
    4.单击以选择SuppressExtendedProtection注册表值。
    5.在“编辑”菜单上,单击“修改”。
    6.在“数值数据”框中,键入0,然后单击“确定”。
    7.单击以选择LmCompatibilityLevel注册表值。
    8.在“编辑”菜单上,单击“修改”。注意此步骤将更改 NTLM 身份验证要求。
    9.在“数值数据”框中,键入3 (启用 NTLM 2 身份验证),然后单击“确定”。
    10.退出注册表编辑器。

    2014年10月24日 6:34

全部回复

  • 你好,

    建议你运行下面的指令检查OutlookAnywhere用到的验证方式:

    Get-OutlookAnywhere |fl Identity,*Authen*

    另外,根据你的描述,你当前的域名应该是KBXDG,那么密码验证框中KBX又是对应的哪个域?

    谢谢!


    Niko Cheng
    TechNet Community Support

    2014年10月24日 6:09
    版主
  • 建议修改以下注册表

    对于outlook2007修改

    [HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\AutoDiscover]

    "ExcludeScpLookup"=dword:00000001
    "ExcludeHttpRedirect"=dword:00000001
    "ExcludeHttpsAutoDiscoverDomain"=dword:00000001
    "ExcludeHttpsRootDomain"=dword:00000001
    "PreferLocalXML"=dword:00000001
    "ExcludeSrvRecord"=dword:00000001

    2. Uncheck option "only connect to proxy servers that have this principal in there certificate" in connection settings

    对于OS是windows XP 电脑修改:

    1.启动注册表编辑器。为此,请依次单击「开始」、“运行”,在“打开”框中键入regedit,然后单击“确定”。
    2.找到并单击以下注册表子项:HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\LSA
    3.验证注册表值SuppressExtendedProtection和LmCompatibilityLevel是否存在。
    如果这些注册表值不存在,请按照下列步骤创建它们:
    a.在选中了步骤 2 中列出的注册表子项的情况下,指向“编辑”菜单上的“新建”,然后单击“DWORD 值”。
    b.键入SuppressExtendedProtection,然后按 Enter 键。
    c.在选中了步骤 2 中列出的注册表子项的情况下,指向“编辑”菜单上的“新建”,然后单击“DWORD 值”。
    d.键入LmCompatibilityLevel,然后按 Enter 键。
    4.单击以选择SuppressExtendedProtection注册表值。
    5.在“编辑”菜单上,单击“修改”。
    6.在“数值数据”框中,键入0,然后单击“确定”。
    7.单击以选择LmCompatibilityLevel注册表值。
    8.在“编辑”菜单上,单击“修改”。注意此步骤将更改 NTLM 身份验证要求。
    9.在“数值数据”框中,键入3 (启用 NTLM 2 身份验证),然后单击“确定”。
    10.退出注册表编辑器。

    2014年10月24日 6:34
  • 那个KBXDG.COM是我外部的域名。内部AD的域名是KBX.LOCAL。

    下面是Exchange Powershell信息截图:


    Regards, Jason

    2014年10月24日 17:28