none
exchange 2010 事件错误 RRS feed

答案

  • 您好,

    从您提供的详细事件日志来看,问题的出现是由于您在运行Test-OutlookWebServices检测Autodiscover时,没有指定Identity这一参数,这时系统会默认寻找"extest_xxx"这个测试账户并填充这个属性。当这个账户或其对应的邮箱不存在时,就会在运行界面上返回报错提示,并生成Event ID 6。

    为了修复这个问题,有如下解决方案:

    1> 检查extest_xxx"这个测试账户是否存在于ADUC-> Users 这个OU中。如果存在,运行Get-Mailbox 查看其对应的邮箱是否存在。如果不存在,运行Enable-Mailbox "extest_xxx" 去启用这个测试账户的邮箱功能。然后重新运行Test-OutlookWebServices命令检查问题是否已经解决。

    2>如果您在ADUC中没有发现这个这个账户(第一次运行这条命令时,该账户是不存在的),也没有查看到其对应的邮箱,我们需要运行new-TestCasConnectivityUser.ps1去创建这个测试账户以及邮箱。具体步骤如下:

    1>打开EMS,输入cd $env:ExchangeInstallPath\Scripts
    2> 输入.\new-TestCasConnectivityUser.ps1并回车运行。
    3> 当收到密码提示时,为这个测试账户设置一个临时密码,此密码会每隔一段时间自动由系统修改。输入完成后,回车继续
    4> 输入Ctrl+Break推出或回车继续。
    5> 重新运行Test-OutlookWebServices命令检查问题是否已经解决。

    以下是测试截图:

    此致,

    Manu Meng


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    • 已标记为答案 Centery 2019年1月2日 8:13
    • 取消答案标记 Centery 2019年1月2日 8:13
    • 已标记为答案 Centery 2019年1月2日 8:14
    • 取消答案标记 Centery 2019年1月2日 8:38
    • 已建议为答案 Manu MengModerator 2019年1月3日 1:50
    • 已标记为答案 Centery 2019年1月3日 2:07
    2019年1月2日 7:16
    版主

全部回复

  • 您好,

    请问您的Exchange 2010 的你具体版本号是多少?

    Get-Command ExSetup | ForEach {$_.FileVersionInfo}

    根据我的经验,这个事件ID可能与安装的三方杀毒软件或者备份软件有关,建议您临时关闭一下,看看Event是否会继续生成。

    鉴于您目前仅提供了Event ID ,不太好进行排错,我们建议您将完整的事件日志发到下一贴中,并注意抹去可能存在的私密信息。

    此致,

    Manu Meng


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    2018年12月27日 7:32
    版主
  • 版本号 

    日志详情 

    2019年1月2日 3:10
  • 您好,

    从您提供的详细事件日志来看,问题的出现是由于您在运行Test-OutlookWebServices检测Autodiscover时,没有指定Identity这一参数,这时系统会默认寻找"extest_xxx"这个测试账户并填充这个属性。当这个账户或其对应的邮箱不存在时,就会在运行界面上返回报错提示,并生成Event ID 6。

    为了修复这个问题,有如下解决方案:

    1> 检查extest_xxx"这个测试账户是否存在于ADUC-> Users 这个OU中。如果存在,运行Get-Mailbox 查看其对应的邮箱是否存在。如果不存在,运行Enable-Mailbox "extest_xxx" 去启用这个测试账户的邮箱功能。然后重新运行Test-OutlookWebServices命令检查问题是否已经解决。

    2>如果您在ADUC中没有发现这个这个账户(第一次运行这条命令时,该账户是不存在的),也没有查看到其对应的邮箱,我们需要运行new-TestCasConnectivityUser.ps1去创建这个测试账户以及邮箱。具体步骤如下:

    1>打开EMS,输入cd $env:ExchangeInstallPath\Scripts
    2> 输入.\new-TestCasConnectivityUser.ps1并回车运行。
    3> 当收到密码提示时,为这个测试账户设置一个临时密码,此密码会每隔一段时间自动由系统修改。输入完成后,回车继续
    4> 输入Ctrl+Break推出或回车继续。
    5> 重新运行Test-OutlookWebServices命令检查问题是否已经解决。

    以下是测试截图:

    此致,

    Manu Meng


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    • 已标记为答案 Centery 2019年1月2日 8:13
    • 取消答案标记 Centery 2019年1月2日 8:13
    • 已标记为答案 Centery 2019年1月2日 8:14
    • 取消答案标记 Centery 2019年1月2日 8:38
    • 已建议为答案 Manu MengModerator 2019年1月3日 1:50
    • 已标记为答案 Centery 2019年1月3日 2:07
    2019年1月2日 7:16
    版主
  • 此事件的执行   “Test-OutlookWebServices”,是系统自动触发的,还是用户请求后触发的。
    对于这个报错,如果我不进行处理,是否会有什么影响?
    2019年1月2日 8:43
  • 此事件的执行   “Test-OutlookWebServices”,是系统自动触发的,还是用户请求后触发的。
    对于这个报错,如果我不进行处理,是否会有什么影响?

    是用户请求后触发的,一般我们手动运行这条命令去检测Autodiscover的设置。另外,这个事件日志是对您运行这条命令失败的记录,如果您不处理这个报错,可能无法运行Test-OutlookWebServices,但不会对Exchange的正常使用造成影响。

    此致,

    Manu Meng


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.


    2019年1月2日 9:31
    版主