none
请大家帮忙?谢谢! RRS feed

  • 问题

  • 大家好,今天出现“未能转换部分或所有标识引用”的故障。
    我试着:启动“SharePoint 产品和技术配置向导”断开也服务器的连接,然后再重新建立一次连接就出现问题了。现在门户主页都打不开了。。。
        通过“SharePoint 产品和技术配置向导”重新连接时出现“配置失败”
    提示:一个或多个配置设置失败。已完成的配置设置将不会回滚。未能设置 SharePoint 管理中心 Web 应用程序。
    已引发类型为 System.ArgumentException 的异常。其他异常信息: 加密或解密过程中出错。系统错误代码 997。
    System.ArgumentException: 加密或解密过程中出错。系统错误代码 997。
    2009年6月1日 5:13

答案

  • 您好!

     

    请问你有没有执行下面的操作?

     

    You install Windows SharePoint Services 3.0 in a stand-alone farm environment. You use the SharePoint Products and Technologies Wizard (PsconfigUI.exe) or Psconfig.exe from the command line to leave the stand-alone farm. Then, you use SharePoint Products and Technologies Wizard or Psconfig.exe from the command line to rejoin the farm.

     

    如果有的话,该问题是由于下面的原因引起的。

     

    This issue occurs if the Network Service account is used as the farm account. In this situation, when you remove Windows SharePoint Services 3.0 from a stand-alone farm, or when you remove SharePoint Server 2007 from a Windows SharePoint Services 3.0 farm environment, the following registry subkey that is used to encrypt passwords that are contained in the Windows SharePoint Services 3.0 configuration database (configdb) is deleted:

    HKLM\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Secure\ FarmAdmin\

    Therefore, when you try to join a Web application that exists in the configuration database that does not use the Network Service account, the Web application account credentials cannot be decrypted. This occurs because the required registry subkey is deleted.

     

    要解决该问题,您需要运行下面的命令来重新创建一个配置数据库。

     

    psconfig -cmd configdb -create -server ServerName -database ConfigDBName -user Domain\User -password Password

     

    详细的信息,请参考下面的链接:

    Error message when you try to use the SharePoint Products and Technologies Wizard: "Exception: System.ArgumentException: Error during encryption or decryption"

    http://support.microsoft.com/kb/927156

     

    Rock Wang 望正茂


    Rock Wang– MSFT
    • 已标记为答案 moss_2007 2009年6月1日 9:29
    2009年6月1日 7:41
    版主
  • 谢谢!!问题找到了,是之前我修改了域密码,连接sqlserver 2005时密码是之前创建的本地密码。

    2009年6月1日 9:30

全部回复

  • 您好!

     

    请问你有没有执行下面的操作?

     

    You install Windows SharePoint Services 3.0 in a stand-alone farm environment. You use the SharePoint Products and Technologies Wizard (PsconfigUI.exe) or Psconfig.exe from the command line to leave the stand-alone farm. Then, you use SharePoint Products and Technologies Wizard or Psconfig.exe from the command line to rejoin the farm.

     

    如果有的话,该问题是由于下面的原因引起的。

     

    This issue occurs if the Network Service account is used as the farm account. In this situation, when you remove Windows SharePoint Services 3.0 from a stand-alone farm, or when you remove SharePoint Server 2007 from a Windows SharePoint Services 3.0 farm environment, the following registry subkey that is used to encrypt passwords that are contained in the Windows SharePoint Services 3.0 configuration database (configdb) is deleted:

    HKLM\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Secure\ FarmAdmin\

    Therefore, when you try to join a Web application that exists in the configuration database that does not use the Network Service account, the Web application account credentials cannot be decrypted. This occurs because the required registry subkey is deleted.

     

    要解决该问题,您需要运行下面的命令来重新创建一个配置数据库。

     

    psconfig -cmd configdb -create -server ServerName -database ConfigDBName -user Domain\User -password Password

     

    详细的信息,请参考下面的链接:

    Error message when you try to use the SharePoint Products and Technologies Wizard: "Exception: System.ArgumentException: Error during encryption or decryption"

    http://support.microsoft.com/kb/927156

     

    Rock Wang 望正茂


    Rock Wang– MSFT
    • 已标记为答案 moss_2007 2009年6月1日 9:29
    2009年6月1日 7:41
    版主
  • 谢谢!!问题找到了,是之前我修改了域密码,连接sqlserver 2005时密码是之前创建的本地密码。

    2009年6月1日 9:30
  • 你重启一下服务器试试
    2009年6月3日 7:39