none
最新的1607版LTSB Windows 10的任务计划是不是有问题?或是创建方式不对? RRS feed

  • 问题

  • 如题,我之前用的是2015版的LTSB Windows 10,导出了任务计划后,全新安装了1607版LTSB Windows 10,然后导入了任务计划,结果发现不执行。我手动点击运行这个任务计划是可以运行的。

    我的任务计划是每隔15分钟执行一次自己写的批处理,相同方法在Windows 7上都是可以运行的。

    于是我怀疑我的电脑有问题,换了办公室的电脑安装了VM虚拟机测试,一个效果。不会自动运行。

    搜索了网上各种方法,如下图,安全选项那里,从默认的administrator的改为SYSTEM账户,更改“不管用户是否登录都要运行”,勾选“使用最高权限运行”,配置那里,选择“Windows 2008 R2”等等,都是无效。

    发不了图,见如下外链,下同。

    https://imgur.com/Xdf7c6H

    时间间隔15分钟的配置,在Windows7和2015版的LTSB Windows 10上也是可用。如下图:

    https://imgur.com/2gzQKr5

    网上还说,起始于那里要填批处理所在路径,也试了,无效,如下图:

    https://imgur.com/uDymlVC

    反复重装了好几次,无解了,是不是2016版的有问题?还是方法不对?

    求解答,谢谢。

    2017年2月7日 0:23

全部回复

  • 您好,

    建议您试试在Windows 10 1607 的版本上重新创建一个 task 测试一下是否可以运行。

    如果不可以的话,输入services.msc打开服务窗口,确保Task schedule service 设置为自动启动并且运行中。

    同时查看event viewer中有什么线索。路径如下:

    Windows Logs\Application, System, Applications and Services\Microsoft\Windows\Task schedule

    如果新的task可以运行的话,说明是你的这个task的问题。重新创建它试试看。

    另外,配置那里,选择“Windows 10“。


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2017年2月8日 6:03
    版主
  • 重新创建过了,系统也是重装过的也不行,甚至重装完什么也不装包括驱动,然后就测试任务计划程序,还是无反应。新建完,手动点击这条任务,点击运行是可以运行的,然后计划条目里也明确有上次运行时间,下次运行时间,都是正确的,但是就是到那个时间了不会自动运行。

    event viewer看了下,好像是整个系统的事件日志吧,太多了,没看出啥来。

    配置那里,也选择“Windows 10“,还是没有效果。

    搞不懂了,谢谢解答,继续求解。

    2017年2月15日 0:35
  • 您好,

    你是否尝试过创建一个不同的简单的task(例如打开cmd.exe), 看看能否运行?

    另外把你的触发条件截图发过来看看有没有什么异常。


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    2017年2月16日 9:42
    版主