Choosing which column is the title when importing a spreadsheet


  • I can import a spreadsheet successfully, but the import seems to randomly choose which column will be the title section in SharePoint. I have 4 columns, Last Name, First Name, Email address, Apartment Number. I want Last Name to be the title section of the SharePoint List but cannot seem to find t a setting to make this happen. The import makes the email address or Apartment number the title section of the list.


    • 已编辑 Mike Walsh FIN 2010年12月17日 15:08 Don't use prefixes - incorporated into a single sentence
    • 已移动 Mike Walsh FIN 2010年12月17日 16:57 (9th today) SP 2010 questions go ONLY to SP 2010 forums (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    2010年12月17日 14:59



  • Go to List view then under colums section order last name column top most (i.e 1)

    So when you export list to excel Last name will be in the title

    Regards, Pratik Vyas | SharePoint Consultant |
    2010年12月17日 15:16
  • Export from the list completed successsfully.
    When I try to import the spreadsheet into a list in Sharepoint 2010 for some reason it makes the email address the title column and not the last name.


    2010年12月17日 16:42
  • > When I try to import the spreadsheet into a list in Sharepoint 2010

    Why, if you have SP 2010, did you post your question in a pre-SP 2010 forum?

    Naturally answers here assume that you have a SP 2007 product unless 2003 or 2001 is stated.

    Moderator - moving to a SP 2010 forum)

    SP 2010 "FAQ" (mainly useful links):
    WSS3/MOSS FAQ (FAQ and Links)
    Both also have links to extensive book lists and to (free) on-line chapters
    2010年12月17日 16:55
  • Hello,


    In my case, it takes the first column from left e.g. “AA” as the field named “AA(linked to item with edit menu)” and leave the Title filed as blank. For your scenario, I think you can rename the field name in Excel to be Title before importing the file to SharePoint list. For detailed instructions, please see:


    Thanks & Regards.

    Lily Wu
    • 已标记为答案 Lily Wu 2010年12月27日 14:04
    2010年12月24日 8:52
  • Did you ever find a fix for this?  I'm having the same problem, my spreadsheet is larger (A1-AR233) but SharePoint keeps making column D the title.
    2010年12月29日 17:39
  • It's been a while since this post but I also had this problem and couldn't find the answer online.  It seems like sharepoint will use the first column that it detects as type 'Single line of text'.  I had this problem when trying to copy a list via a spreadsheet.  Even though the original version was single line text, on importing sharepoint would convert it as 'Multiple lines of text'.  I'm not sure of the logic it uses to make that distinction but in my case deleting a space from one of the cells made the difference.  If you try to use the 'Export Table to sharepoint list' function in excel (2010 in my case but I think it's in 2007 too) then it will indicate the key cell it is making the decision based on.

    Note I'm using sharepoint 2007 here.


    2011年2月25日 10:51
  • Hi,

    This answer is not correct. There is no rhyme nor reason as to which column is selected to be the 'title' column.


    2011年11月14日 16:11
  • Hi ,

    i know the thread must have expired but wanted to share this information

    I found the best solution -

    What happens is when we import the Spreadsheet it renames the title column at times and on which the edit item is linked to and by default the edit item is only linked to the title column .

    This would work for limited amount of columns and items

    you can create a custom list . a blank one

    in which you will see only a title column - avoid renaming that column i would sugest never do that

    Then click on edit is datasheet view .

    if you can keep the same name title copy the contents below the column which you want to have it linked to edit

    then create the other columns with the right options and then copy paste one column at a time in the list .

    And there you go you will have the edit linked to the right column .

    Regards - Sushant Khambekar - MCTS Please Mark As Answer if my post solves your problem or Vote As Helpful if a post has been helpful for you. Sharepoint Admin - Moss 2007 , Sharepoint 2010

    2012年7月2日 5:05