none
Microsoft .NET Framework for XP 的安装 RRS feed

  • 问题

  •  

    Microsoft .NET Framework  2.0  到底 包不包括了 Microsoft .NET Framework 1.1。我在网上查了半天。两种说法都有。一种说包括了。只要装2.0就可以。另一种说法是两个都要安装。请问是不是两个都要安装?

    2008年5月6日 6:48

答案

  • 2.0的winform程序如果不使用2.0中的新控件,确实可以使用1.1来代替。但是如果2。0的程序使用了新控件就不能正常运行了,比如backgroundprocess控件,建议还是都装为好。

     

    2008年5月6日 10:37

全部回复

  • 2.0不包含1.1, 如果要用1.1的程序, 需要单独安装1.1, 如果都要用就都需要安装.

    2008年5月6日 6:50
  • 如果是1.1下开发的winForm应用程序,只装1.1或者2.0就可以了,如果你想在你的机器上部署WEB应用程序的话就要安装相应版本的Framework.

    2008年5月6日 9:09
  • 2.0的winform程序如果不使用2.0中的新控件,确实可以使用1.1来代替。但是如果2。0的程序使用了新控件就不能正常运行了,比如backgroundprocess控件,建议还是都装为好。

     

    2008年5月6日 10:37
  • 不同版本的 .net Framework 不是向下兼容的关系,不是安装了新版本就可以取代旧版本了,而是新旧版本可以共存。

     

    2008年5月6日 13:02
    版主
  •  

     

    Microsoft .NET Framework 2.0 是在 Microsoft .NET Framework 1.0 和 1.1 成功的基础上构建的。对于 .NET Framework 1.1 应用程序,Microsoft 的兼容性目标是:这些应用程序能够在 .NET Framework 2.0 上顺利运行(除一组记录在案的更改之外)。

     

     

    虽然微软已尽力使 .NET Framework 版本具备兼容性,但仍发现由于增加安全性和重要功能而存在个别不兼容的情况,所以有时还是要安装 .NET Framework 1.1 。

     

     

    2008年5月7日 8:33