none
安装vista后,我每次开机都找不到网卡驱动 重启后又能恢复正常 RRS feed

  • 问题

  • 安装vista后,我每次开机都找不到网卡驱动
    在网络适配器里也找不到Realtek RTL8101E Family PCI-E Fast Ethernet NIC (NDIS 6.0)这一项。
     必须重启后才能显示和链接到网络,我重装过好多次驱动,可问题还是存在,想请教专业人士,这问题如何解决?

    附:此问题我早些时候就提出来,中间有一段时间电脑突然正常了,现在老问题有来了。



    这是‘远程访问诊断报告’报告里有关realtek网卡的信息,我截了下来,希望对各位有帮助。
                  .............
                  .............
                  .............

    【注册表检查】[目录]
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0004]
    "NewDeviceInstall"=dword:00000000
    "NetCfgInstanceId"="{375ABE6F-9D6D-4E9B-BDC6-8294EC696554}"
    "*IfType"=dword:00000006
    "Characteristics"=dword:00000084
    "*MediaType"=dword:00000000
    "*PhysicalMediaType"=dword:00000000
    "NetLuidIndex"=dword:00000005
    "*SpeedDuplex"="0"
    "*FlowControl"="1"
    "*PriorityVLANTag"="3"
    "*InterruptModeration"="1"
    "*ReceiveBuffers"="512"
    "*TransmitBuffers"="128"
    "BusType"="5"
    "ComponentId"="pci\\ven_10ec&dev_8136&subsys_0560107b&rev_01"
    "InfPath"="oem1.inf"
    "InfSection"="RTL8136.ndi"
    "InfSectionExt"=".NT"
    "ProviderName"="Realtek"
    "DriverDateData"=hex:00,80,80,09,92,7a,c9,01
    "DriverDate"="1-20-2009"
    "DriverVersion"="6.216.120.2009"
    "MatchingDeviceId"="pci\\ven_10ec&dev_8136&subsys_0560107b&rev_01"
    "DriverDesc"="Realtek RTL8101E Family PCI-E FE NIC"
    "ForceMode"="0"
    "WolShutdownLinkSpeed"="0"
    "WolCap"="3"
    "*IPChecksumOffloadIPv4"="3"
    "*TCPChecksumOffloadIPv4"="3"
    "*UDPChecksumOffloadIPv4"="3"
    "*LsoV1IPv4"="1"
    "S5WakeOnLan"="1"
    "AutoLinkDownPcieMacOff"="0"
    "EnumPropPages32"="rtnicprop32.dll,RTNicPropPageProvider"
                                ...
                                ...
                                ...

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0033]
    "NewDeviceInstall"=dword:00000001
    "NetCfgInstanceId"="{CE428203-3ED4-4212-AE3B-63F8A80CEDE7}"
    "*IfType"=dword:00000006
    "Characteristics"=dword:00000084
    "*MediaType"=dword:00000000
    "*PhysicalMediaType"=dword:0000000e
    "NetLuidIndex"=dword:00000006
    "*SpeedDuplex"="0"
    "ForceMode"="0"
    "*FlowControl"="1"
    "*PriorityVLANTag"="3"
    "*InterruptModeration"="1"
    "*ReceiveBuffers"="512"
    "*TransmitBuffers"="128"
    "WolShutdownLinkSpeed"="0"
    "WolCap"="3"
    "*IPChecksumOffloadIPv4"="3"
    "*TCPChecksumOffloadIPv4"="3"
    "*UDPChecksumOffloadIPv4"="3"
    "*LsoV1IPv4"="1"
    "S5WakeOnLan"="1"
    "AutoLinkDownPcieMacOff"="0"
    "EnumPropPages32"="rtnicprop32.dll,RTNicPropPageProvider"
    "BusType"="5"
    "ComponentId"="pci\\ven_10ec&dev_8136&rev_01"
    "InfPath"="oem1.inf"
    "InfSection"="RTL8136.ndi"
    "InfSectionExt"=".NT"
    "ProviderName"="Realtek"
    "DriverDateData"=hex:00,80,80,09,92,7a,c9,01
    "DriverDate"="1-20-2009"
    "DriverVersion"="6.216.120.2009"
    "MatchingDeviceId"="pci\\ven_10ec&dev_8136&rev_01"
    "DriverDesc"="Realtek RTL8101E Family PCI-E FE NIC"

         ....................................
         ....................................
         ....................................
         ....................................

    "Realtek RTL8101E Family PCI-E FE NIC"=hex(7):31,00,00,00,00,00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\{0DD45C1C-6A8B-4A5F-A8BB-C689216F61F2}]

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\{0DD45C1C-6A8B-4A5F-A8BB-C689216F61F2}\Connection]
    "DefaultNameResourceId"=dword:00000709
    "DefaultNameIndex"=dword:00000003
    "Name"="本地连接* 3"

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\{375ABE6F-9D6D-4E9B-BDC6-8294EC696554}]

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\{375ABE6F-9D6D-4E9B-BDC6-8294EC696554}\Connection]
    "PnpInstanceID"="PCI\\VEN_10EC&DEV_8136&SUBSYS_0560107B&REV_01\\4&37104257&0&00E0"

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\{7FBB74F2-8FAB-462F-806C-6D2170D0CE5F}]

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\{7FBB74F2-8FAB-462F-806C-6D2170D0CE5F}\Connection]
    "DefaultNameResourceId"=dword:0000070e
    "DefaultNameIndex"=dword:00000000
    "Name"="无线网络连接"
    "PnpInstanceID"="PCI\\VEN_8086&DEV_4222&SUBSYS_10028086&REV_02\\4&24F7F99B&0&00E1"
    "MediaSubType"=dword:00000002

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\{C16D3CAF-6C55-4A2D-94BC-53D781BFC328}]

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\{C16D3CAF-6C55-4A2D-94BC-53D781BFC328}\Connection]
    "DefaultNameResourceId"=dword:00000709
    "DefaultNameIndex"=dword:00000004
    "Name"="本地连接* 4"

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\{CDBFF130-A9A0-44F8-A409-92FF6B889E3E}]

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\{CDBFF130-A9A0-44F8-A409-92FF6B889E3E}\Connection]
    "DefaultNameResourceId"=dword:00000709
    "DefaultNameIndex"=dword:00000000
    "Name"="本地连接*"

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\{CE428203-3ED4-4212-AE3B-63F8A80CEDE7}]

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\{CE428203-3ED4-4212-AE3B-63F8A80CEDE7}\Connection]
    "DefaultNameResourceId"=dword:0000070b
    "DefaultNameIndex"=dword:00000000
    "Name"="本地连接"
    "PnpInstanceID"="PCI\\VEN_10EC&DEV_8136&SUBSYS_812910EC&REV_01\\4&37104257&0&00E0"
                          .................................
                          .................................
                          .................................
                          .................................

    系统信息报告


    [组件]

     

    [多媒体]

                 ..............
                 ..............
                 ..............
                 ..............

    名称 [00000004] Realtek RTL8101E Family PCI-E FE NIC 
    适配器类型 不可用 
    产品类型 Realtek RTL8101E Family PCI-E FE NIC 
    已安装 是 
    PNP 设备 ID 不可用 
    上次重置 2009/8/20 11:15 
    索引 4 
    服务名称 RTL8169 
    IP 地址 不可用 
    IP 子网 不可用 
    默认 IP 网关 不可用 
    DHCP 已启用 是 
    DHCP 服务器 不可用 
    DHCP 租约过期的时间 不可用 
    DHCP 获得租约的时间 不可用 
    MAC 地址 不可用 
                      .........
                      ........ 
                      .........
                      .........

    名称 [00000033] Realtek RTL8101E Family PCI-E FE NIC 
    适配器类型 不可用 
    产品类型 Realtek RTL8101E Family PCI-E FE NIC 
    已安装 是 
    PNP 设备 ID 不可用 
    上次重置 2009/8/20 11:15 
    索引 33 
    服务名称 RTL8169 
    IP 地址 不可用 
    IP 子网 不可用 
    默认 IP 网关 不可用 
    DHCP 已启用 是 
    DHCP 服务器 不可用 
    DHCP 租约过期的时间 不可用 
    DHCP 获得租约的时间 不可用 
    MAC 地址 不可用 
                            ............
                            ............
                            ............


    [系统驱动程序]

    名称 描述 文件 类型 已启动 启动模式 状态 状况 错误控制 接受暂停 接受停止
    rtl8169 Realtek 8169 NT Driver c:\windows\system32\drivers\rtlh86.sys Kernel Driver 否 Manual Stopped OK Normal 否 否
                                      ....................................
                                      ......................................
                                      .......................................

    • 已更改类型 tigken 2009年8月20日 4:35 安装vista后,我每次开机都找不到网卡驱动 重启后又能恢复正常
    • 已编辑 tigken 2009年8月20日 4:48
    2009年2月25日 5:13

全部回复

  • 楼主请连接以下Realtek网站下载今年2月5日For VISTA的最新版本:

    http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=3&PNid=14&PFid=7&Level=5&Conn=4&DownTypeID=3&GetDown=false
    Zhou Cony
    2009年2月25日 8:16
    版主
  • 更新下网卡驱动试试吧。http://drivers.mydrivers.com/drivers/238-95281-Realtek-RTL8100E-RTL8101E-RTL8102E-GR-PCI-E-6.210-For-Vista-Vista-64/
    2009年2月25日 8:20
    版主
  • 我按楼上的方法做了,可问题还是没有解决,我怀疑问题还是出在操作系统上,之前我也在网上查了,发现也有人出现过和我类似的情况,他们好像都是通过下载vista更新解决的。
    我再仔细描述一下我遇到的情况,就是只要是关机后开机,都会出现在“网络适配器”选项里找不到网卡驱动程序。链接到网络便会提示“找不到网卡”。
    但凡是只要重启计算机,问题都解决了,网卡驱动程序在了,也能正确上网。也就是说我如果要上网使用计算机的话,必须先开机,再重启。无论如何,感谢楼上的回答,希望高手能指点迷津!
    2009年2月25日 13:29
  • 排错恶意程序卸载网卡驱动 请执行以下步骤:

    首先在本机建立一个系统还原点! 

    请在出现问题的客户端上执行一次clean boot。

    a. 运行MSCONFIG。

    b. 在常规下选择 选择性启动。

    c. 然后清除Process System.ini File, Process Win.ini File和Load Startup Items 的复选框,但是保留使用原始Boot.ini。

    d. 在服务下,先点隐藏所有windows 服务,然后选择 disable all.

    e. 然后重新启动。观察问题是否依旧发生。

    找不到网卡的错误后在控制面板-设备管理器看是否有黄色感叹号设备出现!

    如果问题没得意解决,不是笔记本的前提下,尝试更换一个网卡!


    Microsoft Certified Systems Engineer 如果您觉得对您有帮助,请在“是否有帮助”点“是”;如果你觉得回复很满意,请“标记为已解答”
    2009年2月26日 5:07
  • 我按楼上的方法试了下,但还是没解决问题,重启后是能找到网卡驱动的,但是休眠,睡眠或开机都找不到驱动程序,而且我用的是笔记本,刚买没多久,系统是vista ulitimate sp1
    2009年2月26日 12:22
  • 有高手能解决吗
    2009年2月28日 12:38
  •  更新主板BIOS
    2009年3月1日 7:42
  • 这和主板bois有关系吗?

    • 已标记为答案 tigken 2009年3月3日 13:50
    2009年3月3日 13:48
  •   如果在控制面板里都找不到硬件的话,首先要确定你的网卡是没有接触不良的情况,然后在控制面板里找到添加新硬件,找到网络适配器,为其添加新的驱动,注意你使用的是vista操作系统,一定要为其找到合适的驱动程序!!
    2009年3月7日 11:57
  • 虽然问题不大,但每次重启也很麻烦的

    2009年8月20日 4:51
  • 建議找一張可以支持網絡功能的 Windows PE 啟動盤, 看在那裏面能夠找到網卡.
    還有你是否安裝了同網絡相關的筆記本廠商自帶軟件? 如果有請暫時卸載, 如果你沒有這些軟件的原始安裝文件, 請在卸載前, 咨詢筆記本廠商售後.
    Folding@Home
    2009年8月20日 4:57
  • 这个问题是自新机以来就出来的吗?是否更改过BIOS设置,如果有,尝试将设置还原成默认状态,然后重新安装你的网卡看看.
    2009年8月20日 5:36
  • 我照楼上的两位做了,可还是不行,笔记本出厂时就装好系统了,没有这个问题,后来我又重装了系统和随机软件,之后就装了一些stardock公司的deskscapes和object desktop,还有些360卫士之累的软件。然后用无线网卡上了几次网,问题就出现了,具体情形我也不记得了。哦,对了,我的主板是phoenix Trusted(tm)。bios启动项选择里好像有个boot to lan:realtek boot agent一项,不知和这个问题有关吗?而且重启比开机速度要快,而且每次重启是一定能在设备管理器里找到网卡的(一个是intel的无线网卡,还有就是realtek的网卡,而第一次开机就只有intel的无线网卡)

    2009年8月21日 4:12
  • 這樣你通過 控制面板 - 网络和 Internet - 网络连接 選 中realtek 網卡 - 鼠標右鍵 - 彈出上下文菜單 - 選擇 "屬性(R)" - 在彈出對話框中查看有無第三方的項目, 如果有暫時去掉其複選框, 然後單擊 "確定" 按鈕.

    注:
    1. 此方法假設是軟件原因導致的錯誤.
    2. 此方法是手動進行屏蔽, 如果該項可以通過自己的軟件進行設置, 那么請直接使用軟件進行.

    相關截圖:


    Folding@Home
    2009年8月21日 4:31
  • 建议你先卸载杀软和其它带虚拟驱动的应用程序,然后在设备管理器中,卸载网络适配器下所有设备,再重新启动计算机,然后安装你的网卡驱动看看.

    2009年8月21日 4:39
  • 是不是这个啊,
    到底哪些是第三方软件,我也不清楚,你帮我分析下吧








    • 已编辑 tigken 2009年8月22日 8:22
    2009年8月22日 8:01
  • 第三個鏈接是不是把第二個給複製下來了?


    Folding@Home
    2009年8月22日 8:04
  • 没有啊,截图中“此链接使用下列项目(0)”窗口下的内容无法用一个截图,就用来两个
    2009年8月22日 8:25
  • 那裏面沒有第三方的項目.
    Folding@Home
    2009年8月22日 8:27
  • 昨天又重装了一遍驱动,用的是zol网站提供的http://driver.zol.com.cn/detail/38/373716.shtml
    今天两次开机都还算正常,我也不清楚以后电脑还会不会旧病复发。


    和以前装大驱动不一样
    我在设备管理器里查了下
    这个驱动多了2文件






    • 已标记为答案 tigken 2009年8月22日 8:52
    • 取消答案标记 tigken 2009年8月22日 10:48
    2009年8月22日 8:41
  • 恩, 多觀察一段時間吧.

    Good Luck!
    Folding@Home
    2009年8月22日 8:42
  • 问题又来了,这次是开了3d梦幻桌面,然后关机,再开机,老问题又出现了。我的电脑有两种梦幻桌面,一种是windows系统里的mpg与wmv格式。还有就是靠stardock 的deskcapes运行的Dream格式的梦幻桌面文件





    2009年8月22日 11:02
  • 試試進入系統後, 不啟動 "夢幻桌面", 雖然覺得兩者關聯不大.
    Folding@Home
    2009年8月22日 11:28
  • 恩,不过没了这功能,vista就没什么吸引力了!

    2009年8月22日 11:41
  • 也不會, 那我用 Home Basic 豈不是要淚奔?


    Folding@Home
    2009年8月22日 11:45
  • 哦,对了,不是每次开机都找不到网卡吗,我就重装了网卡驱动,但跳出这样条消息:
    The Realtek Network Controller was not found.
    If Deep Sleep Mode is enabled Please Plug the Cable
    我实在不懂什么意思,到网上查了一下,情况都差不多,都是些老外的网站,也没提供具体的办法,可能我英语水平不行吧,反正看不懂。http://forums.tweaktown.com/f69/lan-controller-ex58-ud4-gone-33016/
    http://www.sevenforums.com/network-internet/19488-no-ethernet-controller-no-internet-connection-5.html

    麻烦高手想想办法?

    2009年8月25日 10:17
  • 兄弟 你新买的笔记本 遇到质量问题 最好去找卖商解决
    2009年8月25日 13:24
  • 看了你貼的鏈接, 感覺硬件自身可能存在某種問題.
    Folding@Home
    2009年8月26日 1:21
  • 你好。我来晚了。

     

    现在是 2011年了 。。。晚了2年啊。

     

    因为。。。。。。。。。。。我也遇到了完全一摸一样的问题!!!!!!!!!!!

    我的也是刚买来就这样,

    我换了驱动,没用

    我换了网卡,没用

    我更新了BIOS,没用

    我换了系统,没用

    我插拔了,没用

    我青灰了,没用,

     

    初步认为是主板的问题,我的主板是华擎的。

     

     

     

    2011年6月5日 1:31
  • 有可能是软件和硬件的兼容性问题,建议更新一下驱动程序。
    2011年6月30日 1:41
  • 更新一个网卡驱动试一试
    2011年8月25日 6:13