none
win10无法访问Samba共享文件夹 RRS feed

  • 问题

  • 我现在用一台装有ubuntu14.04系统的电脑做Samba服务器, 配置好后在内网内进行测试发现win7, win10都能连接共享文件夹. 但是把Samba服务器连入公网后在同一网段进行测试, win7可以连接共享文件夹, 用win10连接会弹出"windows无法访问\\ip, 请检查名称的拼写, 否则, 网络可能有问题. 要尝试识别并解决网络问题, 请单击"诊断".

    我按照网上的一些方法对win10进行了修改, 比如修改注册表, 关闭防火墙, 添加协议, LAN 管理器身份验证级别等等, 都不能解决, 请问有没有其它可能的解决办法?

    2016年9月1日 13:57

答案

  • 你好:

    这台Windows 10 可以访问其他机器的共享文件吗?可以ping 通吗?

    检查一下你的Samba 是否配置了SMB3.0 协议.

    尝试一下命令行,强制windows 10 使用SMB 1.0 协议访问共享文件夹.
    sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
    sc.exe config mrxsmb20 start= disabled

    重新启用:
    sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
    sc.exe config mrxsmb20 start= auto


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    2016年9月2日 3:03
    版主

全部回复

  • 你好:

    这台Windows 10 可以访问其他机器的共享文件吗?可以ping 通吗?

    检查一下你的Samba 是否配置了SMB3.0 协议.

    尝试一下命令行,强制windows 10 使用SMB 1.0 协议访问共享文件夹.
    sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
    sc.exe config mrxsmb20 start= disabled

    重新启用:
    sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
    sc.exe config mrxsmb20 start= auto


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    2016年9月2日 3:03
    版主
  • 你好:

    请问问题解决了吗?还需要什么帮助吗?


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    2016年9月16日 9:38
    版主