none
I am an Administrator, but I keep getting errors like, "You require permission from Administrators to make changes to this file."

    问题

  • I have run into this more than once before, and I'm looking for a straight answer as to why this is happening.

    There is an avi file in C:\some folder, and I can't rename it.  The message is, "You require permission from Administrators to make changes to this file."  The problem is that I am using an administrator account, and when I look at the permissions for that file, Administrators is granted Full control.  (I don't know whether an administrator account implies membership in the Administrators group in Windows 7, but I am in that group, in this case).

    I also saw that Everyone had Read and Read & Execute permissions, so I tried just granting that group Full control.  This just gave the error message, "Unable to save permission changes on 3441.avi.  Access is denied."

    I just want to get an authoritative answer on why this happening and on how to fix it.  Thanks.

    Edit:

    I am able to access that file with user Administrator, but not with my own personal Administrators account.  I tried using Administrator to explicitly add my personal account to the permissions for the file, granting it Full control, but I am still unable to use the personal account to change the file; only Administrator works.

    • 已编辑 Panzercrisis 2014年5月12日 13:18 more information
    2014年5月12日 13:15

答案

全部回复

  • Hello, 1. Are you accessing the path in witch the file is located by by UNC-path like \\servername\c$\test.avi or are you just accessing the file from the local path like C:\test.avi 2. If you click the file while holding down SHIFT-key and right clicking the file choose run as administrator and see what happens 3. Who is the owner of the file?
    2014年5月12日 15:49
  • While assigning permissions, was your user account added to the ownership of the folder?

    Assigning permissions to full control alone does not work in all cases.


    Balaji Kundalam

    2014年5月13日 3:35
  • Hi,

    This situation happens because you are not the owner of this folder of file, The default owner of a file or folder is the person who creates the resource.

    Log on the computer with the account which created the folder of file, namely the owner, then you are permitted to modify the file or folder.

    Also, you can follow this article to assign ownership of files and folders:

    http://technet.microsoft.com/en-us/magazine/ff404240.aspx
    2014年5月13日 8:13
  • The issue is with UAC.

    You can disable the UAC feature that triggers this.

    Start---run---gpedit.msc

    Computer Configuration -- windows settings --Security Settings -- Local Policies -- Security Options

    Scroll down to:

    User Account Control: Run all administrators in Admin Approval Mode - Set to DISABLED.

    Reboot.

    Done.

    2015年4月15日 15:47
  • I simply change the file's directory; for example move the file or folder you need to modify to Documents Library and then rename it. After that, move it again.
    2015年9月29日 11:28
  • i set my User Account Control: Run all administrators in Admin Approval Mode - to DISABLED and i am still getting the "you'll need to provide administrator permission to delete this file" when i am trying to delete folders, or files. also my user account settings is set to "never notify". this is driving me nuts trying to delete my windows files from my windows 7 installation from a secondary drive that i had to replace because somehow my windows installation got corrupted and would not start or repair. what is this? apple? microsoft doesnt need to protect me from myself, if i needed someone to hold my hand, i would have gotten a mac.
    2015年10月30日 19:56
  • I love that the only answer is to violate the security model that this feature is set to protect.
    2016年3月3日 17:01
  • The solution to this problem is by allowing/enabling "inheritance" in the security options of the folder and replacing all subfolders security permissions from the parent folder and taking the ownership in group or user level. If inheritance is disabled, and even the administrator is administrators group, it does not imply that subfolders also have same security settings. For me this resolved the problem, may be someone else will benefit from this fix.
    2016年3月6日 18:35
  • Turn off the preview pane in windows explorer - this causes the file to be locked.

    2016年3月18日 5:03
  • I found that my problem ended up being to do with Google Drive.

    I was trying to clear some tmp files and it wouldn't let me remove them, no matter what I tried.

    It didn't take me long to realise I could just open the web interface of Drive and delete the folder, and Google synced the delete across my multiple systems. The file was created/synced by my laptop so there was no user on my current system (except Google, essentially) that would ever have permission to delete it.

    2016年5月17日 3:00
  • Just rename the file and Delete it...Simple as that...

    • 已建议为答案 Nicster205 2018年2月20日 21:49
    2016年10月3日 12:38
  • ( typo in my user name btw..) I tried that run command and windows couldnt find it.

    2016年10月25日 22:39
  • Just rename the file and Delete it...Simple as that...

    Didn't work for me. In my case it was a rebuilt computer with the hard disk taken from the original build. Even taking ownership of the folder doesn't seem to work.


    Dave


    • 已编辑 mfr28 2016年11月6日 23:44
    2016年11月6日 23:42
  • I've seen this answer many times, so it must have some merit to it.

    What I would like to know is--what if the OWNER (me) creates the folder/file--but STILL receives this message?

    What excuse could there be, then?  

    It certainly couldn't be true that I am NOT the owner of the folder/file--if I am the one that actually creates it--right?  (Unless it's possible for someone to create a folder/file--yet NOT be the owner!)

    So, I (the owner of not only the folder/file--but also the machine!!!), am NOT able to effect any changes to my folder/file, even if I create it (and YES--I AM an administrator)--unless I receive permission from...wait for it...MYSELF!!!!

    2016年11月17日 11:54
  • ...what if it's ALREADY disabled?
    2016年11月17日 12:24
  • Thanks, the inheritance fix worked for me!  
    2016年12月31日 17:55
  • For me the problem was caused by the fact that I wasn't owner of the source file.

    This was NOT a problem at the destination folder level.

    It was a disk just attached to that server, that came from another VM.

    Hope that helps

    2017年3月7日 10:12
  • I am currently having the same problem as the guy is, but in my case, I AM using the account that was used to download this file, which is also the administrator, yet I am not allowed to delete this file. Could you help?
    2017年3月13日 12:21
  • This is my own PC, I own and am in complete control of every single thing on this PC, and it tells me I require permission from Administrators to make changes or access this file. WHY?! MY ACCOUNT IS THE ONLY ACCOUNT ON THIS PC!! I AM THE ONLY, FULL, COMPLETE ADMINISTRATOR OF THIS PC!!!!!
    2017年3月15日 22:18
  • anyone find a fix for this yet? I have tried all the suggestions here.  I created the files. The owner was Administrators, which I am but I still decided to try making myself the owner.  The only thing that changed is the error.  Now the error says I need permission from myself instead of administrators. 
    2017年3月30日 9:40
  • i Solved it. Here it's How :

    right click on the folder then ( secuirty ) , ( Advanced ) then you will see the name of the owner and ( Change )

    Click Change then ( Advanced ) Then Click ( Find Now )  And change it to ur Admin Account. The only account u Use.
    Then Mark The Box ( Replace owner on Subcontainers and objects )

    Then you MUST CLICK ( Enable inheritance )

    And Mark The box Under-it. then ok and apply. and now delete the file

    2017年4月1日 22:26
  • BEFORE YOU BEGIN: Remember to never, ever let anything to do with computers cause you to compromise your peace of mind, let alone your sanity. No, keep the insanity at its source - where it originates: with the programmers and coders of the operating systems and software we are all essentially forced to use and/or have our lives interface with and, unfortunately, come to rely and depend upon.
    2017年4月6日 21:14
  • NONE of the above solutions work for me.  I've got an unwanted "backup" file created by Paint.net that I cannot delete, move, rename, or open because I "don't have permission."

    Mine is THE administrator account on this machine; the ONLY account on this whole bloody machine!  When I first set it up, I disabled that crap UAC so I shouldn't even be experiencing the slightest bit of file permission management.

    If I try to change permissions via file properties, all I get is "You do not have permission to view or edit this object's permission settings."

    While I'm flying off the deep end about this, let me tell you what else about this whole experience is pushing me off the edge right now:

    I had to log into my rarely used hotmail account to comment here, and I was told that my account had been suspended for sending out craptons of junk mail.  I had to get a reactivation code sent to my phone to log in (it prompted me for the phone number), and then yet ANOTHER code had to be sent to me to view my "recent activity," but this time I had to confirm the secret phone number before they would send the code out.   Sounds real secure, Microsoft!  The recent activity?  ABSOLUTELY NO HISTORY ON FILE.

    Meanwhile, I've got a "featured message" in my inbox which is a phishing scam posing as Paypal.  That right there is some really effective and reliable detection of incoming scams and outgoing spam activity!


    2017年6月6日 21:27
  • I struggled to delete a system folder (inside windows folder) I'm login as admin, but when when I set the folder ownership as admin, and apply the ownership to subfolders ('inheritance') I got the **"Failed to enumerate objects in the container. Access is denied"**. It should have worked but no, I guess it's a windows 10 bu. I finally made it by changing the folder ownership to the basic user, then apply it to subfolder and it works. I'm not shure but if you encouter the "Failed to enumerate objects..." I suggest you apply first the ownership as admin (and try it), then apply it to (non admin) "users", (and try it again). It's possible that changing the ownership 2 times soved a bug.
    2017年7月2日 15:49
  • My situation is much like many of the reports above. I am using Windows 10 Pro, Version 1607, OS Build  14393.1358.  I am the only user of the system using a local account that had Administrator rights, verified. 

    One manifestation of the problem: There is a shortcut on the desktop. I want to rename it.  When I try to rename the shortcut I get a box that says "You'll need to provide administrator permission to rename this file".

    The desktop is MY desktop, located in C:\Users\MyName.  When I check the Properties, Security tab for the Desktop all the permissions are checked for me (MyName (ComputerName\MyName)) and for Administrators (Administrators (ComputerName\Administrators).  All the Allow items are checked for both my name and Administrators for the Deskop.  From everything I can gather those all mean I should be able to do anything on the Desktop without further permissions.

    I checked the Properties, Security tab for the shortcut itself, it is all exactly the same as I described for the Desktop.  I have all rights.  I am the owner.  I can not rename it because I "need to provide administrator permission".  Or so it tells me.


    2017年7月8日 17:44
  • Come to think of it--ALL windows-based machines should come with a disclaimer:

    "Caution!  Continued use of the windows operating system WILL cause side effects such as: loss of peace of mind, loss of sanity, high blood pressure, extreme confusion and highly-aggressive behavior.  Consult your therapist before use."

    2017年7月9日 12:17
  • I get the same nonsense. More unnecessary "security" from Microsoft. Tried various solutions and they DO NOT WORK. Things like "Trusted Installer" are totally unnecessary for private use

    2017年8月4日 20:46
  • You´re exactly right. I have assigned full ownership and still get these ridiculous messages

    2017年8月4日 20:48
  • doesn't work
    2017年8月4日 20:50
  • Dude... you can't rename it if you don't have permissions

    2017年8月9日 17:49
  • I had a process that was "holding" the folder and got the same error. When I killed it with task manager I managed to delete the folder. Hope it helps someone! :)
    • 已建议为答案 Tyler Tran 2018年6月21日 0:23
    2017年8月16日 11:56
  • This worked great! Even after taking ownership of the folder (SoftwareDistribution for windows update issues) it still would prompt me to get permission...from my self. After the GPO edit I was able to edit the folder.

    Thanks again!

    2017年8月30日 16:43
  • I struggled with an issue similar to this for a while, but mine wouldn't allow me to delete a folder that I had created myself because I "needed permission from (myself)". Eventually, what worked for me was selecting the "Shred" option from the right-click menu that my anti-virus (McAfee) provided- after the shredding and a restart, the folder deleted with no issues. I don't know if this would work as a fix for others, but it did the trick for me.
    2017年9月11日 3:31
  • I just worked through an instance of this problem.

    The same issue occurred when I tried to modify some files on a remote server.  Working from my main computer, I connected to the remote server using the fully qualified path to the directory (\\{server_name}\TM1\TM1App\Files\) that I needed file maintenance.  When trying to copy/paste/delete/etc.,  I would get the same error.  Remote connecting to the server and browsing the file locally (C:\Data\NonCritical\0398\TM1\TM1App\Files\) gave me full connectivity and no errors when manipulating the files.

    It's not quite the same issue but may be connected.

    2017年9月15日 15:37
  • 1. Open File Explorer.
    2. Browse and find the file or folder you want to have full access.
    3. Right-click it, and select Properties.
    4. Click the Security tab to access the NTFS permissions.
    5. Click the Advanced button.
    6. On the "Advanced Security Settings" page, you need to click the Change link, in the Owner's field.
    7.Click the Advanced button.
    8.On the "Select User or Group" page, click the Find Now button.
    9.From the search result, select your user account, and click OK.
    10.On the "Select User or Group" page, click OK.
    11.Click Apply.
    12.Click OK.
    13.Click OK again.
    14.Click OK one more time to complete this task.
    2017年10月11日 4:14
  • On Windows 10, i just tried this and all these other suggestions and none of them worked... it wont let me click "ok" after i change the security properties, i need permission to do even that... i'm trying to delete the Black Desert Online, i only downloaded it cuz i thought it was free to play. When the uninstaller finished it left 2 files behind in its designation folder, both are launcher files, one's an application an the other is an E_ file whatever that is. I tried all the different suggestions but none of them worked...  None of the property settings allow me to change anything. Not having permission when my account  and profile is the only one on here is fucking ridiculous.
    2017年10月31日 0:36
  • This has been going on for years. Microsoft should be utterly ashamed of themselves. The orphaned files were created by a crash in the XPS printer driver. I AM the freaking Administrator. I DO give myself (and, indeed, the entire universe) permission to delete them, if only I could!

    I need working files with the same names, so I'll have to workaround it, something which isn't always possible : move everything else out to a new folder, and just leave these until the day I can take a hammer to the HDD - and even that probably won't get rid of them. If only I could make a suit of armour out of these indestructible files!

    2017年11月19日 4:03
  • I just used spybot to kill file. I had tried all the above. But in the end i just wanted to delete the file so I just used spybot kill file by right clicking, assuming you have spybot installed.

    It may help some of you.

    2017年11月28日 19:21
  • This worked like a charm for me. Thank you so much!
    2017年12月16日 11:07
  • Thank You, This was the only solution that worked for me.
    2018年1月10日 5:43
  • Wow! That actually worked! Thanks. It's insane that I have to do that, just to delete my own folder, but it worked! Thanks.
    2018年2月7日 0:12
  • Wow! That actually worked! Thanks. It's insane that I have to do that, just to delete my own folder, but it worked! Thanks.
    2018年2月7日 0:12
  • I run into the same problem and the files were created by me and saved in my documents folder. This time I suddenly can't save or edit anything in my own document folder! Permissions weren't changed. Yesterday I was in... today it won't let me in. It says My Documents don't belong to me.


    2018年2月8日 19:23
  • This is a bit of a strange one that happens to me from time to time. I am not sure why this worked but I noticed one time that it was telling me I needed to have permission from [MyComputer]\\[Me], which was who I logged in as. It is actually the only account on this computer except the default [Administrator] who still has the default desktop because I have not logged into it for almost a year, so there is no chance to "Mistake" who I am logged in as. I also do not have a domain or domain account, so that stuck me as strange.

    But basically I just did a "switch user" then on the login screen I clicked on my account which it said was already logged in. once I was back in my desktop I could delete the files again just as normal.

    Like I said though this happens maybe once in 2 to 3 months so I have not really though about it much till today. I am not going to give it much though after this unless it starts to become a more constant problem.

    2018年2月25日 9:49
  • This happen when u start sharing folder and delete some sub-folder(inherated) from other device. An image or a shadow of the previously existing folder still exists so that's why u can neither give permission to that folder nor and delete or edit it.(as previously stated that actually that folder does not exists).
    2018年2月26日 9:05
  • The simplest way if you have an non-encrypted drive is to boot form a Linux CD or DVD.

    Then mount the Windows hard drive

    Login to Linux as root and do as you wish to the Windows drive.

    NOTES:

    • Good: You can also run virus or malware scan from Linux and cleanup the Windows drive
    • Bad: It will NOT work if your drive is encrypted. You get an error that Linux cannot read the drive
    • Ugly: It is a pain for some who are not familiar with Linux
    2018年2月27日 23:21
  • Please read mine. There is no need to mess up Microsoft settings. They are there for a reason. Nor should you need to move stuff or use Google. If you read my reply here there is a simple non-disruptive way.

    2018年2月27日 23:30
  • Hi everyone,

    I had the similar issue, where inheritance properties didnt work.  I was the only account (and admin) on the computer and every suggestion I tried did not work from this thread.  

    If you're still in need, I downloaded File Assassin by Malwarebytes (Prominent Antivirus company, look it up for your own peace of mind, I did)  File Assassin removed the file in about 3 seconds, and made me feel silly for wasting so much time on it.  You just have to type in the entire file in the directory and check delete file.

    It is a free program, and trusted by the Norton Community.

    https://www.malwarebytes.com/fileassassin/

    Enjoy and good luck.  


    2018年3月22日 21:13
  • I have a folder under my downloads folder (C:\Users\Richard\Downloads\Photos (1)) that I can't delete. Tried the Malware File Assassin, but it only works on files and can't select the folder. I also tried the Spybot option, and while that one gave me a success window, the folder is still there. I'm logged in as Admin and all the same stuff everyone mentioned above. I also tried messing with all of the folder security options and none of those suggested helped either. I believe the file was made by another program at some point which is why it's a second photos folder. I don't know what program did that though and the folder is empty and just needs to be deleted. Any idea how to do this when all suggestions above failed?

    Thanks!

    2018年4月21日 23:33
  • Didn't work for me
    2018年5月13日 0:25
  • That's worked, Thanks, but can it be bad for my pc security?

    2018年5月17日 15:05
  • YES. Thank you. I've been having this issue intermittently and had no idea what would cause it.
    2018年5月24日 15:51
  • Hi Kappa-Gooner,

    Many people suggest change the Owner of the folder or file, that's kind of awkward.  Your solution is much practical.  Thanks.

    2018年5月31日 15:23
  • Well,  genius, I'm having the exact same problem and I created the file and am the only user on the computer with the only account so I am the administrator. There is no other "default owner." 
    2018年6月1日 11:40
  • I've come to the conclusion that--in situations like this, it's best to just live with the folder(s)/file(s) that we, as administrators (and some of us as owners), to which we have been denied access.  It's far less hair-pulling and stressful to just walk away--than to try to find a useful, yet workable solution.

    Perhaps, we should try speaking with a bonafide computer hacker.  They don't appear to have any problem, remotely reading and writing to our supposed "secure" systems.  I guess microsoft WILL allow writing to a directory and/or file--as long as it is done remotely?

    Maybe there is a "secret" security level ABOVE administrator, of which we are unaware?  There MUST be, how else would it be possible to:

    1.  Be the OWNER of the machine;

    2.  Be an administrator;

    3.  Take ownership of a folder/file;

    ...yet STILL receive the "access denied" error when attempting to delete/rename/move it????

    2018年6月2日 12:59
  • so what if i cant run GPedit.msc 

    any advise regarding that task is useless to me because i cannot run it 
    2018年6月24日 12:04
  • Up with this , Thanks Sir , Problem solved ...

    2018年6月26日 23:54
  • These could be my words exactly.  Same damn thing.  Doesn't make sense.  If I install Windows I should automatically own it and be able to do whatever the hell I want to whatever the hell I want.  It's mine, damn it.
    2018年7月20日 0:05
  • Sorry; NOT TRUE.

    I have just created a new file (.txt) and I get the same message when trying to transfer it from the Desktop to any other folder!

    2018年7月30日 12:52
  • there is neither "Local Policies" nor "Security Options" in Win10 (Settings/Security)!
    2018年7月30日 12:55
  • and after I've gone through all of this - EVERY TIME I RUN INTO THIS PROBLEM (10 or 12 TIMES A DAY),

    I'll be ready for the shrink....

    THANK YOU!

    2018年7月30日 13:10
  • So I have wasted about three hours, trying EVERYTHING that's listed here: TO NO AVAIL.

    WHY DO I NOT SEE ANY HELP HERE FROM MICROSOFT ? !

    2018年7月30日 13:18
  • NO: IT'S NOT!

    I have just created the file - and advanced properties does list me as owner!

    2018年7月30日 13:22
  • Ok, Ok, so you, Liu Wade ARE with Microsoft.

    BUT YOU'RE ANSWER DOES NOT HOLD WATER:  The files in question ARE created by me and PROPERTIES does list me as "Owner"!!!

    So what IS your answer? Your solutions? 

    As you can readily see, quite a lot of us are struggling not to be driven NUTS by this nonsensical problem!

    2018年7月30日 13:28
  • Sometimes, to solve a STUPID problem--it takes a STUPID solution!
    2018年7月30日 23:52