none
Exchange Server 2003 SP2 升级到Exchange Server 2010 SP2存在客户端问题 RRS feed

  • 问题

  • 客户端outlook 2007通过MAPI连接服务器后,打开outlook 2007反复提示输入用户名及密码

    客户端outlook2003,outlook2010未出现此问题

    2012年7月31日 5:27

答案

  • lisa chen,

    执行以下操作问题解决,谢谢!

    打开iis manager,在默认站点下,选择autodiscover虚拟目录,对ssl设置,将默认“忽略”更改为“接受”。

    我想知道原因,在没修改前outlook2003、outlook2010通过MAPI连接Exchange Server 2010 SP2,都正常。只有outlook2007通过MAPI连接Exchange Server 2010 SP2时,登录outlook2007,输入一次密码后,反复弹出输入密码对话框,但不需要输入密码,点确认5-7次后,对话框消失,邮件收发正常。

    outlook2007客户端也不是全部出现这个问题。

    谢谢!

    • 已标记为答案 nozhu 2012年8月4日 3:36
    2012年8月2日 4:14

全部回复

  • 您好!

    1.首先请确定outlook2007的验证方式为NTLM验证

    2.请在CAS上检查autodiscoverssl设置,是否选择了”ignore client certificate”

    3.使用EXRCA测试下autodiscover.

    3.请在客户端上检查应用程序日志有无错误信息。

    谢谢!


    2012年8月1日 6:18
  • 您好!
    1.outlook2007客户端的验证方式是默认的协商身份验证
    2.3.不知道怎么实现
    4.在有问题的客户端查看系统日志有错误,内容如下:
    The kerberos client received a KRB_AP_ERR_MODIFIED error from the server cas02$.  This indicates that the password used to encrypt the kerberos service ticket is different than that on the target server. Commonly, this is due to identically named  machine accounts in the target realm (ASTORI.CN), and the client realm.   Please contact your system administrator.

    不是每一台outlook2007客户端有这个问题(登录outlook2007,输入一次密码后,反复弹出输入密码对话框,但不需要输入密码,点确认5-7次后,对话框消失,邮件收发正常)
    有一种解决方法:
    新建一个Windows账户,登录后,配置MAPI,正常。

    谢谢!

    2012年8月2日 1:37
  • 您好!

    1.请服务器上,打开iis manager,在默认站点下,选择autodiscover虚拟目录,对ssl设置进行检查。

    2.使用ExRCA https://www.testexchangeconnectivity.com)测试Autodiscover是否工作正常

    3.关于该错误,请参考以下这个thread来解决。

    http://social.technet.microsoft.com/Forums/en-NZ/exchangesvrmigration/thread/ecc49b5e-aa65-4d5e-a224-69abfd6fe48d

    谢谢!


    2012年8月2日 3:02
  • lisa chen,

    执行以下操作问题解决,谢谢!

    打开iis manager,在默认站点下,选择autodiscover虚拟目录,对ssl设置,将默认“忽略”更改为“接受”。

    我想知道原因,在没修改前outlook2003、outlook2010通过MAPI连接Exchange Server 2010 SP2,都正常。只有outlook2007通过MAPI连接Exchange Server 2010 SP2时,登录outlook2007,输入一次密码后,反复弹出输入密码对话框,但不需要输入密码,点确认5-7次后,对话框消失,邮件收发正常。

    outlook2007客户端也不是全部出现这个问题。

    谢谢!

    • 已标记为答案 nozhu 2012年8月4日 3:36
    2012年8月2日 4:14