none
搜索不到内容? RRS feed

  • 问题

  • 在爬网日志中,提示:
    访问被拒绝。请验证默认内容访问帐户是否有权访问此库,或添加爬网规则对此库进行爬网。如果正在爬网的库是 SharePoint 库,请验证您所使用的帐户对正在爬网的 SharePoint Web 应用程序是否拥有“完全读取”权限。 (由于找不到该项目或拒绝爬网程序对其进行访问,该项目已被删除。)

    现在可以确定的是默认内容访问帐户是管理员账号.
    在内容源中"本地 Office SharePoint Server 网站" 开始地址为http://sps.***.net/
    在爬网设置中设置为仅对每个开始地址的 SharePoint 网站爬网不行,如果改为对每个开始地址的主机名称下的所有内容爬网,也是同样错误.
    但是在这个网站中唯一的网站集为http://sps.***.net/sz
    请问是否与这个有关?

    由于用这个默认的内容源不行,我另外建了一个内容源sz 开始地址为http://sps.***.net/sz/
    爬网设置为仅在每个开始地址的服务器内爬网或仅对每个开始地址的第一个页面爬网
    和上面的日志是一样的?

    这究竟是什么原因,我已经设置这个服务器为索引服务器了,所有的服务也启动了.
    2009年3月18日 6:17

答案

  • 其实很简单,就是在后台管理中心,打开操作,点击备用访问映射,选择编辑公用URL,再选择所要修改的web应用程序.在Intranet栏填入sharepoint  web的IP,就可以了.其它地方不变

    但是我现在还没有想明白,为什么这样做,那个老外也没有说原因,只说了解决办法.
    2009年3月20日 1:49
  • Resolution:

    Follow these steps to Disable the loopback check which is causing the error:

    1. Click Start, click Run, type regedit, and then click OK.
    2. In Registry Editor, locate and then click the following registry key:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

    3. Right-click Lsa, point to New, and then click DWORD Value.
    4. Type DisableLoopbackCheck, and then press ENTER.
    5. Right-click DisableLoopbackCheck, and then click Modify.
    6. In the Value data box, type 1, and then click OK.
    7. Quit Registry Editor, and then restart your computer.

     

    2009年4月30日 1:44

全部回复

  • log如下:
    事件类型: 警告
    事件来源: Office Server Search
    事件种类: Gatherer 
    事件 ID: 2436
    日期: 2009-3-18
    事件: 15:47:27
    用户: N/A
    计算机: moss
    描述:
    无法对开始地址 <http://sps.***.net/sz> 进行爬网。

    上下文: 应用程序“SharedServices1”,目录“Portal_Content”

    详细信息:
    访问被拒绝。请验证默认内容访问帐户是否有权访问此库,或添加爬网规则对此库进行爬网。如果正在爬网的库是 SharePoint 库,请验证您所使用的帐户对正在爬网的 SharePoint Web 应用程序是否拥有“完全读取”权限。   (0x80041205)

    有关更多信息,请参阅在 http://go.microsoft.com/fwlink/events.asp 的帮助和支持中心。

    • 已建议为答案 Jinnhe 2011年10月25日 8:50
    • 取消建议作为答案 Jinnhe 2011年10月25日 8:50
    2009年3月18日 8:08
  • 已经搞定

    把所有的sharepoint书翻遍,然后利用万能的baidu google

    从中国国内查到台湾,再到老外的网站,最后还是没有查到,几乎放弃.

    最后终于在一个不起眼的blog中找到了准确的解决方法,阿门

    终于可以安心睡觉了.
    2009年3月18日 12:29
  •  帮Rock说他很想说的话吧,我猜的.

    拜托共享下你的解决方案,论坛就是共享的地方.

    这样才能mark as answer!
    上善若水
    2009年3月19日 15:36
  • 其实很简单,就是在后台管理中心,打开操作,点击备用访问映射,选择编辑公用URL,再选择所要修改的web应用程序.在Intranet栏填入sharepoint  web的IP,就可以了.其它地方不变

    但是我现在还没有想明白,为什么这样做,那个老外也没有说原因,只说了解决办法.
    2009年3月20日 1:49
  • 今天又遇到相同问题?
    和上次不同的是,这次80(web),81(mysite),8080(管理中心)用的是不同用户,现在的提示和上面的错误一样,又该晕了.

    2009年4月20日 7:29
  • 您好!

     

    该问题可能是由于下面的原因导致的:

     

    当您在Content source 中没有使用缺省的URL

    例如:在alternate access mappings 中,如果我们使用http://servername作为缺省的URL,同时<http://FQDN>作为internet URL,如果在内容源中使用http://FQDN,就会遇到该问题。

     

    您可以尝试通过下面的任意一种方法来解决该问题:

    方法1


    - Check the alternate access mappings and note the default URL
    - Add the default URL in the content source and reset the index
    - Do a full update again, we should get the search results using this site scope

    方法2


    - Go to SSP Search settings
    - Click on Server name mappings- Click on New Mapping?- Under Address in
    index: type the URL we are using for crawling (<http://FQDN> as in above example)
    - Under Address in search results: type the default URL as we see in alternate
    access mappings (<http://servername> as in above example)
    - Reset the index and do a full update

     

    Rock Wang 望正茂


    Rock Wang– MSFT
    2009年4月22日 9:20
    版主
  • 首先谢谢Rock兄,
    我的default url为:http://sps.test.net
    Internet为http://servername
    如果把Internet换为http://servername.test.net或http://IP 也搜索不到内容
    其中内容源为默认的 http://sps.test.net
    不管我怎么映射,总是不成功,错误还是以前的错误

    是不是因为和上次比:
    1.加了主机头
    2.80的应用程序管理员和管理中心的管理员不同?

    2009年4月24日 1:23
  • 请高手帮忙看一下,实在找不到办法了

    2009年4月27日 1:35
  • 以前用htTP://IP 可以访问站点,现在不行了
    2009年4月27日 1:35
  • 您好!

     

    根据您的描述,您的default URLhttp://sps.test.net

     

    请将default URL添加到内容源中,然后重置索引,然后做一次完整的更新,在测试一下看结果如何。

     

    此外,请提供下面这些信息:

     

    1、  您是如何添加主机头的?请描述一下大致的过程。

     

    Rock Wang 望正茂


    Rock Wang– MSFT
    2009年4月27日 7:07
    版主
  • 我最开始就把default url加入到内容源中,索引也重置过,完整更新也做过,错误还是依旧.

    主机头是在创建web app的时候添加的.


    昨天下午这个问题,我已经找到解决方法,与大家分享一下:

    这个问题其实就是主机头引起的,引起回环操作,导致搜索失败,一个老外这样的解释的.

    能通过修改注册表,可以解决这个问题,不知道这个算不算bug?

    2009年4月28日 1:49
  • 您好!

    很高兴您的问题得到了解决!

    如果您能够将禁用回环操作的具体步骤发送到论坛中,这样可以使更多的用户受益。谢谢!

    Rock Wang 望正茂
    Rock Wang– MSFT
    2009年4月28日 7:15
    版主
  • Resolution:

    Follow these steps to Disable the loopback check which is causing the error:

    1. Click Start, click Run, type regedit, and then click OK.
    2. In Registry Editor, locate and then click the following registry key:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

    3. Right-click Lsa, point to New, and then click DWORD Value.
    4. Type DisableLoopbackCheck, and then press ENTER.
    5. Right-click DisableLoopbackCheck, and then click Modify.
    6. In the Value data box, type 1, and then click OK.
    7. Quit Registry Editor, and then restart your computer.

     

    2009年4月30日 1:44
  • 楼主 请留下msn交流下
    我的msn:xiaoyan1@126.com 谢谢!

    2009年8月14日 3:36
  • LOOPbackcheck这个害人精啊...
    我们搞form service的也被它搞死了.
    高度警惕啊.
    Joshua
    2009年10月21日 3:02