none
SQL Server 2008 Express SP1 安裝提示需要 .NET Framework 2.0 SP2 的解決方法 RRS feed

  • 問題

  • 當執行安裝程式會出現「SQL Server 2008 Setup requires Microsoft .NET Framework 2.0 SP2 to be installed.」的訊息
    但確定已經安裝了 .NET Framework 3.5 SP1 時

    經過自己的研究發現
    這可能是 .NET Framework 3.5 SP1 安裝程式沒有更新相關機碼產生的問題

    解決方法
    1.執行 Regedit
    2.找到機碼 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v2.0.50727
    3.該機碼下有個 DWORD 值叫做 SP
    4.該值改成 2

    SQL Server 2008 的安裝程式就不會找不到 .NET Framework 2.0 SP2 了 -__-
    2009年4月27日 上午 09:32

解答

  • 以上就是解決方法
    翻爛了 Internet
    好像沒有人有這個問題
    不知道是不是只有我自己有這個問題?

    提供自己的發現,給需要的人囉
    希望對大家有幫助
    • 已標示為解答 EIGHTS 2009年4月27日 上午 09:35
    2009年4月27日 上午 09:35