none
SMTP 傳輸緩慢 RRS feed

  • 問題

  • Dear 各位先進
     我遇到一個狀況,兩台exchange 2007 隸屬於不同的公司,
    架構上算是獨立彼此無關,(中間有10M VPN連線)
    作業系統皆為Windows 2003 R2 sp2

    但是遇到同樣的問題 OE/Outlook使用 POP3/SMTP 都遇到傳輸很慢的問題(SMTP),
    兩台exchange 的設定如下
    Port 465
    Port 25 (SSL)
     
    問題的狀況也一致
    Port 465 每秒50~70 KB
    Port 25 (SSL) 每秒2000~6000KB

    也試了一下 Port 25 (沒SSL),速度一樣是緩慢的

    如果Outlook/OE 在exchange 機器本身上設定,就完全正常,速度飛快。

    Server to Server 也很正常。

    後續又發現,跑VPN SSL (Windows AD CA)速度也是正常的。
    目前歸納,只要走SSL 不管用哪個Port 都是正常速度.

    初步已經排除是網路的問題,因為這問題只發生在SMTP 上(網芳/ Outlook exchange 用戶端模式皆很正常 )
    這問題讓我無法歸納出可能的原因。
    是否有前輩可以協助,好讓我有個正確的方向來解決。


    誤闖IT界的小白兔~ http://willtech365.blogspot.com/
    • 已編輯 Will Chen 2009年4月10日 上午 02:06 Update
    2009年4月9日 上午 05:15

所有回覆

  • 用戶端是在Internet還是Internal使用?
    很慢是指用戶端在傳送信件時還是收信時?還是只有在兩台伺服器用戶端相互寄信時?

    Jammy羅濟棠 https://partner.microsoft.com/taiwan/40014662 您的公司是微軟解決方案的提供者嗎?請加入Microsoft Partner Program(MSPP)計劃, 立即獲得無限次數微軟Partner專屬線上技術支援。
    2009年4月10日 上午 08:59
  • 再USER 寄信時
    測過
    Port 465  慢
    Prot 25 + SSL 超快

    如果跑SSL VPN
    Port 465  超快

    伺服器互寄很快,是正常的


    誤闖IT界的小白兔~ http://willtech365.blogspot.com/
    2009年4月10日 上午 09:15
  • SSL VPN是什麼?
    你的用戶端都只有跑POP3 mode嗎?
    不管在Internet or internal都一樣的情況嗎?

    Jammy羅濟棠 https://partner.microsoft.com/taiwan/40014662 您的公司是微軟解決方案的提供者嗎?請加入Microsoft Partner Program(MSPP)計劃,立即獲得無限次數微軟Partner專屬線上技術支援。
    2009年4月10日 上午 09:24
  •  若跑VPN 通道,這問題就會消失,
    VPN通道是我們讓同仁由外部連接至內部。
    我試著從內部啟用VPN 過去連SERVER,

    只有跑POP3 mode的USER會有此現象
    Outlook 連接exchange  就沒有此現象,
    但是Outlook 跑POP3 mode也有此問題,

    目前就只知道只要有SSL 速度就正常,
    不管由Outlook/OE SMTP+SSL
    或是,使用SMTP + 跑VPN通道,都是正常的

    因為實測每秒40~100KB ,不等,
    無法判定外部是否也一樣的狀況,從家裡的ADSL ,上傳也不過16~25KB 跟小於這個值

    兩台伺服器是不同時間架設的,一台已經架設一年了,一台最近架設,
    才發現這問題。
    兩台都有....
    誤闖IT界的小白兔~ http://willtech365.blogspot.com/
    2009年4月10日 下午 01:12
  • 再USER 寄信時
    測過
    Port 465  慢
    Prot 25 + SSL 超快
    Port 465 慢 : 你的這個情況是不是 User 在 Internet 上 , 然後穿越防火牆連到公司內部的 Exchange 呢?
                       如果是 , 問題或許是在防火牆上? (加密運算費時?)
    Garry Lin
    2009年4月13日 下午 04:28
  • 不是
    全部測試都是在區域網路內進行,
    防火牆內

    目前伺服器除了UESR SMTP慢,卻沒有一點錯誤訊息。
    但是丟檔案到同一台伺服器上(透過網路上的芳鄰),又超快的。

    原本想說是不是網路架構的問題,
    但同一個區域(IP網段)有另一台 D品牌 伺服器,他的SMTP就超正常的,傳輸訊速。

    而且這種情形出現在兩台伺服器,不同的公司。
    網路架構也略有不同,卻有同樣的問題....

    其他測試,
    用三台用戶端同時傳遞5M郵件
    每台用戶端的流量是40~50 KB/s
    伺服器的流量是 130~160 KB/s
    看起來
    伺服器的網卡流量也是正常的,只是SMTP 每個連線被限制在40~50 KB/s 不等........


    Exchange 一台是RTM使用一陣子後升級SP1
    最近建置的一台安裝完畢後就是SP1

    再重新描述一下架構
    A公司  兩台,腳色SMB、(Hub+CAS)
    B公司  一台,基本腳色全包
    上述架構都沒有Eag

    看了好幾天,幾乎想不出辦法.......(技窮.....泣)





    誤闖IT界的小白兔~ http://willtech365.blogspot.com/
    2009年4月13日 下午 04:53
  • 1. Exchange 本身有沒有啟用(安裝)防火牆功能(軟體)呢?
    2. 有沒有試著用Network Monitor去查看網路封包呢? 或許能找出問題所在.
    Garry Lin
    2009年4月14日 上午 09:56
  • 再USER 寄信時
    測過
    Port 465  慢
    Prot 25 + SSL 超快

    Hello,

    我想... 問題應該就出在這裡 , 你的目的就是想要在 SMTP 寄信時要加密處理 (像 Gmail 那樣)
    而 SMTP 走 465 就是想加密 (Gmail 的做法) , 其實和你所謂的 25 + SSL 是雷同的
    所以... 我建議你應該就是用 Port 25 + SSL 即可 , 而不是手動把 Port 25 改成 Port 465 才是
    有可能是微軟的機制只接受 Port 25 + SSL , 而不接受手動把 Port 25 改成 Port 465 (個人淺見供參考)

    以下是微軟 KB 的說明 , 也供你參考 http://support.microsoft.com/kb/278339/zh-tw
    通訊協定:SMTP/SSL
    連接埠 (TCP/UDP):465 (TCP)
    描述:SMTP over SSL。TCP 連接埠 465 都保留給一般業界慣例,以進行使用 SSL 通訊協定的安全 SMTP 通訊。然而,不同於 IMAP4、POP3、NNTP 及 HTTP,Exchange 2000 中的 SMTP 不會使用分開的連接埠來進行安全通訊 (SSL),而會採用稱為傳輸層安全性 (TLS,Transport Layer Security) 的「In-Band 安全性子系統」。
    Garry Lin
    2009年4月14日 上午 10:24
  • 之前有想過會不會是 port 465 在exchange 上有某些程度的不相容,
    有試著改成 999 , 666 等port 測試,狀況一樣。

    至於為什麼開465 是因為很多旅外同仁都遭"飯店"綁架 SMTP
    雖然開465遭飯店綁架的機率仍有,但是比25小一點。
    ^^"有很多歷史的~

    誤闖IT界的小白兔~ http://willtech365.blogspot.com/
    2009年4月14日 上午 10:39
  • 其實... 當你是使用 Port 25 + SSL 時 , SMTP 應該就不是走標準 Port 25 了
    這樣應該就不會被飯店綁架 SMTP 了才是 (應該如你所說的, 機率較低了)
    你可以試著抓取封包來看看, 看 Port 25 + SSL 到底是走什麼 Port (我認為應該是 465)
    Garry Lin
    2009年4月15日 上午 09:37
  • 就歷史~
    25+SSL 會被綁架,所以才改用 465

    我有想過全面改用25+SSL ,但是這樣便成問題沒也解決,
    只是躲掉這問題,再加上全面性的更改...會遭上千人公幹,
    我一直想找出真正的原因~  (準備開技術支援專案了TOT)

    試著攔截一下封包....(不大會分析封包T_T)
    Tcp: Flags=......S., SrcPort=2566, DstPort=SMTP(25),

    SSL跑25 應該還是走25 port

    465還是465 port
    Tcp: Flags=......S., SrcPort=2614, DstPort=(TCP) URL Rendesvous Directory for SSM/(UDP) IGMP over UDP for SSM(465),


    誤闖IT界的小白兔~ http://willtech365.blogspot.com/
    2009年4月15日 上午 09:58
  • 那... 不考慮 "Outlook無所不在" 之功能嗎?
    Garry Lin
    2009年4月15日 上午 10:17
  • 喝喝,這.......
    因為OE太受歡迎,很多同仁還是使用OE
    不過使用"Outlook Anywhere"......跟全面改用25+SSL
    沒什的差別,一個會被公幹.........一個會被毒打

    只針對旅外的同仁開放,有討問過,不過"大頭目"仍希望把問題解決,真的無解在說~

    等明天CSS 支援後,看最後結果為何,我在上來renew .......


    誤闖IT界的小白兔~ http://willtech365.blogspot.com/
    2009年4月15日 上午 10:24
  • 來Update 這訊息

    經過3個月的討論與測試
    結論歸咎在這份KB
    http://support.microsoft.com/kb/823764/zh-tw

    封包擷取也是看到這樣的現象

    改完機碼後但是卻出現這樣的流量圖


    其中,三段傳輸,撇開第一段與第三段那流量,(後面解釋)
    中間那段流量呈現
    1000KB/s~6000KB/s  
    50M很快就傳輸完成,
    看起來是恢復正常了,
    但是我另外一個納悶,為什麼流量會震盪!

    就這樣的觀點,這樣應該也不算正常。

    於是在開啟Microsoft Network Monitor 3.3截取封包,發現Microsoft Network Monitor 3.3開啟後(在伺服器端)流量會變的很穩定
    就是上面的圖形第依段流量和第三段流量,
    其中第依段流量末段開始震盪是因為我把Microsoft Network Monitor 3.3關掉。

    請問,是否有人知道,這樣的問題該歸納在哪,
    因為Microsoft Network Monitor 3.3開啟後流量震盪的問題消失了,這時候去擷取封包失去了意義。

    也想請教各位exchange 2007 SMTP + OE 傳輸緩慢的問題是否也發生在各位的環境中。


    誤闖IT界的小白兔~ http://willtech365.blogspot.com/
    2009年8月4日 上午 09:50
  • 來Update 這訊息

    經過3個月的討論與測試
    結論歸咎在這份KB
    http://support.microsoft.com/kb/823764/zh-tw

    封包擷取也是看到這樣的現象

    改完機碼後但是卻出現這樣的流量圖


    其中,三段傳輸,撇開第一段與第三段那流量,(後面解釋)
    中間那段流量呈現
    1000KB/s~6000KB/s  
    50M很快就傳輸完成,
    看起來是恢復正常了,
    但是我另外一個納悶,為什麼流量會震盪!

    就這樣的觀點,這樣應該也不算正常。

    於是在開啟Microsoft Network Monitor 3.3截取封包,發現Microsoft Network Monitor 3.3開啟後(在伺服器端)流量會變的很穩定
    就是上面的圖形第依段流量和第三段流量,
    其中第依段流量末段開始震盪是因為我把Microsoft Network Monitor 3.3關掉。

    請問,是否有人知道,這樣的問題該歸納在哪,
    因為Microsoft Network Monitor 3.3開啟後流量震盪的問題消失了,這時候去擷取封包失去了意義。

    也想請教各位exchange 2007 SMTP + OE 傳輸緩慢的問題是否也發生在各位的環境中。


    誤闖IT界的小白兔~ http://willtech365.blogspot.com/
    1. Network Monitor僅只是單純的擷取封包而已,個人不認為會與導致您所指稱的情況有所關聯
    2. 若這是個普遍性的問題,我想應該會有很大量的相同問題被提出.但目前看來似乎無此一現象
    3. 若您的Exchange 2007都是安裝在Windows Server 2003的OS上,那麼個人會強烈建議您參考
        KB http://support.microsoft.com/kb/948496/en-us 的描述先下載Hot fix安裝後重開,再下載Fix It安裝後重開.
        這個問題往往會造成許多莫名的網路問題.

    Jammy羅濟棠
    2009年8月6日 上午 02:35