locked
兩台2008 r2建立NLB的錯誤訊息請教! RRS feed

  • 問題

  • 請教各位先進!

    客戶端那邊有兩台2008 R2,環境中沒有網域的存在,兩台的administraotr密碼皆不同

    設定Multicast NLB的時候,在第一台主機中,設定將第二台主機也加入NLB,但是卻出現下面的錯誤訊息

    經過確認,第二台主機也已經有Bind NLB的IP了,請問這樣有算成功的設定嗎?謝謝囉...

     

    PS.在我們的測試環境中,如果兩台的administrator密碼皆相同,則無此問題

    2011年11月11日 上午 10:08

解答

所有回覆

  • Dear DannyLee

     

    您的問題很簡單,因為在進行交集時,會驗證操作者是否有權限執行交集作業,因此在兩個操作者沒有相同帳號密碼時,會產生確認的問題

     

    建議您,在兩台設備上各加一個使用者,並且將這個使用者加入Administrators群組中,再由這個使用者進行NLB的交集作業

     

    另外也建議你,在A設備上建立NLB集區,在B設備上執行加入NLB會比較少問題!!


    Jason的電腦健身房 沒有永遠的安全 沒有永遠的弱點 有牌的神經病

    • 已提議為解答 AChange 2011年11月14日 上午 01:11
    2011年11月12日 上午 08:13
  • Dear DannyLee

     

    您的問題很簡單,因為在進行交集時,會驗證操作者是否有權限執行交集作業,因此在兩個操作者沒有相同帳號密碼時,會產生確認的問題

     

    建議您,在兩台設備上各加一個使用者,並且將這個使用者加入Administrators群組中,再由這個使用者進行NLB的交集作業

     

    另外也建議你,在A設備上建立NLB集區,在B設備上執行加入NLB會比較少問題!!


    Jason的電腦健身房 沒有永遠的安全 沒有永遠的弱點 有牌的神經病

    感謝您的回覆,不過印象中在2008 R2中,好像有使用非administrator的帳號(該帳號是administrators的成員)建置NLB,但是會無法成功的情況...

    這個部分我們會再進行測試,後續情況再做回報,感謝

    2011年11月13日 下午 02:04
  • 剛剛已經有進行測試了,依照Jason所提議的方式:

    1.在兩台主機都建立一個相同密碼的帳號「nlb」,並加入「administrators」群組,而且兩台主機都使用nlb此帳號進行登入。

    2.先在A主機建NLB,然後在B主機進行節點加入的動作。

    3.在B主機要連線到NLB叢集時,出現下面的視窗,使用nlb帳號無效

    4.因為使用nlb帳號認證授權無效,所以改用主機1的administrator,結果認證授權就過了

    5.雖然認證授權過了,但是卻出現錯誤

    以上為整個測試的經過,請問有可能是我們哪邊有做錯嗎?感恩...

     

    PS.以上兩台測試主機都是Hyper-V的VM,模式為多點傳輸

    2011年11月14日 上午 01:55
  • 今天有找到網路上有一篇文章,裡面有提到跟我們遇到相同的情況,雖然不建議關閉UAC,但是只要關閉UAC之後,經過我們的測試,的確就可以順利的設定NLB成功。

    該篇文章網址:Configuring NLB on Windows Server 2008 as a member of the local Administrators group may not work as expected on standalone servers

    以上的內容也提供給有需要的朋友參考,也感謝在此回覆的相關先進,感恩...

    • 已提議為解答 Kill Apple 2011年11月14日 上午 08:02
    • 已標示為解答 DannyLee 2011年11月14日 上午 09:26
    2011年11月14日 上午 03:15