none
SharePoint網站備份的問題 RRS feed

  • 問題

  • 請教各位:

     

    目前我遇到一個問題,就是我使用SBS2003內建的備份工具,位於C:\Program Files\Common Files\Microsoft Shared\web server extensions\60\BIN 之下,名為smigrate.exestsadm.exe這兩個備份工具,之前使用這兩個備份工具的備份語法來備份檔案都沒問題,後來因為Server所對外的網路線和IP有更變換過,但最後又換回原來的網路與IP

    問題來了,從變換過後到改回與原來的一樣,線在用那兩個小工具在命令提示字元那裡備份的時候,stsadm是正常的,但smigrate卻無法正常備份,命令提示字元那裏所出現的錯誤訊息是:

     

    ERROE:6553612 在companyweb 找不到網頁伺服器,請檢查以確定網頁伺服器名稱是否有效,Proxy設定是否正確,如果你確定所有設定都正確,可能是網頁伺服器暫時停止服務。

     

    而我進入Server裡的IIS網站,裡面的companyweb網站跟一些網站,再按下右鍵瀏覽的時候都說找不到網頁

    ,在網址上鍵入companyweb也沒用,只能打IP進入,

     

    請問有人知道為什麼網站無法備份??為什麼IIS內的多個網站都無法瀏覽??

    謝謝

    2007年4月19日 上午 09:34

解答

  •  Fly Away 寫信:

    您好:

    對不起,之前打字太快變成手誤,目前發生這個問題的SharePoint網站是屬於SBS2003內建的WSS 2.0才對

    而我照您所教導的管理中心>作業>通用設定>備用存取對應,但找不到您所說的這些選項

    是否能再麻煩您告知在WSS 2.0該如何解決這問題,感謝

     

    現在除了網站無法備份之外,還有預設的companyweb也無法連結開啟,甚至在SBS2003的伺服器管理內的IIS網站中,右鍵點選companyweb,選擇瀏覽,也是無法開啟來看,非常傷腦筋



    您能建立新的網站嗎 ? 試試建立新的網站是不是正常

    如果建立新的網站也沒辦法瀏覽

    比較快速的方式就是找另個環境將備份還原上去先

    再來慢慢排除現在的問題

    2007年5月6日 下午 03:26

所有回覆

  • Dear Fly Away:

     

    SharePoint 2003 最忌諱也最可怕的地方就是更換 IP, 即便你更改回來了系統依然是有問題的, 這一部分妳可以試著更改資料庫中的 IP 值, 我之前有改過是可以正常運作, 但是成功機率極低, 碰運氣

    2007年4月22日 下午 02:57
  •  Fly Away 寫信:

    請教各位:

     

    目前我遇到一個問題,就是我使用SBS2003內建的備份工具,位於C:\Program Files\Common Files\Microsoft Shared\web server extensions\60\BIN 之下,名為smigrate.exestsadm.exe這兩個備份工具,之前使用這兩個備份工具的備份語法來備份檔案都沒問題,後來因為Server所對外的網路線和IP有更變換過,但最後又換回原來的網路與IP

    問題來了,從變換過後到改回與原來的一樣,線在用那兩個小工具在命令提示字元那裡備份的時候,stsadm是正常的,但smigrate卻無法正常備份,命令提示字元那裏所出現的錯誤訊息是:

     

    ERROE:6553612 在companyweb 找不到網頁伺服器,請檢查以確定網頁伺服器名稱是否有效,Proxy設定是否正確,如果你確定所有設定都正確,可能是網頁伺服器暫時停止服務。

     

    而我進入Server裡的IIS網站,裡面的companyweb網站跟一些網站,再按下右鍵瀏覽的時候都說找不到網頁

    ,在網址上鍵入companyweb也沒用,只能打IP進入,

     

    請問有人知道為什麼網站無法備份??為什麼IIS內的多個網站都無法瀏覽??

    謝謝

     

    你的IIS當中的每一個virtual server的web site設定當中,他們是選擇任何IP還是有指定IP?如果是沒有指定IP,試試看指定選擇該機器的IP指定看看。

    2007年4月24日 下午 08:54
  • 好的

    我試試看

    2007年4月25日 下午 03:48
  • 你好

    請問能詳細說明操作的步驟嗎??因為我在WSS3.0的管理中心內,找不到有關"虛擬伺服器"這類的名詞選項

     

    而且現在還有個問題

    就是我之前原本有個網站,直接打 http://123.123.12.12: port/sites/ooxx/ 就可連上去,但是後來因為如上述所言,有更換過IP,導致現在打http://123.123.12.12: port/sites/ooxx/ 連不上去,改成內部的虛擬IP http://192.168.5.1: port/sites/ooxx/ 也是連不上,可是管理中心用內部的虛擬IP卻連的上,用固定IP就連不上,我找不出是哪裡出現什麼問題,懇請各位朋友幫忙,謝謝

    2007年4月26日 上午 02:13
  •  Fly Away 寫信:

    你好

    請問能詳細說明操作的步驟嗎??因為我在WSS3.0的管理中心內,找不到有關"虛擬伺服器"這類的名詞選項

     

    而且現在還有個問題

    就是我之前原本有個網站,直接打 http://123.123.12.12: port/sites/ooxx/ 就可連上去,但是後來因為如上述所言,有更換過IP,導致現在打http://123.123.12.12: port/sites/ooxx/ 連不上去,改成內部的虛擬IP http://192.168.5.1: port/sites/ooxx/ 也是連不上,可是管理中心用內部的虛擬IP卻連的上,用固定IP就連不上,我找不出是哪裡出現什麼問題,懇請各位朋友幫忙,謝謝

     

    你需要到安裝MOSS的伺服器上打開IIS的介面,然後找到你這個網站的virtual directory,打開內容之後查看一下在web site下的IP Address的設定有沒有指定IP。

    2007年4月26日 下午 09:39
  •  Well761014 寫信:

    Dear Fly Away:

     

    SharePoint 2003 最忌諱也最可怕的地方就是更換 IP, 即便你更改回來了系統依然是有問題的, 這一部分妳可以試著更改資料庫中的 IP 值, 我之前有改過是可以正常運作, 但是成功機率極低, 碰運氣

     

    2007是不是也是一樣要小心呢?

    2007年4月27日 上午 09:40
  • 我覺得應該是你換了ip之後..原先sharepoint的設定資料庫還是原先的

    所以建議你可以再新增一個備用存取對應的ip

     

    管理中心>作業>通用設定>備用存取對應

     

    from Jade

    2007年5月4日 下午 04:00
  •  Jade Yu 寫信:

    我覺得應該是你換了ip之後..原先sharepoint的設定資料庫還是原先的

    所以建議你可以再新增一個備用存取對應的ip

     

    管理中心>作業>通用設定>備用存取對應

     

    from Jade

     

    您好:

    對不起,之前打字太快變成手誤,目前發生這個問題的SharePoint網站是屬於SBS2003內建的WSS 2.0才對

    而我照您所教導的管理中心>作業>通用設定>備用存取對應,但找不到您所說的這些選項

    是否能再麻煩您告知在WSS 2.0該如何解決這問題,感謝

     

    現在除了網站無法備份之外,還有預設的companyweb也無法連結開啟,甚至在SBS2003的伺服器管理內的IIS網站中,右鍵點選companyweb,選擇瀏覽,也是無法開啟來看,非常傷腦筋

    2007年5月6日 下午 12:46
  •  Fly Away 寫信:

    您好:

    對不起,之前打字太快變成手誤,目前發生這個問題的SharePoint網站是屬於SBS2003內建的WSS 2.0才對

    而我照您所教導的管理中心>作業>通用設定>備用存取對應,但找不到您所說的這些選項

    是否能再麻煩您告知在WSS 2.0該如何解決這問題,感謝

     

    現在除了網站無法備份之外,還有預設的companyweb也無法連結開啟,甚至在SBS2003的伺服器管理內的IIS網站中,右鍵點選companyweb,選擇瀏覽,也是無法開啟來看,非常傷腦筋



    您能建立新的網站嗎 ? 試試建立新的網站是不是正常

    如果建立新的網站也沒辦法瀏覽

    比較快速的方式就是找另個環境將備份還原上去先

    再來慢慢排除現在的問題

    2007年5月6日 下午 03:26
  • 各位大大:

      請問一下, 我也有相同的Sharepoint網站備份問題,我用了

      備份 : smigrate.exe -w https://xxx.xxx.com/sites/STSxxx_01 -f C:\123 -e -y -u ID -pw password
        還原 : smigrate.exe -r -w https://xxx.xxx.com/sites/STSxxx_02 -f C:\123.fwp -u ID -pw password

      備份正常, 但在還原時會出現,

      Error : 6553619 在xxx.xxx.com 的連接阜443,找不到網站伺服器,請檢查伺服器的名稱是否有效,proxy設定是否正確,如果您確定所有設定都是正確的,可能是網頁伺服器服務暫時停止了.


       可是,我之前這樣做都正常, 且我們沒有改過IP, 現在也可以正常建立網站,就還原時會出現上述的錯誤,還請各位大大指引一下迷津,謝謝了.

     

      

    2007年6月11日 上午 03:35
  • 我是建議你2件事..

    1.用stsadm來備份試看看,你的那個smigrate(是舊版用的語法,新版是用STSADM import export)比較適合做網站的搬動.

    2.看看你的web service是不有問題, 尤其是login name password重新打一次看看.

    2007年6月11日 上午 03:41