locked
Hyper-V Guest OS(Server 2008)無法安裝整合服務 RRS feed

  • 問題

  • 我的虛擬主機是Windows Server 2008,原先在Virtual Server 2005 R2上執行,現在我將虛擬主機轉移到Hyper-V,我先將Virtula Machine Addtions移除,然後遷移到Hyper-V上,再安裝整合服務,整個安裝過程,都沒有出現錯誤,但是.........似乎整合服務沒有安中成功,因為我在控制台的程式和功能中,看不到Hyper-V Guest Component,所以我的網路卡抓不到,滑鼠切換也有問題。

    我仔細查看又發現,我有兩個PATCH(KB968930、KB973917)每次都安裝都失敗,是這個問題造成的嗎?該怎麼才能解決?

    • 已編輯 Vincent Lin 2010年4月8日 上午 06:16 修改標題
    2010年4月7日 上午 12:20

解答

  • 跟那兩隻更新沒什麼關係 , 應該是跟HAL有關

    參考下面這篇KB的方式做看看 , 讓系統重新偵測 HAL 看看是否改善

    The VMBus device does not load on a virtual machine that is running on a Windows Server 2008-based computer that has Hyper-V installed
    http://support.microsoft.com/kb/954282/en-us

    Thanks


    不管問題有沒有解決..麻煩都回來回報一下..對回答者也算是一種尊重:)
    微軟技術支援網站
    • 已提議為解答 Vincent Lin 2010年4月7日 上午 08:45
    • 已標示為解答 Vincent Lin 2010年4月8日 上午 06:04
    2010年4月7日 上午 08:42

所有回覆

  • 有關網路卡抓不到的問題,檢查看看Hyper-V管理員中網路介面卡的設定是否正確(如下圖)。

     

    2010年4月7日 上午 12:46
  • 先參考看看微軟TechNet 技術文件庫的文件:
    Virtual Machine Migration Guide: How To Migrate from Virtual Server to Hyper-V

    看有哪一步是漏掉沒做的,至於抓不到網卡的問題可以先以新增傳統網路介面卡的方式處理。


    蘇老碎碎念
    資訊無涯,回頭已不見岸
    好用的微軟技術支援小工具
    Facebook - 微軟台灣官方論壇愛好者俱樂部
    • 已提議為解答 Vincent Lin 2010年4月7日 上午 08:45
    2010年4月7日 上午 01:29
  • 相同的步驟,我將Windows Server 2003虛擬主機,遷移到Hyper-V都沒有問題

    但是Windows Server 2008卻不行?

    2010年4月7日 上午 01:35
  • 如果確認Virtual Server 2005 的Virtula Machine Addtions 已經移除,
    試著先在那台Server 2008 的VM硬體設定傳統式網路介面卡,
    讓該台VM可以正常上網,然後試著做WindowsUpdate更新看看。
    蘇老碎碎念
    資訊無涯,回頭已不見岸
    好用的微軟技術支援小工具
    Facebook - 微軟台灣官方論壇愛好者俱樂部
    2010年4月7日 上午 03:37
  • 這樣做仍然不行

    最主要是整合服務沒有出現在新增/移除程式當中看的到

    在Windows Server 2003中,整合服務裝完有Hyper-V Guest Component

    在Windows Server 2008中,整合服務安裝完看不到Hyper-V Guest Component

    這和之前KB安裝不成功有關嗎?

    2010年4月7日 上午 06:33
  • 有試過在裝一次嗎? 因為第一次可能是提示你要upgrade系統的HAL , 第二次重新開機後才能安裝整合服務

    Thanks


    不管問題有沒有解決..麻煩都回來回報一下..對回答者也算是一種尊重:)
    微軟技術支援網站
    2010年4月7日 上午 08:05
  • 有的

    第一次UPGRADE HAL,然後重新開機,再自動繼續安裝

    我的Windows Server 2003也是同樣的方式安裝遷移,並沒有任何的問題

    我猜想,會不會是和我Windows Server 2008,有兩個Path無法安裝有關?(KB968930、KB973917)

    2010年4月7日 上午 08:22
  • 跟那兩隻更新沒什麼關係 , 應該是跟HAL有關

    參考下面這篇KB的方式做看看 , 讓系統重新偵測 HAL 看看是否改善

    The VMBus device does not load on a virtual machine that is running on a Windows Server 2008-based computer that has Hyper-V installed
    http://support.microsoft.com/kb/954282/en-us

    Thanks


    不管問題有沒有解決..麻煩都回來回報一下..對回答者也算是一種尊重:)
    微軟技術支援網站
    • 已提議為解答 Vincent Lin 2010年4月7日 上午 08:45
    • 已標示為解答 Vincent Lin 2010年4月8日 上午 06:04
    2010年4月7日 上午 08:42
  • 謝謝你

    這樣的做法沒有問題了

    網路卡可以抓的到了

    可是..........

    網路速度非常的慢,尤其只要有一個使用者存取Web,去ping Server就會time out,而且........網站的回應非常慢,這在Virtual Server上所沒有發生過的

    另外在同樣這部Hyper-V上的另一個Server 2003虛擬主機,也不會有這樣的情形

    不知道問題在哪裡?

    請再麻煩一下,謝謝!

    • 已標示為解答 IanChen 2010年4月8日 上午 06:37
    • 已取消標示為解答 Vincent Lin 2010年4月9日 上午 10:13
    2010年4月8日 上午 05:24
  • 這樣的話就跟原先的問題可能比較沒關係了

    建議你重新再問一個新問題 , 然後把你的狀況在描述一次

    比如:Server 2008 VM裡面有什麼角色? 提供什麼服務? 問題狀況大概如何等等

    這樣比較能清楚你的問題 , 也可以讓其它人看到你新的問題來跟你做討論

    Thanks


    不管問題有沒有解決..麻煩都回來回報一下..對回答者也算是一種尊重:)
    微軟技術支援網站
    2010年4月8日 上午 06:16