locked
Server2008 Terminal Server中的RemoteApp一直無法成功執行 RRS feed

  • 問題

  • 不好意思!小弟的狀況是,暫時沒有 要從internet上連RemoteApp,只是在區網中要透過RDWebAccess來執行RemoteApp,

    登入後,執行我的桌面 VDI 都是可以成功的,唯獨RemoteApp 就是會失敗,會出現 『因為連接的遠端電腦不是您指定的電腦,所以無法完成連線』。

    https://docs.google.com/file/d/0B91B3YRQ5ZnnME4wYnJsdGJyN2c/edit

    第一:RemoteApp,我是透過控制台中在遠端桌面伺服器安裝應用程式 的方式安裝的

    第二:RemoteApp,執行權限上,勾選所有驗證過的網域使用者。

    這困擾我好久~不知能否麻煩大大教我一下,原因在哪~非常感謝!

    2012年9月26日 上午 02:55

所有回覆

  • 你有多於一台RemoteApp 伺服器, 或有用網絡負載平衡嗎?

    這好像是TS Session Broker設定的錯誤引起的, 請查看Session Broker的Event Log..看看有沒有其他資訊

    這邊有一個解決個案, 試試看會不會是RDP 6.1的設定問題

    http://social.technet.microsoft.com/Forums/en-US/winserverTS/thread/5ce52403-5d7b-4e72-aa41-48336ad851b4/


    邊幫助, 邊鍛鍊



    2012年9月26日 上午 05:16
  • 感謝您的回覆!

    1、我的環境僅有一台RemoteAppServer,我所有的TS Role都安裝於一台,僅有Hyper V 相關的角色獨立開來。也沒有安裝任何NLB。

    2、我仔細查過 TS Session Broker ,的Log ,警有Alert ,並無錯誤訊息,而且其內容多為警告重新導向:

    遠端桌面連線代理人用戶端已成功將使用者 Domain\fox 重新導向到端點 W7.XXXXXX.local。
    端點的 IP 位址 = 192.168.1.XXX

    3、有按照您建議的網址,我將RDP 的Security Level 改為 RDP Level ,Reboot Server 之後,錯誤訊息還是一樣~

    很奇怪,重新導向 到Hyper V上的 VM 都能成功,唯獨Remote App 都不行耶~


    2012年9月26日 上午 06:15
  • http://social.technet.microsoft.com/Forums/en/winserverTS/thread/42bc8c4f-6dab-4ffa-a0f1-61a6daa2e6ac

    有可能是只問題造成!我的環境都是擺在同一個VM中,正在測試中!

    2012年9月26日 下午 02:16
  • 有點不是很懂有關:

    server1: RDVH, RDSH (in redir mode), HyperV, some test client VMs.
    server2: RDSH with remoteapps, RD Connection Broker, and RD Web Access  

    特別是 RDSH 的(in redir mode) 跟RDSH with remoteapps  有何差別! 

    2012年9月27日 上午 01:00
  • 根據小弟昨天查到的該網址,剛剛才測試出來~但我個人覺得不是標準的答案、SOP,所以僅提供我剛解決的過程,也許誤打誤撞,如果有先進有正確答案,請不吝指正!

    1、我原本將 所有TS Role都安裝於同一台TS Server上(ts.domain.local),同時作為 Remote Desktop Redirect 、也同時擔任RemoteApp 角色。

    結果卻發生 https://docs.google.com/file/d/0B91B3YRQ5ZnnME4wYnJsdGJyN2c/edit,TS Gateway 與 VDI 都可以Run。

    2、根據 昨天查詢到 http://social.technet.microsoft.com/Forums/en/winserverTS/thread/42bc8c4f-6dab-4ffa-a0f1-61a6daa2e6ac ,小弟自己的解讀是,負責 VDI 的RDSH 與 RemoteApp 必須隔開。

    3、所以昨日安裝新一台RemoteApp TS Server ,然後在舊的 ts.paradigm.local 上把 RemoteApp來源改成 新架設的RemoteApp TS Server上。

    4、不知為何,做了這動作後,卻發生了 https://docs.google.com/open?id=0B91B3YRQ5ZnndXoyaHJlbHU5QjA  此問題,新的Logon 都不能登入,而且GUI 都無法修改

    5、只好透過下cmd 方式修改,chglogon /enable 。

    6、這時候透過RD WebAccess 測試 RemoteApp 與 VDI都是正常的了!

    2012年9月27日 上午 03:15