none
NET Framework 問題 RRS feed

  • 問題

  • 我從1.0 安裝到2.0   直接更新了NET Framework 3.5 SP1 發現連同3.0都安裝了
    系統馬上肥了幾百mb
    請問能不能做個
    沒安裝過NET Framework  能直接安裝一版就好
    不要讓系統內有1.0又有1.1 還有2.0 又加上3.0 3.5  2版
    一個系統有5版 還真是無言
    直接做個NET Framework
    然後C:\WINDOWS\Microsoft.NET\Framework  就只有一版就好了
    這樣會很難嗎????
    單安裝Microsoft的系統以及更新 系統已經肥大到弊了
    跟殺也殺了該砍都砍了(所有備份檔)   只能說 Microsoft  拜託 妳們真是夠了
    2009年6月9日 上午 02:34

解答

  • 這邊是網友交流、分享討論區,你要跟微軟建議的話,打客服電話或是到 connect.microsoft.com 反映。

    .Net 1.0 / 1.1 / 2.0 是獨立的,你如果沒有對應的應用程式,就不用裝該版本的 .Net ,不同版本不相容。
    .Net 3.0 / 3.5 是 base on 2.0,所以要用 .Net 3.5 一定要有 .Net 2.0/3.0 。

    只有 .Net 1.0/1.1/2.0 是還好,主要大的是 .Net 3.0/3.5。

    .Net 就是為了解決以前的 dll ____ ,所以設計上就是互不相容,所以不能只有一版,只有一版的話,就又回到以前 windows 的老問題:dll 地獄。

    .Net 4.0 馬上就要出來了,你可能又要哭了...

    註:我有反應過類似問題,CSS 工程師說新版的 .Net 4.0 有注意到此問題,已經有部分改善了,但我也不知道改多少。
    論壇是網友平等互助 保證解答請至 微軟技術支援服務
    • 已標示為解答 Bethere 2009年6月22日 下午 03:02
    2009年6月9日 上午 07:33

所有回覆

  • 這邊是網友交流、分享討論區,你要跟微軟建議的話,打客服電話或是到 connect.microsoft.com 反映。

    .Net 1.0 / 1.1 / 2.0 是獨立的,你如果沒有對應的應用程式,就不用裝該版本的 .Net ,不同版本不相容。
    .Net 3.0 / 3.5 是 base on 2.0,所以要用 .Net 3.5 一定要有 .Net 2.0/3.0 。

    只有 .Net 1.0/1.1/2.0 是還好,主要大的是 .Net 3.0/3.5。

    .Net 就是為了解決以前的 dll ____ ,所以設計上就是互不相容,所以不能只有一版,只有一版的話,就又回到以前 windows 的老問題:dll 地獄。

    .Net 4.0 馬上就要出來了,你可能又要哭了...

    註:我有反應過類似問題,CSS 工程師說新版的 .Net 4.0 有注意到此問題,已經有部分改善了,但我也不知道改多少。
    論壇是網友平等互助 保證解答請至 微軟技術支援服務
    • 已標示為解答 Bethere 2009年6月22日 下午 03:02
    2009年6月9日 上午 07:33
  • 挖哩,居然地獄的英文被馬賽克了... 改用全形試看看~
    dll hell
    論壇是網友平等互助 保證解答請至 微軟技術支援服務
    2009年6月9日 上午 07:34