none
關於MSI自動派送的問題 RRS feed

  • 問題

  •  

    我製作了一個msi檔,並在Group Policy 以派送的方式,套用在OU上,派送給網域中的各電腦
     
    大部分的電腦都自動派送到了,但是有些電腦明明就在該OU 裡,卻始終沒有在開機時進行自動安裝
     
    請問這有什麼可能的原因? 或需要修正什麼嗎?
    2008年4月3日 上午 01:06

解答

  • 請嘗試以下三個步驟,請一個一個做,直到問題解決。

     

    1. Upgrade the NIC driver

    2. Also added the WaitForNetwork entry

         - In Registry Editor, locate the following registry subkey:

            HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

         - Add the WaitForNetwork entry.  To do this, follow these steps:

            a.  Right-click the Winlogon subkey, click New, and then click Dword Value.

            b.  In the Value name box, type WaitForNetwork.

         - Right-click WaitForNetwork, and then click Modify.

         - In the Edit DWORD Value dialog box, in the Value Data box, type 1, and then click OK.

     

    3. To add the GpNetworkStartTimeoutPolicyValue registry entry and to define the value, follow these steps:

        a. Click Start, click Run, type regedit, and then click OK. 
        b. Expand the following registry subkey: 
            HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon 
        c. Right-click Winlogon, point to New, and then click DWORD Value. 
        d. To name the new entry, type GpNetworkStartTimeoutPolicyValue, and then press ENTER. 
        e. Right-click GpNetworkStartTimeoutPolicyValue, and then click Modify. 
        f. Under Base, click Decimal
        g. In the Value data box, type 60, and then click OK. 
        h. Close Registry Editor, and then restart the computer. 
        i. If the Group Policy startup script does not run, incrementally increase the value of the GpNetworkStartTimeoutPolicyValue registry entry until the problem is resolved. For example, 90, 120, 150, 180 and etc.

     

    REFERENCE KB

    ========================

    KB933458 "Group Policy may not install the PolicyMaker Software Update client on a Windows XP Service Pack 2-based computer, and event ID 5719 and event ID 1054 are logged" http://support.microsoft.com/kb/933458

     

    HTH

    Marty

    2008年4月3日 上午 01:47

所有回覆

  • 請嘗試以下三個步驟,請一個一個做,直到問題解決。

     

    1. Upgrade the NIC driver

    2. Also added the WaitForNetwork entry

         - In Registry Editor, locate the following registry subkey:

            HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

         - Add the WaitForNetwork entry.  To do this, follow these steps:

            a.  Right-click the Winlogon subkey, click New, and then click Dword Value.

            b.  In the Value name box, type WaitForNetwork.

         - Right-click WaitForNetwork, and then click Modify.

         - In the Edit DWORD Value dialog box, in the Value Data box, type 1, and then click OK.

     

    3. To add the GpNetworkStartTimeoutPolicyValue registry entry and to define the value, follow these steps:

        a. Click Start, click Run, type regedit, and then click OK. 
        b. Expand the following registry subkey: 
            HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon 
        c. Right-click Winlogon, point to New, and then click DWORD Value. 
        d. To name the new entry, type GpNetworkStartTimeoutPolicyValue, and then press ENTER. 
        e. Right-click GpNetworkStartTimeoutPolicyValue, and then click Modify. 
        f. Under Base, click Decimal
        g. In the Value data box, type 60, and then click OK. 
        h. Close Registry Editor, and then restart the computer. 
        i. If the Group Policy startup script does not run, incrementally increase the value of the GpNetworkStartTimeoutPolicyValue registry entry until the problem is resolved. For example, 90, 120, 150, 180 and etc.

     

    REFERENCE KB

    ========================

    KB933458 "Group Policy may not install the PolicyMaker Software Update client on a Windows XP Service Pack 2-based computer, and event ID 5719 and event ID 1054 are logged" http://support.microsoft.com/kb/933458

     

    HTH

    Marty

    2008年4月3日 上午 01:47