none
SCOM 手動安裝Agent 問題 RRS feed

  • 問題

  • 各位老師您好:

    針對最近LAB遭遇到的問題,來此尋求協助!

    一‧相同網域中,手動安裝 Agents:

          Domain:LAB.COM, AD:lab-ad, SCOM:lab-scom, Client:lab-exch

          先前準備:自動部屬沒問題,已在console針對"手動安裝代理程式"部分做好設定

          目標:在lab-exch中手動安裝Agent,讓lab-scom可以抓到

          過程:1.安裝Agent時,管理群組設定,選擇"Active Directory中管理群組設定",SCOM 抓不倒

                      檢視Event發現,HealthService 2011, 2003 無法在AD中找到原則,與無法啟動管理群組

                      等訊息

                    2.安裝Anget時,管理群組設定,選擇"指定管理群組設定",輸入管理群組名稱"LAB"管理

                       伺服器"lab-scom"埠號依預設,SCOM有抓到,卻顯示灰色符號(但卻顯示代理程式良好!?

                       亦可以進行監控動作...)

          問題:1.在相同Active Directory中,要如何將管理群組原則加入AD讓網域中成員手動安裝時

                       可以抓到?

                    2.手動設定方式安裝,SCOM有抓到看似可以動作,狀態卻顯示灰色,如何解決呢?   

    二‧不同且無信任網域中,手動安裝Agent:

          Domain 1:lab.com    AD:lab-ad, SCOM:lab-scom

          Domain 2:lab2.com  AD+Client: lad2-ad

          先前準備:在lad2-ad中,安裝SCOM gateway

          過程:1.依文件步驟安裝gateway完成

                    2.依文件步驟執行質閘道核准程式,卻發生意外問題,內容如下↓

    -------------------------------------------------<開始>-----------------------------------------------------------------------

    C:\Program Files\System Center Operations Manager 2007>Microsoft.EnterpriseManag
    ement.GatewayApprovalTool.exe /lab-scom.lab.com /lab2-ad.lab2.com

    Unhandled Exception: System.IO.FileNotFoundException: Could not load file or ass
    embly 'Microsoft.Mom.DataAccessLayer, Version=6.0.4900.0, Culture=neutral, Publi
    cKeyToken=31bf3856ad364e35' or one of its dependencies. 系統找不到指定的檔案。
    File name: 'Microsoft.Mom.DataAccessLayer, Version=6.0.4900.0, Culture=neutral,
    PublicKeyToken=31bf3856ad364e35'
       at GatewayInsertionTool.Program.Main(String[] args)

    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\M
    icrosoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure lo
    gging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fus
    ion!EnableLog].

    ---------------------------------------------------<結束>-----------------------------------------------------------------------

                      查詢event,查閱的原因如下列網址
    http://www.eventid.net/display.asp?eventid=1000&eventno=3975&source=.NET%20Runtime%20Error&phase=1

                      接下來就無法往下步驟繼續了...

                      由於我是使用Virtual PC來執行LAB,是否是虛擬機器的限制?是否須使用實體機器測試?

     

    以上落落長的發問文,只希望各位老師更加明白我要表達的問題,請各位老師幫幫忙指點,謝謝!

    2008年1月24日 上午 10:01

解答

  • Hi Jesse,

     

    針對前二個問題,與您分享我的經驗:

     

    1.在相同Active Directory中,要如何將管理群組原則加入AD讓網域中成員手動安裝時可以抓到?

    Ref: 請參考http://www.systemcenterforum.org/howto/#133的設定方式

     

    2.手動設定方式安裝,SCOM有抓到看似可以動作,狀態卻顯示灰色,如何解決呢?

    Ref: 請問有捉到但狀態是灰色的描述,對應到SCOM Console指的是在Administration/Device Management/Agent Managed中看到灰色的燈號嗎?

     

    (1) 如果是,最常見的是Agent沒有正常回報訊號,通常從Agent端的OperationsManager事件檢視器就可以找到問題。

    (2) 另外,在開啟Console時,可以先試著下c:\program files\system center operations manager 2007\microsoft.mom.ui.console.exe /clearcache的參數清cache,可以排除是因為cache造成的資訊不一致現像

    (3) 如果不是,那就要看你指的狀態是灰色的地方在那一層,因為SCOM的監控對像是應用程式的邏輯組成元件,例如Windows Server 2003 OS或Exchange 2003 Role,每一個邏輯元件都會有對應的狀態,所以要先知道灰色的狀態是屬於那個元件,才能判斷問題所在。

     

    希望以上的資訊對你有幫助,謝謝

     

    Best Regards,

    Rico

     

     

    2008年1月27日 上午 04:52

所有回覆

  • Hi Jesse,

     

    針對前二個問題,與您分享我的經驗:

     

    1.在相同Active Directory中,要如何將管理群組原則加入AD讓網域中成員手動安裝時可以抓到?

    Ref: 請參考http://www.systemcenterforum.org/howto/#133的設定方式

     

    2.手動設定方式安裝,SCOM有抓到看似可以動作,狀態卻顯示灰色,如何解決呢?

    Ref: 請問有捉到但狀態是灰色的描述,對應到SCOM Console指的是在Administration/Device Management/Agent Managed中看到灰色的燈號嗎?

     

    (1) 如果是,最常見的是Agent沒有正常回報訊號,通常從Agent端的OperationsManager事件檢視器就可以找到問題。

    (2) 另外,在開啟Console時,可以先試著下c:\program files\system center operations manager 2007\microsoft.mom.ui.console.exe /clearcache的參數清cache,可以排除是因為cache造成的資訊不一致現像

    (3) 如果不是,那就要看你指的狀態是灰色的地方在那一層,因為SCOM的監控對像是應用程式的邏輯組成元件,例如Windows Server 2003 OS或Exchange 2003 Role,每一個邏輯元件都會有對應的狀態,所以要先知道灰色的狀態是屬於那個元件,才能判斷問題所在。

     

    希望以上的資訊對你有幫助,謝謝

     

    Best Regards,

    Rico

     

     

    2008年1月27日 上午 04:52
  • Hi Rico:

    感謝您的解答,Console 灰色狀態的問題已順利解決

    可能是我當時LAB的效能、網路狀態忙碌狀態以致對應不同步

    隔天即正常顯示了:

    (2) 另外,在開啟Console時,可以先試著下c:\program files\system center operations manager 2007\microsoft.mom.ui.console.exe /clearcache的參數清cache,可以排除是因為cache造成的資訊不一致現像

    您的這個方式,應可解決那時當下的問題,非常感激!

     

    另外感謝您額外提供的SOP,對我幫助非常大,感恩!

     

    Best Regards,

     

    Jesse Chang

    2008年1月28日 上午 02:50
  • Hi Jesse,

     

    很高興提供的資訊對你有幫助。

     

    就實務上的使用,我們發現SCOM Console背景refresh的速度並不是那麼即時,所以有時候你會發現燈號不準,或在操作Console時,跳出error警告,例如:在close alert時,會跳出資料索引錯誤類似的訊息。這是因為在操作這個動作的同時,所看到的資料不是最新的,而是console端本身的cache。這時候,就建議把console關掉,然後下/clearcache參數開啟,可以確保看到的是最近的資料。

     

    至於能解決那時當下的問題,由於你的狀況是Hardware Performance的issue導致延遲回報,所以下這個參數的效果可能沒有那麼明顯。

     

    希望以上對你有幫助,如果還有其它SCOM的問題,也歡迎你提出來討論,謝謝。

     

    Best Regards,

    Rico

     

    2008年1月29日 上午 12:48