none
安裝Exchange 2010 SP1發生"無法將指定的組態檔案下載成XML文件" RRS feed

  • 問題

  • Dear 前輩們:
    近日在測試Exchange 2010安裝,環境是2台Windows Server 2008 R2 SP1
    一台當DC,一台加入網域(member server)拿來安裝Exchange 2010(記憶體設定為4G)
    安裝前執行以下動作
    1.安裝IIS且勾選安裝所有功能,並安裝[.NET Framework 3.5.1 功能]
    2.安裝FilterPackx64.exe
    3.調整NetTcpPortSharing服務到自動後重新開機
    4.執行ServerManagerCmd -i RSAT-ADDS後重新開機2次

    在Exchange 2010 SP1安裝過程中,有勾選"自動安裝Exchange Server需要的Windows Server角色及功能"選項

    但最後會出現如下圖的錯誤

    2012年7月27日 下午 04:58

所有回覆

  • 這是因為您在此Windows Server 2008 R2 的預先準備尚未完成導致的現象

    依照附圖所示, 您想要安裝集線傳輸、用戶端存取、整合通訊、信箱這四個角色, 需要執行以下指令:

    1. 以管理者身分開啟Windows PowerShell

    2. Import-Module ServerManager

    3. Add-WindowsFeature NET-Framework,RSAT-ADDS,Web-Server,Web-Basic-Auth,Web-Windows-Auth,Web-Metabase,Web-Net-Ext,Web-Lgcy-Mgmt-Console,WAS-Process-Model,RSAT-Web-Server,Web-ISAPI-Ext,Web-Digest-Auth,Web-Dyn-Compression,NET-HTTP-Activation,RPC-Over-HTTP-Proxy,Desktop-Experience -Restart

    2012年7月30日 上午 08:50
  • 建議先參考 TechNet 文件庫的資料:Exchange 2010 必要條件
    其中有一節為「安裝 Windows Server 2008 R2 作業系統必要條件」,
    確認所需的元件及指令都有正確安裝及執行。

    蘇老碎碎念
    資訊無涯,回頭已不見岸
    好用的微軟技術支援小工具
    Facebook - 微軟台灣官方論壇愛好者俱樂部
    如何在論壇正確發問,請參考iThome的文章: 如何問到我要的答案

    2012年7月31日 上午 03:13
    版主
  • 前輩,您好:
    後來我使用VMware Workstation將環境打掉重做,一樣開一台AD,一台拿來裝Exchange
    Exchange加入AD後使用Domain Admin身分登入並執行以下步驟
    1.安裝IIS且勾選安裝所有功能,並安裝[.NET Framework 3.5.1 功能] 以及ISE
    2.安裝FilterPackx64.exe
    3.調整NetTcpPortSharing服務到自動後重新開機
    4.以管理者身分開啟Windows PowerShell並分別執行以下指令
    Import-Module ServerManager
    Add-WindowsFeature NET-Framework,RSAT-ADDS,Web-Server,Web-Basic-Auth,Web-Windows-Auth,Web-Metabase,Web-Net-Ext,Web-Lgcy-Mgmt-Console,WAS-Process-Model,RSAT-Web-Server,Web-ISAPI-Ext,Web-Digest-Auth,Web-Dyn-Compression,NET-HTTP-Activation,RPC-Over-HTTP-Proxy,Desktop-Experience -Restart

    但還是遇到如上圖同樣的錯誤...................
    還請前輩不吝指教,感謝您
    2012年8月2日 下午 02:28
  • Hi

    您安裝的帳號具有Schema Admins跟Enterprise Admins 的權限嗎?

    以及,請試著將UAC關閉試看看


    Best Regards, Daniel Liang


    2012年8月2日 下午 02:52
  • 前輩,您好:

    我是使用AD的網域管理者帳號登入去做安裝的,且本來UAC就是關閉的,所以原則上應該沒問題,另外我有嘗試安裝RTM版本的Exchange,是沒有問題的,只是無法開管理主控台....

    2012年8月2日 下午 03:29
  • Hi

    有嘗試過在RTM版本升級成SP1嗎?

    Exchange 2010 Service Pack 1可以在這裡下載Microsoft Exchange Server 2010 Service Pack 1 (SP1)

    以及,您RTM版本安裝後管理主控台無法開啟,錯誤訊息是無法連線到AD嗎?


    Best Regards, Daniel Liang

    • 已提議為解答 AChange 2012年8月3日 上午 02:02
    2012年8月2日 下午 04:07
  • 前輩,您好:

    錯誤訊息如下....  我會嘗試看看升級至SP1看看的...

    2012年8月2日 下午 05:00
  • Hi

    照這個錯誤訊息,我會建議您相關的ISO及安裝檔都重新再下載一次

    Microsoft Exchange Server 2010 Service Pack 1 (SP1)

    Windows Server 2008 R2 含 Service Pack 1

    請都下載英文版的試試看,因為試用版本的Windows Server 2008 R2並沒有繁體中文


    Best Regards, Daniel Liang

    2012年8月3日 上午 02:36
  • Hi virgil0711

    請問你AD有先擴充Schema 嗎? 

    放入Exchange 光碟或mount ISO後輸入以下指令

    setup.com /ps

    Setup.com /p /OrganizationName:"輸入組識名稱"

    setup.com /pad

    這是架Exchange Server的第一個動作,因為上面敘述都沒看到有做這個,所以我好奇問看看

    • 已編輯 陳大至 2012年8月3日 上午 03:56
    2012年8月3日 上午 03:52
  • 前輩,您好:

    所以我要到DC上面去下這些指令是嗎?

    可是我查了一些文章,不是說在安裝的時候,光碟片會自動去擴充schema ???

    無論如何,我重新rebuild新的環境,打掉重做測試看看

    然後再將測試狀況回報給您

    感謝您的回覆


    • 已編輯 virgil0711 2012年8月4日 下午 01:44
    2012年8月4日 下午 01:39
  • 前輩,您好:

    我嘗試至DC上面去擴充schema

    但碰到的狀況是一樣的

    如下圖........

    2012年8月4日 下午 02:02